A7N8X-E Deluxe and RAID card

I recently purchased a Promise FastTrak 4310 RAID card to hook my 4 400GB drives up into a RAID 5 setup. The card works just fine in Windows and such, it's booting into windows where I'm having problems.

When I start the computer it will get to the point of right before loading Windows XP and it sits there. If I unplug two of the SATA cables and force the array to go offline it will boot. During boot I just simply plug the two cables back in and everything is fine.

Is there some setting in BIOS somewhere I'm missing that will tell it to ignore the card and just boot off my regular IDE drive that Windows XP is currently stored on?
17 answers Last reply
More about a7n8x deluxe raid card
  1. Both already got BIOS updates so I know that isn't it. Will switching the board around so it gets a different IRQ really work?
  2. I'll have to swap it and my wireless card to see if it works when I get home.
  3. Yeah, that didn't fix it one bit.
  4. I just bought a Fasttrak 4310 to add 4 300 GB HDs in RAID5.
    I already have 2 200 GB HDs in RAID0 on the onboard SI raid controller.
    I have a A7N8X Deluxe mobo (not exactly the same as yours).

    I've got the same problem (WinXP won't start if the raid5 is functionnal) and I was wondering if you found a way to fix the problem :?:
  5. Nope. Still can't figure out how the hell to get it to boot. I just unplug two of the drives before it gets to the raid card. As soon as it bitches that the drive is in mega danger I plug the drives back in and it loads Windows just fine.

    Absolute bitch to deal with every time I just simply want to reboot or whatnot.
  6. My server is now up...

    I found out that my mobo won't support more than 8 active ATA or SATA devices.

    I found that out when I inverted the boot order and discovered that only half my raid cluster could be detected even with all the cable plugged. So when I disconnected some CD-Rom drives and my raid just went fine.

    I now have 4 HD in raid5, 2HDs in raid0 and 2 CD-Rom drives.
    If I add 1 HD or 1 CD-Rom, I lose something on one of my raids depending of the boot order (last get kicked).

    I used to have the 2HDs, 1 old Maxtor and 2 CD-Rom. When I tried to add 4 new HDs I couldn't make them all work...
    Seperatly they all worked fine...

    I had the choice between removing a CD-Rom drive or the old Maxtor and guess who went away :D
  7. really.... interesting. makes sense seeing as i have the 4 sata drives in the raid 5, two cd roms drives, and two plain hard drives.

    i'm gonna unplug a cd drive when i get home and see what happens
  8. This topic got me worried. I intend to build a fileserver and intend to have 12 sataII disk, i thought 4onboard and 2xraid controler. And some mobo's accept only 8 drives? Where can one find max drive for mobo info?

    Anyone knows a mobo that would accept 12 drives?
  9. I found that out only by atttempting random tests...

    I never saw any documentation about it anywhere...

    It could be a limitation of the A7N8X series :?:
  10. SHv2 i have the same problem than you.
    I have bought this card fasttrak TX4310 with 4 HDD Hitachi 250 Go SATA2

    -When i build my RAID 5 with 3 HDD all work fine

    -When i build or just want to boot with 4 HDD on the card, the windows doesn't start....

    Can't understand...

    no power supply problem, i 'have tried differents graphics card, another powersupply (i already have a 430W PSU)
    My Mother board is a standard Asrock KT7 Pro with 512 Mo RAM
    and an Athlon 2400+ processor.

    I don't know how to make it work.
    I'm going to upgrade the card firmware but the changelog doesn't deal with this problem...

    Somebody have a solution?
  11. the only way to make it boot is to unplug two of the drives. once windows start loading you can plug them back in and it should all work. major pain in the ass to have to deal with though, especially knowing i still have 2 open sata ports on the mobo still.
  12. I'm agree with you... i'm on my nerve with this card... they don't even tested it 8O :lol:

    I have contacted their service and talked to somebody during 20/25mins and he wanted to know everything he could about this problem. I think they are interested in and i think that if you and other people send us notifications about this problem, we could go further.

    First launch a request Here, explaining you'r problem:
    [Iexplorer requiered] https://support.promise.com/support/

    And next call this number , you should be able to explain clearly the problem:
    31(0) 40-235-2600


    The test they gave to me to do was to disable Write Cache on each disc.. i'have done it but nothing change.
    It appears that if you plug 4 drives on the card and try to boot... you can't... (perhaps it deals with RAID 5...) That's all.
    I hope everybody will contact Promise Corp!!
  13. still waiting on a response from them... wow they're slow...
  14. Yeah, they'r really slow but we are at least two persons requiring assistance :)
    not a bad point.
    I hope they will heard us and repair the problem.

    ps: i'm waiting their answer too, they have told me they have "escaladated" my request ... :)
  15. hat that means is it's on the fast track to the recycle bin :P
  16. oh nice :)
    i'll wait and see what will happen ^^
  17. I had the same problem with the TX4310 and my A7N8X-E Deluxe. After I updated the BIOS of both, I found that if I disabled the "Boot Priority" setting in the BIOS of the motherboard (it's in the menu right after the boot order), the system worked perfectly! I also have disabled the onboard SATA controller, so I don't know if that will affect anything.

    Hope this helps!
Ask a new question

Read More

Asus NAS / RAID Boot Windows XP Motherboards