Sign in with
Sign up | Sign in
Your question

Prolly a Noob Q, but Need Help with RAID 1 Data Set

Last response: in Storage
Share
June 21, 2006 8:56:32 PM

First, I do NOT know if my dad's PC is using software or hardware RAID. I do know upon bootup, that a blue or red image that states SATARaid loads on his startup. When I open the configuration utility, it gives me information about the rebuild speeds (low to high), the sets, etc. Also, I have tried entering the RAID utility that shows up while the PC boots, and all it tells me is the RAID 1 set, the HDDs, and some other stuff.

Problem: Just recently, the program has been showing up as red (meaning rebuilding). However, I have looked at the sets, and no matter how much time I have given it, the "curent" rebuild has not even passed 0% (I even tried the rebuild rate at the highest setting for a couple hours)

Can anyone shed any light onto this issue? Thanks.

And oh, the HDDs in RAID 1 are: 2x80Gb Western Digital SATA150 Drives. His PC is basically like my sig, except a Athlon XP 3200+ and 1Gb of RAM.
a b G Storage
June 22, 2006 1:47:25 PM

Sounds like one of the drives is bad and needs replaced. There should be a log or something that will tell you which drive is bad. Look again through the setup and see if anything is in there.
June 22, 2006 2:50:59 PM

Your dad's lucky he was using mirrored RAID rather than striped.
Related resources
June 23, 2006 3:34:16 AM

Well, I looked at the logs before (sorry I didn't post this earlier). There was actually a LOT of errors around 4-16-06. Then the rest of the logs said how the utility worked fine (rebuilds worked after that date). Then about a week ago, another log report recorded something about a channel or whatever (I'm not on his PC right now) being addressed "WRONG". I've looked through the logs and haven't read anything about a bad drive.

Anyways, thanks for the replies. I plan to do a diagnostics check with one of WD's utilities (already got one on a floppy) after I get back from my trip.
June 26, 2006 5:23:02 PM

Anyways, I ran WD's Diagnostic Tool and its "Extended Test" and NO errors were found... Also, I have NOT received any SMART warnings or anything so I do not think it's a bad HDD (if there's another way to test it, can you tell me???)

Rebuilds still do NOT want to rebuild. Here is a list of the past errors on his system:

4/10/06: "Port Error- Aborted. Erro occured on Channel 0 device on adapter 1. Channel 0 - CDB 0x28 0x00 0x07 (etc. etc. )" (There were 11 of these errors)

4/17/06: More port errors, about 15 of them. Each Channel has a different code. (i.e. instead of the third # as 0x07 it's 0x08, 0x06, etc. )

6/16/06: This was NOT in the "Error" log. In the "Event Viewer", its says "RAID polling status from array set ******* RAID: card idx 1. array idx 0. RAID: result WRONG"

So what should I do? And thanks to those who spend the time to read this crap.
a b G Storage
June 27, 2006 1:47:01 AM

Backup what you can if at all.
Since the drives tested ok, I guess its possible that the controllor is making errors. Might even be bad cables. Try different cables. Reseat the raid card (if its using an add-in card).
Take a look at the motherboard and see where the drives are connected to determine card or not.
If its software raid then not much can be done other than trying new cables, although it still could be a bad controllor.
June 27, 2006 3:29:46 AM

It's using the onboard RAID controller on the ASUS A7N8X-E Deluxe. How do I find out if it's using software RAID? I know that the guy who built it installed that Java SataRAID software, but when I boot up the PC, I can actually enter the hardware RAID controller and it sees the 2 HDDs as a RAID 1 set....

Cables can really make a difference huh? Well, I don't really have anymore but one. I'll try that when I can get the time. Thanks.
!