Sign in with
Sign up | Sign in
Your question

New OFFICIAL ForceWare driver release! Woot!

Last response: in Graphics & Displays
Share
June 23, 2006 10:23:02 PM

Look:

http://www.nvidia.com/object/winxp_2k_91.31.html

Another interesting couple of things--it, like the previous 90 beta driver, has release notes that mention it supports the 7600GS in PCI-E AND AGP...good news there, but we gotta couple of new ones, too: The 7300 SE and the 7500 LE (both are PCI-E only). Any word about those, guys?
June 23, 2006 10:44:16 PM

I've been using the beta release 90 for awhile.
June 23, 2006 10:56:20 PM

As have I. The reason I put the word official in caps is because this is the first "OFFICIAL" release of the Forceware 90 driver.

I'll upgrade tonight I suppose, though the beta release works fine on my card too.
Related resources
June 24, 2006 3:00:09 AM

I hate the new control panel ¬¬
Much Vista-like, too many clicks, too many menus.
Just sucks.
Newbie-user friendly, but not power-user friendly.

Is there anyway to use the new drivers, but with the classic control panel? 8O
June 24, 2006 3:52:36 AM

Yes. Can't remember exactly how at the current time, though :roll:
June 24, 2006 4:41:01 AM

You can enable clasic style which was nice to see but the drivers work great been using them for awhile too
June 25, 2006 1:18:04 AM

Ive been hearing some bad things about these drivers. Have all of you had good experiences? Im wary of updating.
June 25, 2006 7:48:39 PM

Quote:
Ive been hearing some bad things about these drivers. Have all of you had good experiences? Im wary of updating.


I'm using them now on that lousy card listed in my sig...no problems. Control panel wasn't hard to get used to for me, but then again I don't use it a whole lot anyway. I'm not a super-gamer, so let me just tell you what I do have and play:

Command and Conquer Generals: Zero Hour: Plays fine wih almost all recent drivers, except one of the early 8x.xx versions.

Star Wars Knights of the Old Republic: Played fine with the original 77.77 drivers, and then all but the latest of the 8x.xx had super-problems with it. They caused major lag (like <1fps at all settings). Again, 91.31 works fine.

WoW: All versions I've played work perfectly fine, although I did hear of problems when using geforce 6800s with the 7x.xx drivers. I've actually noticed slight improvement with this game using 91.31, unlike the others.

Halo PC: All versions except for 81.87 worked fine on this game. 91.31 improved performance a little bit (I found that completely unexpected too...DirectX 9.0a gen game has improvement???) as well.

Star Wars: Empire At War: All drivers work fine, old and new.

So for me, the 91.31 drivers work flawlessly, although granted I have a 6600 AGP card that's just a tad dated, and I'm not playing Oblivion or anything.
June 26, 2006 12:33:33 AM

8O 40MB?!, is that cause of the new control panel? it better speed things up not slow things down lol.
June 26, 2006 3:47:47 AM

I had a big problem with these drivers that were just released. I can play games just fine, but if i try to play any movie file type, my cpu usage hits 100 percent and the file never opens. I have a 7800gs agp card.

I reverted back to my older drivers, which are 84.xxx, and the movies play again. dont know why i cant play movie files with the new drivers.
June 26, 2006 12:12:46 PM

Quote:
I had a big problem with these drivers that were just released. I can play games just fine, but if i try to play any movie file type, my cpu usage hits 100 percent and the file never opens. I have a 7800gs agp card.

I reverted back to my older drivers, which are 84.xxx, and the movies play again. dont know why i cant play movie files with the new drivers.


I remember the notes mention a fix with version 91.31 from 91.28 regarding movies of certain bit-rates. You tried that one, not just the version 91.28 beta, right?
June 26, 2006 12:44:43 PM

Well I tried the beta forceware 90 when it came out and I immediately switched back to my 89 drivers for one reason, it crashed Lineage II. Every single time (even after proper restarts) the game could not get to the log in screen. It would show the splash screen, try and get to the login screen and just crash. So i reverted back and it worked perfectly fine, so until I see something about that bug being fixed, I am staying away from Forceware 9X.

Prob just a fluke on my system, but hey... it doesn't work for me heh.
June 26, 2006 6:44:40 PM

the drivers i had were the 91.31 drivers. I never tried the beta drivers. I had downloaded these drivers on saturday. I guess i will wait for them to update them again. I will stick with my pre 9x.xx drivers until then.
June 26, 2006 11:52:10 PM

Im using the 91.28 beta and it seems to be working fine, no issues at all. Although it was actually the 91.31 driver that cause me problems so i just went one back and all is fine. Correct if im wrong but im pretty sure that version 91.28 is basically the same as 91.31 exept only difference is that 31 has support for the 7950 GPUs.
June 27, 2006 12:56:05 AM

All of the 9x.xx and some of the later beta 80's did. Now as for how well the 91.31 works well from all looks they are the same as the beta 91.31 that came out at the start of the month and some people have nasty bugs with them.INFO

"cannot SLI because no multiple GPU detected" bubble error seems to be the more common errors that happen and to fix that you need to use reg edit and in that thread is posted how to do it.
June 27, 2006 12:58:07 AM

Interesting, I will give it a try... :wink:
June 27, 2006 11:24:13 AM

Quote:
"cannot SLI because no multiple GPU detected" bubble error seems to be the more common errors that happen and to fix that you need to use reg edit and in that thread is posted how to do it.
Yeah thats exactly the bug that was bothering me, and which caused me to go to 91.28 which is really stable. Anyway thanks for that link, least i know that i can go to version 91.31 anytime now.
June 27, 2006 12:10:09 PM

Thanks for the info.
June 27, 2006 12:38:07 PM

So...no word about those two new cards then? Not that the sound any good at all... :?
June 27, 2006 12:44:54 PM

Everything works fine on my SLI 7800GTX and no problems so far. I can't view my GPU temps anymore but I got the NvMonitor to do that now. Performance wise I'm yet to try it to runs with FEAR benchmark.
June 27, 2006 4:28:31 PM

bah humbug,

if you have the 84.21 whql drivers you don't need these new drivers. unless you have one of the newer cards it supports.

people think all these driver releases push more power out of there existing cards. bah humbug. they only fix problems with newer software (maybe). and these drivers are bull***t.

why is it that video drivers that claim to adhere to directx standards have to issue bug fixes for their drivers because of compatability problems?
fooeeyy. the xbox anyone? tell me. what is going on here with 100s of driver releases since nvidia became the king. you don't see as many driver releases on ATI cards.


regards,

JJ+ :oops: 
!