power supply problems?

I'm a newbie building a computer, so be gentle. I purchased Antec TC 2.0 power supply and am trying to connect. When I turn on power supply the green light on mobo (ASUS A8n32 sli-dlx) lights but power supply fan doesn't start, no mobo fans start, no fan on my spankin new 7900GTX (I have connected 6 pin to card) and no video output. What's up? could the PS be bad. I've also tried a new silverstone zeus with same results. They can't both be bad can they? What the f is up? I've worked w/computers before but never built from ground up so I'm kinda new to PS area and am getting concerned. Please help!

thanx
3 answers Last reply
More about power supply problems
  1. did you plug every connector on the mother board in.
  2. I plugged in the 24 pin and the 4pin to mobo. I have an "EZ_PLUG" on mobo but manual states not needed if video card has 6pin, which it does and is connected. Shouldn't the fan be spinning on the power supply or the Video card or the mobo at least? With both power supply's I get no indication of any power except the damn green light on mobo. It seems like something else should be kicking in.
  3. Quote:
    I'm a newbie building a computer, so be gentle. I purchased Antec TC 2.0 power supply and am trying to connect. When I turn on power supply the green light on mobo (ASUS A8n32 sli-dlx) lights but power supply fan doesn't start, no mobo fans start, no fan on my spankin new 7900GTX (I have connected 6 pin to card) and no video output. What's up? could the PS be bad. I've also tried a new silverstone zeus with same results. They can't both be bad can they? What the f is up? I've worked w/computers before but never built from ground up so I'm kinda new to PS area and am getting concerned. Please help!

    thanx


    You didn't mention you have the power switch to you case hooked up. Also, the power switch on you case may be dislodged or bad. Make sure the power switch on your case is making contact.
Ask a new question

Read More

Power Supplies Components