Sign-in / Sign-up
Your question

320GB Western Digital seen as 130GB on Asrock K7S41 Mobo

Tags:
  • Western Digital
  • ASrock
  • Motherboards
  • Storage
Last response: in Storage
July 8, 2006 6:14:45 PM

I've had a 200gb on this motherboard before, and it recognized it as one.. However, I've tried 2 different 320gb WD's, and both are seen as 130GB.. I've updated the bios to the latest (2.40), and still no luck. I can't find anything on their website about it. Anyone have any ideas?
Thanks in advance.

More about : 320gb western digital 130gb asrock k7s41 mobo

a b V Motherboard
a b G Storage
July 8, 2006 6:31:07 PM

Got LBA enabled for this new drive in the BIOS? And XP with SP2 installed as well?
July 8, 2006 6:38:32 PM

(Actually it's a customer's), but no, he loaded w/ old version of xp pro (no sp2), and didn't check LBA in bios. Called and left him a message to check that.. Strange though, since he did have a working 200gb in it before.
Everest32 sees it as the correct model #wd3200jb or whatever, but only as a 130gb hd. Asrock bios doesn't display size of drive, just that it's there.
Thanks for the reply.
a b V Motherboard
a b G Storage
July 8, 2006 7:27:31 PM

Everest isn't reading the size properly because it reads what is detected by the BIOS. If LBA isn't enabled.... it won't see the full capacity (genreally 137GB). It doesn't matter that the BIOS doesn't actually give you the size of the drive, but it still checks the drive for it's capacity anyway.

Edit: The 200GB drive he had in there was probably seen to it's full capacity because the manufacturer provided a program to format the drive and turn on LBA at the same time (the user would not have seen the program enabling LBA, it would have just done it). Maxtor provides such a utility, called Maxblast. Other manufacturers probably provide the same kind of utility.