Sign in with
Sign up | Sign in
Your question

SATA & IDE drives

Last response: in Storage
Share
July 9, 2006 1:28:44 AM

i have SATA drive as master and try to install IDE drive as slave, but my machine sees only IDE drive and tells that there's no master drive. is anybody knows how to configure it to able to use both?
Thanks in advance.

More about : sata ide drives

July 9, 2006 1:52:02 AM

what board do you have, did you activate the SATA in the bios? what is your complete system specs?
July 9, 2006 2:02:03 AM

I had problems like that too, to fix it I had to install Windows with only the SATA plugged in (using the motherboard SATA drivers of course). Then after Windows was installed I plugged in the IDE. This has always fixed all the odd drive detection problems for me. I hope your issue is as simple.

EDIT: Also, it could be a problem setting your IDE drive to slave if its the only drive on the cable. Also could be that RAID is enabled in the bios.
Related resources
July 9, 2006 2:08:42 AM

sorry, forgot...here it is
Mobo: ASUS A8N-SLI
RAM: 2GB
Video: NVidia GeForce 7900 GTX
CPU: AMD Athlon 4800 2.42GHz 64X2 Dual Core
I have Seagate 280GB SATA(setup as master) with my OS on it and another Seagate Barracuda ATA IV 80GB setup as Slave. I have Western Digital Caviar IDE 200GB which I want to put instead of my Barracuda 80GB, but like I said CMOS sees only Barracuda and says that no Master
July 9, 2006 3:16:55 AM

thanks...i'll check my bios setup for that
July 9, 2006 5:17:55 AM

Looking at the new info you've provided, did you setup your new Western Digital to be master?

This might be your problem.
July 9, 2006 6:13:56 AM

Quote:
sorry, forgot...here it is
Mobo: ASUS A8N-SLI
RAM: 2GB
Video: NVidia GeForce 7900 GTX
CPU: AMD Athlon 4800 2.42GHz 64X2 Dual Core
I have Seagate 280GB SATA(setup as master) with my OS on it and another Seagate Barracuda ATA IV 80GB setup as Slave. I have Western Digital Caviar IDE 200GB which I want to put instead of my Barracuda 80GB, but like I said CMOS sees only Barracuda and says that no Master


Your system setup is nearly identical to the one I built for my wife. Our MB is ASUS's A8N-SLI Premium w/WD SE 16 400 GB SATA HDD and a pair of PX-716 SATA DVD burners. However, I didn't experience the problem you're having.

You'll have to correct me if I am wrong here, but I think SATA drives don't use jumpers. If they do, make sure you set it correctly.

Secondly, if you have a SATA drive AND an IDE drive in your system, your IDE drive will need to be set as a MASTER drive on the IDE channel. Make sure the jumper on the IDE drive is set to MASTER and NOT Slave or Cable Select (CS). In other words, pretend like your SATA drive is non-existent (just like your PC is doing).

One IDE channel can have a master and slave device attached. Each device needs its jumper set correctly. Two IDE channels and 4 IDE devices = 2 Master (primary and secondary) and 2 Slave devices (also primary and secondary).

So, regardless of the SATA devices you have in your system, your IDE devices need to be set-up normally. Like I said, I don't think SATA uses jumpers, so it's done automatically- well, you set the master SATA drive in your BIOS.
July 9, 2006 6:36:06 AM

Quote:
thanks...i'll check my bios setup for that


I am looking at the manual for your MB right now. It says that SATA connectors 1 and 2 are used for SATA BOOT devices, while 3 and 4 are for DATA drives.

As you look at your motherboard when it is installed in your PC, SATA 1 is the one in the lower right, SATA 2 is the lower left, SATA 3 is above SATA 1, and SATA 4 is above SATA 2.

So, your SATA drive should be plugged into the lower right hand SATA port (SATA 1).

Also, make sure your BIOS settings have the RAID controller turned OFF if you aren't using RAID.
July 9, 2006 12:16:49 PM

thanks NewbieTechGod ! i'll check it out if it's set correctly.
July 9, 2006 1:40:49 PM

While you are in the BIOS SET your BOOT ORDER to boot from the SATA drive 1st then the IDE.

When the BIOS scan the hardware it detects the IDE buss 1st.
July 9, 2006 7:32:23 PM

thanks a lot...it worked! only i had to do is set my IDE drive to master.
!