Sign in with
Sign up | Sign in
Your question

Why does PC auto-restart after Win shut-down?? BIOS Error?

Last response: in Systems
Share
July 14, 2006 1:36:59 PM

Okay... I'm wringing my hands trying to solve this problem. I use the PCSTATS forum a lot but no one there has an answer... so here I am with my first post :) 

Long story short:

1) A couple weeks ago my PC went on the fritz. Suspected memory issues, ran Memtest on my DIMMS, and one was faulty. Pulled it out for an RMA, went with the one good stick, reset CMOS, off I go.

2) Fixed my major "fritz" problems, but now my PC will automatically reboot after a Windows shutdown. Even if I power on my PC, and press the power button to turn it off during the boot sequence, it will turn off for a second or two, "click", then power on (this is what happens with my Win shutdown too).

3) I've checked the advanced tab of my network card (nVidia built-in LAN) and disabled all the "wakeon" crap. Did the same in my BIOS settings (all the Power settings are disabled).

I have no idea what's going on. My system specs are below. I'm wondering if it's (1) my mobo going bad (could a goofed up mobo cause my RAM to go bad and this booting/power issue?), or (2) a virus (I know this makes no sense but I'm so lost).

I don't know what else to do. Any and all help / suggestions == really appreciated!!!

-- Athlon 4400+ x2
-- Antec Smartpower 450
-- eVGA 7800 GT CO SE
-- aBit A8N SLI mobo
-- Audiomax sound card (from abit)
-- G.Skill RAM (one DIMM now, had 2x1GB sticks)
-- Raptor 72GB HD / Maxtor 200GB HD for storage
-- Samsung DVD-RW
-- WinXP Professional

That's it. No OC'ing or anything.

More about : auto restart win shut bios error

July 14, 2006 2:18:35 PM

There is a registry entry you can change that may fix this. Google 'xp restarts after shutdown' and look around. I don't have a link, but I've found it and fixed it on a couple machines.

When I have time I'll do a search for it, but it will be found on google.
Related resources
July 14, 2006 3:07:02 PM

See if anything in here helps.

I think this is the registry entry I changed to fix the problem, but as outlined on this page, some people were unable to boot after using it, so proceed at your own risk:

Start Regedit and navigate to
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon
Set the value of PowerDownAfterShutdown to 1.
July 14, 2006 3:27:21 PM

Here's my question though... if I power down using the power button on my case during the boot sequence (ie., at my mobo logo screen, before the OS is even getting loaded) -- and it STILL restarts... can this reasonably be presumed to be a Windows registry issue?

I'm starting to wonder if my mobo is bad, or if the PSU is bad, or if my mobo maybe doesn't like my matched pair DIMM stick without the second matched pair (I only have one DIMM in now, as I am awaiting a replacement for the second which went bad on me).
July 14, 2006 3:43:11 PM

I'm a little confused now. When you attempt to halt the reboot via power button during post, aftet xx Seconds the system still boots? If this is the case, your f-panel my be connected wrong.
July 14, 2006 4:01:21 PM

Let me ask you something. If the machine powers off, and then restarts, then why is that a windows problems or a registry setting? That's what was happening to me, and I fixed it with a registry setting.

Why don't you check out some of those possible fixes I linked and see if they help. Long gone are the days where I try to understand every little thing. I simply don't have the time or energy for that, so if it were me, I would try some of the fixes you can find on google and see if they work.

BTW, I'm not trying to be an ass about it, but sometimes there is no logic in what you might think should be logical, so don't beat your head against sharp corners. If it works, it works, accept it. :wink:
July 14, 2006 4:20:23 PM

Have you tried clearing the CMOS then the Fail safe defaults in the BIOS? And f so, does this change the behavior at all? The last time I saw a problem similar to this, it turned out to be a faulty NIC believe it or not. I noticed the NIC stayed active inspite of the power state of the machine. I ripped her out and bam, normal operation except for networking ofcourse.

I would check the PSU connection to the Mobo too, I believe the SmartPower PSU's have a blue wired connector to monitor Temps and control fan speeds for case fans and chipset fans.

Also, is your case old? Maybe the dang power switch perished and no longer suppoorts shut downs LOL. So many possibilities, well I hope I at least gave you some more things to try. I would also recomend using a bootable CD like one of the BartPE discs to see if it's hardware or software related. http://www.nu2.nu/pebuilder/ Oh and have you tried the "Shutdown" command at a promt? Ex: shutdown -s Look at the event viewer for clues, does it power off correctly from Safe-Mode?
Good luck
BTW that registry setting was "Enable fast reboot 1" that addressed a similar issue in Win98SE (Machine would just restart instead of shutdown).
July 14, 2006 4:26:52 PM

Quote:
Let me ask you something. If the machine powers off, and then restarts, then why is that a windows problems or a registry setting? That's what was happening to me, and I fixed it with a registry setting.

BTW, I'm not trying to be an ass about it


Lol I know :)  I'm just to flustered with my damned PC that I keep hoping to narrow the problem down to some extent.

What's weird is that I only started to get this problem after my memory went on the fritz a couple weeks ago. It caused CTDs, BSOD restarts, etc. After memtest identified the culprit DIMM stick, I formatted & reloaded Windows. After those two events, I'm now getting this PC reboot error. So it's probably not the front panel connections (as they didn't change).

I'll try the registry edit; I just hate futzing with something that could cause my PC to not power on at all!

As to the NIC comment... I have built in ethernet on the aBit mobo so I can't rip it out. I could buy an ethernet card... but what a waste! I'll try looking to see if the green activity light is staying on when I power-down (haven't even thought of checking this yet). Also will try completely disabling the onboard LAN from the BIOS and see what that does.

Hopefully something will work!
July 14, 2006 4:46:42 PM

I would say it's still have software problem, the OS sends the kill command to the PSU with instructions to reboot or power down.

Try shutting down using your own command prompts form cmd.
July 14, 2006 5:09:22 PM

The thing is though... I can hear it powering down. It shuts off for a few seconds. Then it pops back on.

It's not as if it's shutting down... the instantly reboots?
July 14, 2006 5:25:43 PM

Quote:
The thing is though... I can hear it powering down. It shuts off for a few seconds. Then it pops back on.

It's not as if it's shutting down... the instantly reboots?


I still believe that its a software issue, you need to look at how an OS starts the systems up. Some are delayed so aren't W2k3 has staggered reboot. Some viruses can affect computers this way as well. Try using google some more.

To take the PSU off your mine, go to BB or COMPUSA and grab a PSU thats cheap, Toss it in, if you dont have the problem anymore, then there you go. If you do, keep it or return it and wait for a new one online. If you buy and return in the same day you shouldn't have any problems getting your $$ back. Its like borrowing.
July 14, 2006 5:58:01 PM

bnason:

Exact same problem with my setup. I have almost same PSU, except mine is a 550. My computer would start the shut down process, and right as it's ready to shut off, BAM!! It reboots. Even when I press the power button, it will reboot instead of shut down. I thought it was hardware. I checked all front panel wiring, unplugged all other peripherals excpet basics, cpu, ram, video.....still same thing.

Solution:

I didn't bother with all the hoopla with reg fixes and what not. Reinstalled Windows, works perfectly now.

Just my two cents, take it or leave it.

TTFN
July 14, 2006 6:04:07 PM

Quick tip. If it reboots before the os is even loaded then it may be the board.

unplug your HDD and try it again with waiting till it tells you that no is is loaded or fine then hit the power button. If it does it there then its your board or another piece of hardware. if not do the registry fix or do a repair of the windows install.
July 14, 2006 6:15:46 PM

Quote:
Quick tip. If it reboots before the os is even loaded then it may be the board.

unplug your HDD and try it again with waiting till it tells you that no is is loaded or fine then hit the power button. If it does it there then its your board or another piece of hardware. if not do the registry fix or do a repair of the windows install.

Good advice, just note that some virus's attack the bios and are not os Dependant after they are deployed. But that really a quick easy test, good on ya!
July 14, 2006 6:19:14 PM

I appreciate all the tips. Will a) do a heavy virus / trojan scan tonight, b) unplug my ethernet to see if that affects anything, c) try the registry tweaks, d) if all that fails, wait until I get my replacement memory sticks then uninstall/reinstall Windows. e) will be a new board/mobo as a last resort (I dread the time for replacing the mobo).

f) will involve me beating my computer mercilessly with a sledgehammer :p 

Will post an update tomorrow!
July 14, 2006 7:28:59 PM

There is one setting you may have over looked. In the BIOS power section there is a flag to have the pc restart on power failure. Make sure these advanced setting are correctly set.
July 15, 2006 3:20:53 PM

Okay... so I've narrowed this down, I think.

I did a full AV scan, spyware scan, and did find a keylogger (son of a b!!!!). Restarted; still would reboot automatically.

Pulled my ethernet cable. VOILA! It wouldn't restart.

Anyone have any thoughts :( ? All my power-on LAN settings are disabled.
July 15, 2006 3:36:39 PM

Seems I might have had a problem like that on a machine at work. I vaguely remember it. I think I might have just disabled the onboard nic and put in a card, or perhaps I just replaced the card that was in there, but I have a dozen cards laying around at work so it was an easy thing to test.

It falls into that catagory of things I don't try to understand, and if I had the time, energy and/or interest I would have investigated it further, but a different card fixed it, so I moved on. :wink:
July 15, 2006 4:30:08 PM

Well if you had one of those key loggers, you should do a root scan too. Did you run highjackthis, and statuplist? More than likely you have more than just the one.
July 15, 2006 10:00:54 PM

Wouldn't Trend Micro catch anything else? Did a full scan with it and Spyware Dr.
July 15, 2006 10:16:50 PM

NO, It takes special programs to scan the root. These app run at the core level and are hidden from all scaners.

Here is a link to Rootkitrevealer
July 15, 2006 10:59:42 PM

If there is a setting called something like
"power state after power failure"
Set it to "always off" or just "off"

If that doesn't help, Me thinks PSU, friend got the same thing, his computer will boot suddenly several minutes after being turned off.
July 16, 2006 5:37:33 PM

ARGH! So now it is still won't turn off even without the ethernet plugged in.

Tried loading failsafe settings in the BIOS, turned off all the power options (including the "After restart --> power state off" one). Nothing works.

Going to wait until I get my two good sticks of RAM, check all my power connections, see if it still happens, if so, reinstall Windows. If it still doesn't work I guess I'll put a new PSU in (wouldn't hurt to upgrade mine I guess). If THAT doesn't solve it... has to be the board??? Not in the mood to upgrade that with the new Intel/AMD chips coming out, so will get used to my PSU off switch I guess ;/
July 16, 2006 5:48:44 PM

You may have a switch (power on) on the case stuck on. Try unpluging this power switch. If the computer does not startup. Use a small screwdriver to short pins to start. Then see if it can be shut down.
July 18, 2006 8:19:02 PM

Funny, I have the exact same problem as you. I also have similar hardware. Antec SmartpowerII 450 and Abit AN8. Lemme know how the power supply switch turns out.
July 22, 2006 4:46:43 AM

SOOOO!!!

BIG UPDATE!!!

Last night I got fed up. I finally got my new matching DIMMS from my G.Skill RMA. I did a CMOS reset, plugged them in, and hoped for the best -- thinking maybe it was still a RAM issue.

NOPE! Still wouldn't turn off.

So I gutted the whole system. I did that screwdriver trick (which was cool, lol). I had just my mobo, CPU, and PSU plugged in with NOTHING else but the CPU and PSU fans. No front panel connectors, no RAM, no NOTHING. Using the screwdriver trick... I'd turn the mobo on, then hold it to turn it off... and it would STILL RESET!

So today I went out and bought a new PSU and mobo, figuring ONE of the two had to be bad. OZS GameXtreme 600W and DFI LanParty Utlra-D nf4.

I was SURE it was my mobo, but I plugged the new PSU in for kicks.

And guess what? IT FREAKING WORKED. IT TURNS OFF.

I'm almost weeping with joy. Such a simple problem. And the sad part is I've known for MONTHS that I skimped on my PSU, but never really thought -- or knew -- it could/would cause this much trouble.

The GameXtreme is SLICK. Nice cabling, solid design, and... most importantly -- it works, lol.

Never even had to unwrap the DFI board.

I guess my problems -- going all the way back to my CTDs, failing RAM in Memtest, and ultimately/finally my automatic restarting troubles -- probably all stemmed from the bunk PSU.

Thanks all to your suggestions and advice.

FANBOY -- GO BUY A NEW PSU AND DUMP THAT ANTEC :)  I'D STRONGLY RECOMMEND THIS OCZ UNIT.
July 22, 2006 4:32:38 PM

Actually, the best power supplies are made by Sparkle.

But they are pricey.
May 1, 2009 1:40:03 PM

3rd Attempt (Success!!)

Problem recognized: Wake on LAN

Right click "My Computer"
Select "Properties"
Go to "Hardware Device"
Click "Device Manager"
Select "Network Adapters"
Select "Marvell Yukon .....PCI-Fast Ethernet Controller--> right click ---properties--->power management-->deselect "Allow the computer to turn off this device to save power"--->Go to "Advanced" tab--->put value off for "Wake from shut down" --->value none for "Wake up capabilities"
press OK


If this doesn't work then check your BIOS

Restart ---> press F2---> go to "Main" tab --->Network boot [Disable] --- Save
!