Sign in with
Sign up | Sign in
Your question

Cd (CRW-5224A) drive not showing up in My Computer

Last response: in Storage
Share
July 19, 2006 2:54:31 AM

Hey, I'm hoping someone can help because I'm all out of ideas.

I recently bought an Asus (sp... AsusTek?) CRW-5224A and got all the wires right, but windows (Windows 2000 pro SP 4) doesn't show it. I looked it the bios and it's there as the secondary slave. I already tried setting it as the Secondary Master and as the Primary Master, but none of that did anything. It shows up fine in the bios but like I said, windows has issues. I looked in device manager for exclamation points, nothing, it's like it doesn't exist. I downloaded the firmware drivers, but all I get is "device to update was not found". I've looked all over google, even deleted the upper and lowerfilters in the registry, that didn't work. I'm clueless, anyone know why the Bios sees it but not Win? and I already tried disabling all my other drives as well as using Safe Mode

Thanks
July 19, 2006 5:09:59 PM

Try booting the computer using a boot disk that has real mode drivers for the cd-rom drive. That will tell you if the problem really is with Windows or not. If it does not work, make sure that the jumpers on all of your drives are set correctly. Many times that can be a cause for this type of problem.
August 6, 2006 9:42:55 PM

Yeah but the problem now I have is this, I can't boot windows... When I do, it gets stuck at the Windows 2000 pro loading page, then a blue screen pops up saying "Inaccessible Boot Device" followed by 0x000... I've tried booting up from the Norton CD to do a virus scan, but the I couldn't get the cd to scan the hardrive (cd, chdir, etc...) it kept saying "invalid drive". I tried using a fix for the MBR (fixmbr) and the BR, but that didn't do anything. I also tried doing a repair from the windows 2000 pro CD, but says "Could not find windows" and asks to format/install. The last thing I did before all this happened was try to manually add the CD drive (add/remove) *smome* controller. And Norton warned me of a virus found in C:\...\*.tmp before I shut off the computer. After that, nothing worked... None of the F8 options (safe mode, last known good configurations) I also tried booting with just the harddrive plugged in the motherboard, that didn't work. I'm probably going to buy a new harddrive and try to get some data from the old harddrive if I can't boot the old one anymore... Anyone have any ideas? I pretty much tried everything on google. Please don't ask me to modify anything inside windows, since as I have said I obviously can't access windows. Does anyone knoe where I can get a chkdsk that will fit a floppy?
Related resources
a b G Storage
August 7, 2006 9:32:49 PM

Considering the issue you are describing, you are most likely doomed to an inhouse repair shop. Trying to fix that issue over chat will be very hard but I will send you in the right direction as it seems you have good technical ability.

Start with suggestion 2 first.
#1 You need to first take care of that virus. Do you have a friends computer that is in good shape with windows XP? Install your hard drive into your friends and do a complete scan with any virus scanner + AVG and remove the virus by any means. Depending on the virus you may or may not need to reinstall the OS. (please not this is not recomended but it would be a shops next step before continuing).

#2 After that the computer will either boot or still have issues. If no boot. remove all IDE deviecs except for the HDD and tripple check its on the right Jumper. If it still doesnt boot, check BIOS again. If still no boot you have a windows problem and you either need to reinstall or take the computer to a shop (NOT BEST BUY or the like).


This is a basic set of suggestions. If you want to try to have us help us can you go into high detail about errors and whats going on... such as IDE settings and what not...
August 12, 2006 5:13:22 AM

Hey,

Putting my harddrive in another computer was my next idea. I bought another harddrive (most of my friends are either on vacation, don't want to open their computer, or have no idea as to what I was trying to do so...). On a side note, the harddrive label said 160gb, but the according to windows it only has a capacity of 131gb.
I loaded windows XP on the harddrive, for logical purposes I'll call this harddrive X, and the problematic harddrive 0.
I set X as the primary master, and the Cd-Rom as the primary slave
I set 0 as the secondary master, and left the asus cd burner disconnected.
Everything went smoothly, I could access 0 from inside X. I rebooted, and I'm sorry I don't have the specifics of it, but a windows xp blue screen popped up saying that one of my drives (E:... being 0 in this case) needed to be checked for errors. There were quite a bit of corrections made from X to 0 and I vaguely remember reading something about a security check.

I'm happy to say that after that I could log into 0 (Windows 2000pro) as well as X so that was good.

There's still a problem. The CD-Burner (Currently I have it as X= primary master, 0= primary slave... Cd-Burner= Secondary Master, Cd-Drive= Secondary Slave) shows up under X's Windows XP as well as the cd-drive, but under Windows 2000pro the cd burner doesn't show up. Yes I checked the jumpers. Why would it show in X's XP, but not in 0's 2000pro?

One more thing, is there a way to be able to select which drive I log into instead of always having to switch masters and slaves?


I gotta thank pcbeginner's website utilities, they allowed me to load linux on a cd and retrive some of the data from 0.
August 13, 2006 11:13:09 PM

Alright I got all the files I needed to I'm free to format the harddrive though I'm somewhat amused by the problems coming from it, and since I have a lot of free time on my hands, I'm gonna try to fix it.

After every other reboot, the old harddrive ( E:)  displays "Inaccessible Boot Device" with the blue screen. Then I boot up from the other harddrive (D:)  and the latter uses chkdsk to scan E: (After that scan is complete, I can usually boot into E: once before I get the inaccessible boot device). Here's what I managed to write down from Chkdsk.

Correcting error in index $SII for file 9.
Attribute record (160, $SII)
(128, $SDS)
Correcting file record segment 9
Deleting an invalid index entry in ...
Replacing invalid security ID with default security ID for file #####

And it says something about correcting the Master file Table. Note that at the ##### it displays the same message from 1 to about 60000 over and over again. I installed another win 2000pro on the same harddrive and THAT one recognizes the cd-burner and boots fine. I also tried using the repair on the win 2000 pro CD and it "repaired" the old windows 2000 pro. I ran a virus scan and spyware scan using :
Kaspersky anti-virus 6.0
Spybot S&D
Microsoft antispyware beta 2 for win xp
Microsoft's malware scanner
and I think that's it, anyone have any ideas or suggestions? about the cd-burner or the inaccessible_boot_device?
thanks in advance
a b G Storage
August 14, 2006 3:40:19 PM

Windows 2000 required SP4, and XP Sp2 to see larger sizes then 131gb.
As for all the trouble your having... Good luck.
I would recommend, Ewido, Trend Micro, Spyware Doctor, Spysweeper. Hijack this.

As for the rest... See above post.
!