Sign in with
Sign up | Sign in
Your question

SATA2 HD not being detected.

Tags:
Last response: in Storage
Share
July 20, 2006 12:48:13 AM

Unsure whether or not this has been asnwered in another thread but i've looked relatively hard and found nothing. I recently got a 320gb SATA2 seagate barracuda 7200.10 and it isn't being detected on my Soyo CK8 Dragon Plus mobo. I have an antec truepower 430w PS and have the right power cable and Soyo's own sata cable connected. I've also tried all possible jumper changes (excluding that of the HD's jumpers due to having no idea about them :p ). I have the latest BIOS for the mobo and it seems to be powering up. My BIOS have no mention of Serial ATA options or anything of the like from what i've looked at besides Onboard Serial Port 1/2 that are set to auto. I've also tried the discwizard program from Seagate and my drive is nowhere to be found :/ . Is it possible that the SATA in my mobo is too old for the SATA2 to work with? Will i have to buy a PCI card? Please help as i'm out of ideas.


Gracias

More about : sata2 detected

a b G Storage
July 20, 2006 7:07:52 PM

You have to change the jumper on the hard drive to make it run at the lower interface speed. Your board only supports the SATA1 spec.
July 21, 2006 3:21:01 PM

Tried it, i moved the jumper to the 1-2 where it was default on 3-4. Am i supposed to remove the jumper entirely?
Related resources
July 21, 2006 3:42:42 PM

Go to the seagate web site, look up your model # and you will find a data sheet with jumper settings.
July 21, 2006 3:50:08 PM

The jumper should be on the two pins that are furthest away from the sata and power connectors if you want to drop it to SATA I.
July 21, 2006 6:17:24 PM

They're in SATA1 interface by default apparently...so jumper changes are null . Model # is ST3320620AS and thank you for the suggestions to head to Seagate's site. I'd been there but i didn't pay attention to the Drive finder feature at the top of the page :p . I'm still stuck however and even replaced my SATA cable to no avail. Is my only remaining option a pci card with sata on it?
a b G Storage
July 21, 2006 6:23:01 PM

See if there are any BIOS updates for your board.
July 21, 2006 6:32:09 PM

From looking at a picture of your mainboard, it looks like it has a 3rd party sata controller.

When the computer POST's, is there another screen after the first one that mentions SATA, SCSI, RAID, Silicon Image, or anything to do with that? If yes, that screen probably has its own mini "bios" that you can go into with a weird key combination like ALT-F. It should mention the key combination on the screen for a brief second.

If you can't find a screen like that, then maybe there isn't one but worth a look. That's where all the sata settings are on my mobo.
July 21, 2006 10:40:44 PM

I didn't see any odd key combo for a mini bios, but when I attempted re flashing my BIOS i get a BIOS ROM checksum error. Looks like i'll have to get my board de flashed. It freezes when i try to re flash again. Thanks for the help :)  .
!