Sign in with
Sign up | Sign in
Your question
Solved

Connect parallel printer into serial port

Last response: in Windows 7
Share
May 10, 2011 8:22:34 PM

i have win 7 64 bit desktop with only serial port, com1 i guess. I have an old HP 5P laserjet that has an lpt1 parallel printer cable securely attached to it. i tried to connect a couple of adapters to the cable and plug it into the com port. I don't get any errors and it doesn't print. i took the driver from the hp site. do i need to change the com port settings (baud rate, etc...? what am i missing?
a b $ Windows 7
May 10, 2011 9:08:22 PM


Are you joking ?
you can not connect a Centronics Parallel printer to a Serial port.

I know there are USB to serial (RS232) adapters I do not know if USB to Centronics Parallel adapters are available

There are PCI cards with parallel ports available which seem the easiest way to go.

I know serial ports can be 9 pin on PC/AT and 25 pin on PC or modem or Terminal and 25pin ports are used for Parallel and SCSI ports on PC/AT

http://www.lammertbies.nl/comm/cable/RS-232.html for serial ports

http://en.wikipedia.org/wiki/Parallel_port for parallel port


The HP LaserJet 5P is unusual in having 2 micro centronics ports which require a special PC to Printer cable
I still have some cables and a old 5P printer which I should throw away, in a cupboard at work

regards

Mike Barnes

Best solution

a b $ Windows 7
May 10, 2011 9:40:40 PM
Share

I've used one of these on a hp printer:
http://cgi.ebay.co.uk/USB-36Pin-Parallel-IEEE-1284-Prin...
Related resources
May 10, 2011 11:44:16 PM

Best answer selected by slomerrills.
February 15, 2012 3:44:03 PM

hairystuff said:
I've used one of these on a hp printer:
http://cgi.ebay.co.uk/USB-36Pin-Parallel-IEEE-1284-Prin...


Being stocked up 4 boxes of toner ay $40 each and a LaserJet 5P, which gives me 5-7,000, can you let assist with two items

1. The Serial to USB I have been using for XP first came out.
2. Windows 7 requirted a new one.

Is anyway to get the HP on to my router with some type of print server. Yes, I do understand this can accomplished with a NAS, but does no one make a pront server with one serial plug and one CAT5 so I can make things simply and add it to the router. (of course the benefit of 8 other PC's being able tol print is heaily weighted.

I was once able to trick home group and somehow it worked. I could print from Laptop. However, my most recent build is not working, although I did get one device to recognize the printger as an IP, but only for my laptop. No one else can print to it.

Permission issue possible?

Thanks.
!