Adaptec ATA Controller Card not working?

Well I just setup a new Gigabyte DS3 Core 2 Duo system, and I can't seem to get the Adaptec Ultra ATA PCI card to work so I can get my 2 IDE DVD-ROMs working. The card is recognized in windows as a pci card(though I can't seem to get the drivers to install). However I thought it would be recognized by bios?

I have 2 IDE Hard drives on the only MB IDE port, and these 2 DVD ROMs(with master and slave individually set) plugged into the card. Is there something I'm doing wrong?
5 answers Last reply
More about adaptec controller card working
  1. Well I tried just using the HD's on the card, and it still didn't work. Is there some kind of special setting I'm overlooking? I figured it would be mostly just plug and play.
  2. try different methods of installing the drivers.if windows does not do it automatically,then cancel the auto driver install in windows and install directly from the driver disc you got with it.then re-boot system.that should work.or try the manufacturers website and download the latest drivers for your operating system.

    Dahak

    EVGA NF4 SLI READY MB
    2X1GIG DDR400 IN DC MODE(128BIT)
    2 7800GT'S IN SLI MODE
    WD300GIG HD @ 7200RPM
    X2 4400+@2.4 S-939
    520WATT PSU
    EXTREME 19IN.MONITOR
  3. Well I can't use a driver disc since my DVD Drives can't work. I downloaded the Adaptec drivers from their website, unzipped, etc. Windows says they are not valid drivers and won't install it.

    Really confused...
  4. My primary is an ATA drive, I don't own any SATA drives which is why I had to get the extender card.
  5. Ok, I will try that sometime this weekend.

    Thanks for your help
Ask a new question

Read More

Controller Adaptec Components