Total newbie, configuring dial-up (long)

Archived from groups: microsoft.public.win2000.dns (More info?)

Hello,

First of all, I am a total newbie in DNS and Windows network configuration.
I have a problem configuring my XP machine to use both a company dial-up
conection and my regular internet connection.

1. in the beginning, I used to dial-up my company's network (through my RTC
modem) and I was completely losing my internet connection (through an
ethernet cable). It was somewhat frustrating, but it worked well. All names
finishing with suffix "mycompany.com" resolved correctly. (I use this
connection mainly for Remote Desktop Program purposes, so I RDP
computer1.sub.mycompany.com, computer2.sub.mycompany.com, etc)

2. Then I changed my configuration because I wanted to have BOTH internet
AND dial-up conection! I unticked box "Use default gateway on remote
network" and hurra it worked! I could use internet and being connected at
the same time! but wait a minute... all my addresses
"computer1.sub.mycompany.com" now do not resolve anymore! So I cannot RDP
anymore except if I use the IP address instead, and if I ROUTE this address
through the dial-up connection...

I would like to be able to use the same names "computer1.mycompany.com", and
not having to use IP address AND ROUTE command. I believe confusely it might
be related to DNS settings but I have absolutely no idea how to tell windows
that
- all names with suffix "sub.mycompany.com" should be resolved to the DNS on
the dial-up connection,
- all traffic to "sub.mycompany.com" should be sent through dial-ip
connection.

Can someone help?

SerGioGioGio
3 answers Last reply
More about total newbie configuring dial long
  1. Archived from groups: microsoft.public.win2000.dns (More info?)

    "SerGioGio" <nospam> wrote in message
    news:OJ9T7OuHFHA.4032@TK2MSFTNGP12.phx.gbl...
    > Hello,
    >
    > First of all, I am a total newbie in DNS and Windows network
    configuration.
    > I have a problem configuring my XP machine to use both a company dial-up
    > conection and my regular internet connection.

    Before you go further you have to realize that
    DURING a dial connection (VPN also) the
    DIAL settings take precedence over any other
    NIC for things like Default Gateway, DNS
    and even WINS server if that latter applies.

    > 1. in the beginning, I used to dial-up my company's network (through my
    RTC
    > modem) and I was completely losing my internet connection (through an
    > ethernet cable).

    Probably not. You just didn't have name resolution
    (see above) through DNS set for the Internet and you
    may not have had a default gateway that worked for
    the Internet.

    Had you fiddle with the routes you could probably
    make that part work fairly easy -- DNS is a little
    tougher and might take more work.

    > It was somewhat frustrating, but it worked well. All names
    > finishing with suffix "mycompany.com" resolved correctly. (I use this
    > connection mainly for Remote Desktop Program purposes, so I RDP
    > computer1.sub.mycompany.com, computer2.sub.mycompany.com, etc)

    This implies that your connection to "mycompany.com"
    either had it's DNS WRONG or purposely was denying
    Internet resolution and access -- at least in theory you
    could have resolve the Internet through THEIR DNS
    servers AND you could have fiddled with the routing
    (static routes etc.) to make the routing work (probably.)

    Or even gone the "slow way" through the dial. <ugh>

    > 2. Then I changed my configuration because I wanted to have BOTH internet
    > AND dial-up conection! I unticked box "Use default gateway on remote
    > network" and hurra it worked! I could use internet and being connected at
    > the same time! but wait a minute... all my addresses
    > "computer1.sub.mycompany.com" now do not resolve anymore! So I cannot RDP
    > anymore except if I use the IP address instead, and if I ROUTE this
    address
    > through the dial-up connection...

    (That is routing if you are talking about DNS but
    just where you point the client.)

    DNS is the hardest part. If your mycompany.com
    DNS servers would resolve the Internet names we
    can make the routing work.

    You keep their DNS and you use YOUR DEFAULT
    router (overide the dial setting.)

    But you then (may) have to add static routes to reach
    the corporate network through the dial (and this may
    require being able to predict the RRAS-dial server
    which will answer.)

    > I would like to be able to use the same names "computer1.mycompany.com",
    and
    > not having to use IP address AND ROUTE command. I believe confusely it
    might
    > be related to DNS settings but I have absolutely no idea how to tell
    windows
    > that
    > - all names with suffix "sub.mycompany.com" should be resolved to the DNS
    on
    > the dial-up connection,

    A DNS CLIENT cannot do that.

    You could however attempt to install a DNS
    server on your workstation and conditionally
    forward to each DNS server.

    Easier would be for the DNS admins to fix it
    for you.

    Let me point out something else: In some companies
    (like that big software Corporation in the Northwest
    for instance but many more) it is a "termination" offense
    to connect to the CORPORATE network and a public
    (or even customer) network AT THE SAME TIME.

    Say it clearly: You might get fired -- or least very
    embarrassed.

    > - all traffic to "sub.mycompany.com" should be sent through dial-ip
    > connection.
    >
    > Can someone help?

    Not with precisely what you ask. This is really
    a job for YOUR IS admins -- or if that is your it
    would really be better to not do this OR to work
    it out at the servers.

    > SerGioGioGio
    >
    >
  2. Archived from groups: microsoft.public.win2000.dns (More info?)

    > > 2. Then I changed my configuration because I wanted to have BOTH
    internet
    > > AND dial-up conection! I unticked box "Use default gateway on remote
    > > network" and hurra it worked! I could use internet and being connected
    at
    > > the same time! but wait a minute... all my addresses
    > > "computer1.sub.mycompany.com" now do not resolve anymore! So I cannot
    RDP
    > > anymore except if I use the IP address instead, and if I ROUTE this
    > address
    > > through the dial-up connection...

    From what I understand, unticking "Use default gateway on remote network"
    results in keeping (not ovverriding) your default gateway AND your DNS
    server AND your default WINS server, am I right? When I use this option the
    names in sub.mycompany.com do not resolve anymore!
    This mens that my default DNS is still being used, not MyCompany's.

    >
    > (That is routing if you are talking about DNS but
    > just where you point the client.)
    >
    > DNS is the hardest part. If your mycompany.com
    > DNS servers would resolve the Internet names we
    > can make the routing work.
    >
    > You keep their DNS and you use YOUR DEFAULT
    > router (overide the dial setting.)
    >

    I understand that. But how can I tell windows to use their DNS instead of
    mine? When I do a ipconfig /all, I can see I have 2 connections, 1 to my
    LAN, and 1 dial-up PPP to my company. There is one DNS for my LAN
    connection, and 2 for my dial-up PPP connection. How can I tell windows to
    use one instead of the other?
    Same question for the default gateway, How can I tell windows to use one or
    the other?

    > But you then (may) have to add static routes to reach
    > the corporate network through the dial (and this may
    > require being able to predict the RRAS-dial server
    > which will answer.)
    >

    I understand that (except for the RRAS part but I guess this is probably too
    advanced for me at the moment)

    > > I would like to be able to use the same names "computer1.mycompany.com",
    > and
    > > not having to use IP address AND ROUTE command. I believe confusely it
    > might
    > > be related to DNS settings but I have absolutely no idea how to tell
    > windows
    > > that
    > > - all names with suffix "sub.mycompany.com" should be resolved to the
    DNS
    > on
    > > the dial-up connection,
    >
    > A DNS CLIENT cannot do that.
    >
    > You could however attempt to install a DNS
    > server on your workstation and conditionally
    > forward to each DNS server.
    >
    > Easier would be for the DNS admins to fix it
    > for you.
    >

    Then, can I not tell windows:
    use this DNS first (my LAN DNS). If name resolution fails, use that other
    one then (my company DNS).
    ?
    If I manage to do that, I'll just have to add one static route then!


    Thanks for your detailed answer Herb, it's been really very helpful and
    educationate.

    SerGioGioGio
  3. Archived from groups: microsoft.public.win2000.dns (More info?)

    > > You keep their DNS and you use YOUR DEFAULT
    > > router (override the dial setting.)
    > >
    >
    > I understand that. But how can I tell windows to use their DNS instead of
    > mine? When I do a ipconfig /all, I can see I have 2 connections, 1 to my
    > LAN, and 1 dial-up PPP to my company. There is one DNS for my LAN
    > connection, and 2 for my dial-up PPP connection. How can I tell windows to
    > use one instead of the other?
    > Same question for the default gateway, How can I tell windows to use one
    or
    > the other?

    Instead of doing it through the "check box"
    you need to override it on the advanced page.

    All interfaces (even dial) have the same settings
    (roughly) as a REAL NIC.

    If you type something into Default Gateway, DNS,
    or WINS then those specific settings take precedence
    of those of the dial/VPN server.

    You don't have to override all of them to override
    one of them.

    --
    Herb Martin


    "SerGioGio" <nospam> wrote in message
    news:OHHDex9HFHA.2656@TK2MSFTNGP09.phx.gbl...
    > > > 2. Then I changed my configuration because I wanted to have BOTH
    > internet
    > > > AND dial-up conection! I unticked box "Use default gateway on remote
    > > > network" and hurra it worked! I could use internet and being connected
    > at
    > > > the same time! but wait a minute... all my addresses
    > > > "computer1.sub.mycompany.com" now do not resolve anymore! So I cannot
    > RDP
    > > > anymore except if I use the IP address instead, and if I ROUTE this
    > > address
    > > > through the dial-up connection...
    >
    > From what I understand, unticking "Use default gateway on remote network"
    > results in keeping (not ovverriding) your default gateway AND your DNS
    > server AND your default WINS server, am I right? When I use this option
    the
    > names in sub.mycompany.com do not resolve anymore!
    > This mens that my default DNS is still being used, not MyCompany's.
    >
    > >
    > > (That is routing if you are talking about DNS but
    > > just where you point the client.)
    > >
    > > DNS is the hardest part. If your mycompany.com
    > > DNS servers would resolve the Internet names we
    > > can make the routing work.
    > >
    > > You keep their DNS and you use YOUR DEFAULT
    > > router (overide the dial setting.)
    > >
    >
    > I understand that. But how can I tell windows to use their DNS instead of
    > mine? When I do a ipconfig /all, I can see I have 2 connections, 1 to my
    > LAN, and 1 dial-up PPP to my company. There is one DNS for my LAN
    > connection, and 2 for my dial-up PPP connection. How can I tell windows to
    > use one instead of the other?
    > Same question for the default gateway, How can I tell windows to use one
    or
    > the other?
    >
    > > But you then (may) have to add static routes to reach
    > > the corporate network through the dial (and this may
    > > require being able to predict the RRAS-dial server
    > > which will answer.)
    > >
    >
    > I understand that (except for the RRAS part but I guess this is probably
    too
    > advanced for me at the moment)
    >
    > > > I would like to be able to use the same names
    "computer1.mycompany.com",
    > > and
    > > > not having to use IP address AND ROUTE command. I believe confusely it
    > > might
    > > > be related to DNS settings but I have absolutely no idea how to tell
    > > windows
    > > > that
    > > > - all names with suffix "sub.mycompany.com" should be resolved to the
    > DNS
    > > on
    > > > the dial-up connection,
    > >
    > > A DNS CLIENT cannot do that.
    > >
    > > You could however attempt to install a DNS
    > > server on your workstation and conditionally
    > > forward to each DNS server.
    > >
    > > Easier would be for the DNS admins to fix it
    > > for you.
    > >
    >
    > Then, can I not tell windows:
    > use this DNS first (my LAN DNS). If name resolution fails, use that other
    > one then (my company DNS).
    > ?
    > If I manage to do that, I'll just have to add one static route then!
    >
    >
    > Thanks for your detailed answer Herb, it's been really very helpful and
    > educationate.
    >
    > SerGioGioGio
    >
    >
Ask a new question

Read More

Dial Up Connection Internet Connection Windows