Sign in with
Sign up | Sign in
Your question

2003 server domain name same as our webhosting domain name

Last response: in Windows 2000/NT
Share
March 11, 2005 9:23:02 AM

Archived from groups: microsoft.public.win2000.dns (More info?)

Hi,
I ran into problem and I don't know if there's a way to get around to it. I
have a window 2003 server and the domain name is "company.com", but we also
have a website on the internet called "www.company.com". We are planning to
move our website from webhosting service to our websever eventually but we
are not ready for that. So, right now I ran into a problem. First is that,
when our employee type "www.company.com" on the internet explorer, the link
will start searching on our corporate server and reply with error, "Page not
found". So, what I did on individual workstation that I move the webhosting
DNS IP address up to the top and move the server ip address down to the
bottom. As example below:

192.168.50.120 (server address)
192.168.50 126 (secondary server address)
66.66.105.199 (Webhost DNS)
66.66.158.250 (webhost secondary DNS)

change to:

66.66.105.199 (Webhost DNS)
66.66.158.250 (webhost secondary DNS)
192.168.50.120 (server address)
192.168.50 126 (secondary server address)

Now, when a person typed out "www.company.com", it work beautiful but the
people complained that the login time take forever.. I know that our employee
do need to get one of our company website because of the web e-mails and news
and notification.

So, is there a way to have "www.company.com" by pass the server and look to
that specific webhosting IP address?? Or is it mistake to have server domain
name same as the webhosting address?

Any advice greatly appreaciated,
Thanks!
RSM
Anonymous
March 11, 2005 11:46:09 AM

Archived from groups: microsoft.public.win2000.dns (More info?)

In news:6C00801B-7521-412C-A92A-B4AE983F0F20@microsoft.com,
Scott <Scott@discussions.microsoft.com> commented
Then Kevin replied below:
> Hi,
> I ran into problem and I don't know if there's a way to
> get around to it. I have a window 2003 server and the
> domain name is "company.com", but we also have a website
> on the internet called "www.company.com". We are planning
> to move our website from webhosting service to our
> websever eventually but we are not ready for that. So,
> right now I ran into a problem. First is that, when our
> employee type "www.company.com" on the internet explorer,
> the link will start searching on our corporate server and
> reply with error, "Page not found". So, what I did on
> individual workstation that I move the webhosting DNS IP
> address up to the top and move the server ip address down
> to the bottom. As example below:
>
> 192.168.50.120 (server address)
> 192.168.50 126 (secondary server address)
> 66.66.105.199 (Webhost DNS)
> 66.66.158.250 (webhost secondary DNS)
>
> change to:
>
> 66.66.105.199 (Webhost DNS)
> 66.66.158.250 (webhost secondary DNS)
> 192.168.50.120 (server address)
> 192.168.50 126 (secondary server address)
>
> Now, when a person typed out "www.company.com", it work
> beautiful but the people complained that the login time
> take forever.. I know that our employee do need to get
> one of our company website because of the web e-mails and
> news and notification.
>
> So, is there a way to have "www.company.com" by pass the
> server and look to that specific webhosting IP address??
> Or is it mistake to have server domain name same as the
> webhosting address?

You should totally remove the external DNS from TCP/IP properties on all
machines. Use only the internal DNS. You can use your ISP's DNS as a
forwarder on the forwarder tab of the DNS server property sheet.
To fix the Web site address, use the DNS console expand the server, expand
forward lookup zones, open your company.com zone, right click in the zone
select new host from the list, name the host www and give it the IP of the
website. You will not be able to connect to the website using only the
domain name, the record for the domain name must only give the IP address on
all domain controllers that have file sharing enabled.



--
Best regards,
Kevin D4 Dad Goodknecht Sr. [MVP]
Hope This Helps
===================================
When responding to posts, please "Reply to Group"
via your newsreader so that others may learn and
benefit from your issue, to respond directly to
me remove the nospam. from my email address.
===================================
http://www.lonestaramerica.com/
===================================
Use Outlook Express?... Get OE_Quotefix:
It will strip signature out and more
http://home.in.tum.de/~jain/software/oe-quotefix/
===================================
Keep a back up of your OE settings and folders
with OEBackup:
http://www.oehelp.com/OEBackup/Default.aspx
===================================
March 11, 2005 11:46:10 AM

Archived from groups: microsoft.public.win2000.dns (More info?)

Thanks Mr. Goodknecht Sr. for quick reply. That does work very well. I'm glad
to solve the problem. Now the only question I have is what about subdomain?
How can I set that up? For example: http://access.company.com. When I test
www.company.com and it work beautiful except for http://access.company.com I
get error. I did try creating new forward host with name "access" but the ip
address point to www.company.com, but not sure how I can do that?

Thanks again for quick response!
RSM

"Kevin D. Goodknecht Sr. [MVP]" wrote:

> In news:6C00801B-7521-412C-A92A-B4AE983F0F20@microsoft.com,
> Scott <Scott@discussions.microsoft.com> commented
> Then Kevin replied below:
> > Hi,
> > I ran into problem and I don't know if there's a way to
> > get around to it. I have a window 2003 server and the
> > domain name is "company.com", but we also have a website
> > on the internet called "www.company.com". We are planning
> > to move our website from webhosting service to our
> > websever eventually but we are not ready for that. So,
> > right now I ran into a problem. First is that, when our
> > employee type "www.company.com" on the internet explorer,
> > the link will start searching on our corporate server and
> > reply with error, "Page not found". So, what I did on
> > individual workstation that I move the webhosting DNS IP
> > address up to the top and move the server ip address down
> > to the bottom. As example below:
> >
> > 192.168.50.120 (server address)
> > 192.168.50 126 (secondary server address)
> > 66.66.105.199 (Webhost DNS)
> > 66.66.158.250 (webhost secondary DNS)
> >
> > change to:
> >
> > 66.66.105.199 (Webhost DNS)
> > 66.66.158.250 (webhost secondary DNS)
> > 192.168.50.120 (server address)
> > 192.168.50 126 (secondary server address)
> >
> > Now, when a person typed out "www.company.com", it work
> > beautiful but the people complained that the login time
> > take forever.. I know that our employee do need to get
> > one of our company website because of the web e-mails and
> > news and notification.
> >
> > So, is there a way to have "www.company.com" by pass the
> > server and look to that specific webhosting IP address??
> > Or is it mistake to have server domain name same as the
> > webhosting address?
>
> You should totally remove the external DNS from TCP/IP properties on all
> machines. Use only the internal DNS. You can use your ISP's DNS as a
> forwarder on the forwarder tab of the DNS server property sheet.
> To fix the Web site address, use the DNS console expand the server, expand
> forward lookup zones, open your company.com zone, right click in the zone
> select new host from the list, name the host www and give it the IP of the
> website. You will not be able to connect to the website using only the
> domain name, the record for the domain name must only give the IP address on
> all domain controllers that have file sharing enabled.
>
>
>
> --
> Best regards,
> Kevin D4 Dad Goodknecht Sr. [MVP]
> Hope This Helps
> ===================================
> When responding to posts, please "Reply to Group"
> via your newsreader so that others may learn and
> benefit from your issue, to respond directly to
> me remove the nospam. from my email address.
> ===================================
> http://www.lonestaramerica.com/
> ===================================
> Use Outlook Express?... Get OE_Quotefix:
> It will strip signature out and more
> http://home.in.tum.de/~jain/software/oe-quotefix/
> ===================================
> Keep a back up of your OE settings and folders
> with OEBackup:
> http://www.oehelp.com/OEBackup/Default.aspx
> ===================================
>
>
>
Anonymous
March 11, 2005 3:57:39 PM

Archived from groups: microsoft.public.win2000.dns (More info?)

access.company.com point to www.company.com? If yes, then since you already
created a record for www, the best thing to do now is to create an alias
(CNAME) called access and put www.company.com as the full name of the target
host.

You can also simply creat access as an A record and put in the same IP
address.

Now, you didn't say exactly what error you got when you used the
http://access.company.com. But if you set up the access record properly, and
you get errors, it may be coming from the web server. Google for "host
header" and you should learn how to resolve the issue.

--

Sincerely,
Dèjì Akómöláfé, MCSE+M MCSA+M MCP+I
Microsoft MVP - Directory Services
www.readymaids.com - we know IT
www.akomolafe.com
Do you now realize that Today is the Tomorrow you were worried about
Yesterday? -anon
"Scott" <Scott@discussions.microsoft.com> wrote in message
news:6D7F7209-6B30-4A67-B551-DE80EC5A6135@microsoft.com...
> Thanks Mr. Goodknecht Sr. for quick reply. That does work very well. I'm
> glad
> to solve the problem. Now the only question I have is what about
> subdomain?
> How can I set that up? For example: http://access.company.com. When I
> test
> www.company.com and it work beautiful except for http://access.company.com
> I
> get error. I did try creating new forward host with name "access" but the
> ip
> address point to www.company.com, but not sure how I can do that?
>
> Thanks again for quick response!
> RSM
>
> "Kevin D. Goodknecht Sr. [MVP]" wrote:
>
>> In news:6C00801B-7521-412C-A92A-B4AE983F0F20@microsoft.com,
>> Scott <Scott@discussions.microsoft.com> commented
>> Then Kevin replied below:
>> > Hi,
>> > I ran into problem and I don't know if there's a way to
>> > get around to it. I have a window 2003 server and the
>> > domain name is "company.com", but we also have a website
>> > on the internet called "www.company.com". We are planning
>> > to move our website from webhosting service to our
>> > websever eventually but we are not ready for that. So,
>> > right now I ran into a problem. First is that, when our
>> > employee type "www.company.com" on the internet explorer,
>> > the link will start searching on our corporate server and
>> > reply with error, "Page not found". So, what I did on
>> > individual workstation that I move the webhosting DNS IP
>> > address up to the top and move the server ip address down
>> > to the bottom. As example below:
>> >
>> > 192.168.50.120 (server address)
>> > 192.168.50 126 (secondary server address)
>> > 66.66.105.199 (Webhost DNS)
>> > 66.66.158.250 (webhost secondary DNS)
>> >
>> > change to:
>> >
>> > 66.66.105.199 (Webhost DNS)
>> > 66.66.158.250 (webhost secondary DNS)
>> > 192.168.50.120 (server address)
>> > 192.168.50 126 (secondary server address)
>> >
>> > Now, when a person typed out "www.company.com", it work
>> > beautiful but the people complained that the login time
>> > take forever.. I know that our employee do need to get
>> > one of our company website because of the web e-mails and
>> > news and notification.
>> >
>> > So, is there a way to have "www.company.com" by pass the
>> > server and look to that specific webhosting IP address??
>> > Or is it mistake to have server domain name same as the
>> > webhosting address?
>>
>> You should totally remove the external DNS from TCP/IP properties on all
>> machines. Use only the internal DNS. You can use your ISP's DNS as a
>> forwarder on the forwarder tab of the DNS server property sheet.
>> To fix the Web site address, use the DNS console expand the server,
>> expand
>> forward lookup zones, open your company.com zone, right click in the zone
>> select new host from the list, name the host www and give it the IP of
>> the
>> website. You will not be able to connect to the website using only the
>> domain name, the record for the domain name must only give the IP address
>> on
>> all domain controllers that have file sharing enabled.
>>
>>
>>
>> --
>> Best regards,
>> Kevin D4 Dad Goodknecht Sr. [MVP]
>> Hope This Helps
>> ===================================
>> When responding to posts, please "Reply to Group"
>> via your newsreader so that others may learn and
>> benefit from your issue, to respond directly to
>> me remove the nospam. from my email address.
>> ===================================
>> http://www.lonestaramerica.com/
>> ===================================
>> Use Outlook Express?... Get OE_Quotefix:
>> It will strip signature out and more
>> http://home.in.tum.de/~jain/software/oe-quotefix/
>> ===================================
>> Keep a back up of your OE settings and folders
>> with OEBackup:
>> http://www.oehelp.com/OEBackup/Default.aspx
>> ===================================
>>
>>
>>
!