Technical Question - sluggish mouse movement

Archived from groups: alt.games.morrowind (More info?)

Hello!

I started playing Morrowind several times, but every time I kicked the
game from my harddisk after a couple of hours. reason: the movement with
the mouse and the overall performance of the game was awkward. I do not
have any problems with other games (Shooters, rpgs like gothic etc...).
In morrowind especially the movement of the mouse is sluggish and
delayed and drives me mad!
My PC is an Athlon XP 2400+, I habe 1 Gig of RAM and the graphics card
is a decent ATI 9500 Pro. This should be more than enough to run this
games smoothly.
Is there any solution for this prob?

Thanks! JoJo
15 answers Last reply
More about technical question sluggish mouse movement
  1. Archived from groups: alt.games.morrowind (More info?)

    JoJo wrote:
    >
    > Hello!
    >
    > I started playing Morrowind several times, but every time I kicked the
    > game from my harddisk after a couple of hours. reason: the movement with
    > the mouse and the overall performance of the game was awkward. I do not
    > have any problems with other games (Shooters, rpgs like gothic etc...).
    > In morrowind especially the movement of the mouse is sluggish and
    > delayed and drives me mad!
    > My PC is an Athlon XP 2400+, I habe 1 Gig of RAM and the graphics card
    > is a decent ATI 9500 Pro. This should be more than enough to run this
    > games smoothly.
    > Is there any solution for this prob?
    >
    > Thanks! JoJo

    There's an add-on utility available for (free) download called the
    Morrowind FPS Optimizer which fixes this irritating problem along with
    giving you various other options for improving graphics performance in
    the game. You can get a copy here:

    http://www.lowgenius.com/games/mwind/mwindfps.asp
  2. Archived from groups: alt.games.morrowind (More info?)

    On Wed, 09 Mar 2005 10:53:56 +0100, JoJo <ngac_jojo@gmx.de> wrote:

    >Hello!
    >
    >I started playing Morrowind several times, but every time I kicked the
    >game from my harddisk after a couple of hours. reason: the movement with
    >the mouse and the overall performance of the game was awkward. I do not
    >have any problems with other games (Shooters, rpgs like gothic etc...).
    >In morrowind especially the movement of the mouse is sluggish and
    >delayed and drives me mad!
    >My PC is an Athlon XP 2400+, I habe 1 Gig of RAM and the graphics card
    >is a decent ATI 9500 Pro. This should be more than enough to run this
    >games smoothly.
    >Is there any solution for this prob?

    What OS are you running it under? I've never got it working properly in
    win98 with 1Gb of RAM - it worked fine when I only had 512Mb, but as
    soon as I upgraded to 1Gb it behaved very erratically. But the game
    works well in Win2K and WinXP with 1Gb of RAM.
  3. Archived from groups: alt.games.morrowind (More info?)

    Greg Johnson wrote:
    > What OS are you running it under? I've never got it working properly in
    > win98 with 1Gb of RAM - it worked fine when I only had 512Mb, but as
    > soon as I upgraded to 1Gb it behaved very erratically. But the game
    > works well in Win2K and WinXP with 1Gb of RAM.
    this is a WIN9X-problem, as it never works correctly with more than 768
    MB of RAM installed. Even if you have 512-768 MB of RAM you have to edit
    the system.ini in order to prevent the dynamic allocated disk cache from
    choking.
  4. Archived from groups: alt.games.morrowind (More info?)

    edit
    > the system.ini in order to prevent the dynamic allocated disk cache from
    > choking.

    Guido , I have the same problem.
    Can you explain to me how to edit the system ini.
    Do you mean the sytem ini of morrowind or the sytem ini of windows?

    pieter
  5. Archived from groups: alt.games.morrowind (More info?)

    pb wrote:
    >
    > Guido , I have the same problem.
    > Can you explain to me how to edit the system ini.
    > Do you mean the sytem ini of morrowind or the sytem ini of windows?
    >
    The problem is built into the design of memory management of Windows 9x,
    it is not a problem of Morrowind.
    To circumvent this problem open the Windows system file SYSTEM.INI,
    which is located in the windows main directory (usually C:\WINDOWS) with
    a text editor (eg. NOTEPAD) -> search for the line [VCACHE] -> below
    this line create a new line containing MAXFILECACHE=524288.
    If you use another editor make shure to save the file in plain text
    format - do not use a format which contains additional format information.
    This will limit the available memory for the dynamic file system cache
    to 512 MB - it does not limit the available memory for applications.
    This should at least work for systems up to 768 MB of RAM installed.
  6. Archived from groups: alt.games.morrowind (More info?)

    "Guido Hörster" <Guido_Hoerster@t-online.de> schreef in bericht
    news:d0mqeb$iap$00$1@news.t-online.com...
    > pb wrote:
    >>
    >> Guido , I have the same problem.
    >> Can you explain to me how to edit the system ini.
    >> Do you mean the sytem ini of morrowind or the sytem ini of windows?
    >>
    > The problem is built into the design of memory management of Windows 9x,
    > it is not a problem of Morrowind.
    > To circumvent this problem open the Windows system file SYSTEM.INI, which
    > is located in the windows main directory (usually C:\WINDOWS) with a text
    > editor (eg. NOTEPAD) -> search for the line [VCACHE] -> below this line
    > create a new line containing MAXFILECACHE=524288.
    > If you use another editor make shure to save the file in plain text
    > format - do not use a format which contains additional format information.
    > This will limit the available memory for the dynamic file system cache to
    > 512 MB - it does not limit the available memory for applications.
    > This should at least work for systems up to 768 MB of RAM installed.

    Guido I will try what you suggest because the fpsoptimiser does not do the
    job and does not work on the alt tab (may be bugs)
    thanks for your advize

    pieter
  7. Archived from groups: alt.games.morrowind (More info?)

    "Guido Hörster" <Guido_Hoerster@t-online.de> schreef in bericht
    news:d0mqeb$iap$00$1@news.t-online.com...
    > pb wrote:
    >>
    >> Guido , I have the same problem.
    >> Can you explain to me how to edit the system ini.
    >> Do you mean the sytem ini of morrowind or the sytem ini of windows?
    >>
    > The problem is built into the design of memory management of Windows 9x,
    > it is not a problem of Morrowind.
    > To circumvent this problem open the Windows system file SYSTEM.INI, which
    > is located in the windows main directory (usually C:\WINDOWS) with a text
    > editor (eg. NOTEPAD) -> search for the line [VCACHE] -> below this line
    > create a new line containing MAXFILECACHE=524288.
    > If you use another editor make shure to save the file in plain text
    > format - do not use a format which contains additional format information.
    > This will limit the available memory for the dynamic file system cache to
    > 512 MB - it does not limit the available memory for applications.
    > This should at least work for systems up to 768 MB of RAM installed.

    Again...any idea where I can find that in xp because I work in xp.
    And other story...I work with 3 screens, can that be a reason?
    The change from 768 to 512mb makes no difference.

    pieter
  8. Archived from groups: alt.games.morrowind (More info?)

    Guido Hörster <Guido_Hoerster@t-online.de> wrote in
    news:d0mqeb$iap$00$1@news.t-online.com:

    > pb wrote:
    >>
    >> Guido , I have the same problem.
    >> Can you explain to me how to edit the system ini.
    >> Do you mean the sytem ini of morrowind or the sytem ini of windows?
    >>
    > The problem is built into the design of memory management of Windows
    > 9x, it is not a problem of Morrowind.
    > To circumvent this problem open the Windows system file SYSTEM.INI,
    > which is located in the windows main directory (usually C:\WINDOWS)
    > with a text editor (eg. NOTEPAD) -> search for the line [VCACHE] ->
    > below this line create a new line containing MAXFILECACHE=524288.
    > If you use another editor make shure to save the file in plain text
    > format - do not use a format which contains additional format
    > information. This will limit the available memory for the dynamic file
    > system cache to 512 MB - it does not limit the available memory for
    > applications. This should at least work for systems up to 768 MB of
    > RAM installed.

    Is this different from changing the Virtual Memory from Control Panel ->
    System -> Advanced?


    C
  9. Archived from groups: alt.games.morrowind (More info?)

    pb wrote:
    > Again...any idea where I can find that in xp because I work in xp.
    > And other story...I work with 3 screens, can that be a reason?
    > The change from 768 to 512mb makes no difference.
    >
    WIN-XP, like WIN2000 has a totally different type of memory management
    compared to WIN9X. They are supposed to support at least up to 4GB. If
    you have problems in WIN-XP, there might be another reason.
    I usually try memtest first on systems with strange instabilities in
    order to decide if it might be a hardware or software problem (no
    software can heal damaged hardware !)
    You can download it from www.memtest86.com for free. It will create a
    bootable floppy including its own "micro operating system". Be warned:
    Depending on system speed and amount of installed RAM a full test may
    take up to 20-30 hours. If it finds any errors, you found your problem.
  10. Archived from groups: alt.games.morrowind (More info?)

    Seymour C. Moore wrote:
    >
    > Is this different from changing the Virtual Memory from Control Panel ->
    > System -> Advanced?
    >
    virtual memory is simulating RAM on the disk, disk cache is using RAM to
    speed up disk access by avoiding multiple diskreads of the same disk
    area - they are opposite to each other
  11. Archived from groups: alt.games.morrowind (More info?)

    > Again...any idea where I can find that in xp because I work in xp.
    > And other story...I work with 3 screens, can that be a reason?
    > The change from 768 to 512mb makes no difference.

    THREE? My work machine has 2, and it's great, but I can't imagine what I'd
    use more than 1 for on my gaming machine. Though I heard about some guy
    that hooked up like 19 monitors to play a flight simulator. Saw a picture
    of his setup online, he actually looked like he was in a cockpit. I don't
    play flight-sims, though, and for games like this one, I'd think 1 monitor
    would be sufficient...
  12. Archived from groups: alt.games.morrowind (More info?)

    In article <d0mqeb$iap$00$1@news.t-online.com>, Guido_Hoerster@t-
    online.de says...
    > pb wrote:
    > >
    > > Guido , I have the same problem.
    > > Can you explain to me how to edit the system ini.
    > > Do you mean the sytem ini of morrowind or the sytem ini of windows?
    > >
    > The problem is built into the design of memory management of Windows 9x,
    > it is not a problem of Morrowind.
    > To circumvent this problem open the Windows system file SYSTEM.INI,
    > which is located in the windows main directory (usually C:\WINDOWS) with
    > a text editor (eg. NOTEPAD) -> search for the line [VCACHE] -> below
    > this line create a new line containing MAXFILECACHE=524288.
    > If you use another editor make shure to save the file in plain text
    > format - do not use a format which contains additional format information.
    > This will limit the available memory for the dynamic file system cache
    > to 512 MB - it does not limit the available memory for applications.
    > This should at least work for systems up to 768 MB of RAM installed.

    I feel that that is way too much memory allocated to file cache.

    I ran for years with 4 MB of file cache, but if you have a Gig of RAM I
    suppose you can set it to 16 ...

    MinFileCache=16384
    MaxFileCache=16384

    sets the cache to a fixed size of 16 MB. No more dynamic allocation,
    which speeds the system up quite a bit in Win98, too. If you feel
    generous, you can quadruple that but no way should you need that much :)

    -Peter
  13. Archived from groups: alt.games.morrowind (More info?)

    Peter Huebner wrote:
    >
    > I feel that that is way too much memory allocated to file cache.
    >
    As you stated yourself, this entry is an upper limit for the disk cache.
    The system normally does not allocate that much. You may be right, that
    by fixing the size to a static value (same value for min and max), the
    system might improve speed as it does not have to handle it dynamically
    any more.
  14. Archived from groups: alt.games.morrowind (More info?)

    Thanks a lot!
    I'll try the Program.

    JoJo


    Pete MC schrieb:
    > JoJo wrote:
    >
    >>Hello!
    >>
    >>I started playing Morrowind several times, but every time I kicked the
    >>game from my harddisk after a couple of hours. reason: the movement with
    >>the mouse and the overall performance of the game was awkward. I do not
    >>have any problems with other games (Shooters, rpgs like gothic etc...).
    >>In morrowind especially the movement of the mouse is sluggish and
    >>delayed and drives me mad!
    >>My PC is an Athlon XP 2400+, I habe 1 Gig of RAM and the graphics card
    >>is a decent ATI 9500 Pro. This should be more than enough to run this
    >>games smoothly.
    >>Is there any solution for this prob?
    >>
    >>Thanks! JoJo
    >
    >
    > There's an add-on utility available for (free) download called the
    > Morrowind FPS Optimizer which fixes this irritating problem along with
    > giving you various other options for improving graphics performance in
    > the game. You can get a copy here:
    >
    > http://www.lowgenius.com/games/mwind/mwindfps.asp
  15. Archived from groups: alt.games.morrowind (More info?)

    Hi!

    My OS is Windows 2000. --> no problems with more than 512 megs.
    MS-DOS based Windows OSes hab a huge problem with more than 512 MB.

    JoJo

    Greg Johnson schrieb:
    > On Wed, 09 Mar 2005 10:53:56 +0100, JoJo <ngac_jojo@gmx.de> wrote:
    >
    >
    >>Hello!
    >>
    >>I started playing Morrowind several times, but every time I kicked the
    >>game from my harddisk after a couple of hours. reason: the movement with
    >>the mouse and the overall performance of the game was awkward. I do not
    >>have any problems with other games (Shooters, rpgs like gothic etc...).
    >>In morrowind especially the movement of the mouse is sluggish and
    >>delayed and drives me mad!
    >>My PC is an Athlon XP 2400+, I habe 1 Gig of RAM and the graphics card
    >>is a decent ATI 9500 Pro. This should be more than enough to run this
    >>games smoothly.
    >>Is there any solution for this prob?
    >
    >
    > What OS are you running it under? I've never got it working properly in
    > win98 with 1Gb of RAM - it worked fine when I only had 512Mb, but as
    > soon as I upgraded to 1Gb it behaved very erratically. But the game
    > works well in Win2K and WinXP with 1Gb of RAM.
Ask a new question

Read More

Mice Games Video Games