Sign in with
Sign up | Sign in
Your question

Getting Checksum Errors on Gigabit Ethernet Cards

Last response: in Networking
Share
Anonymous
October 28, 2004 7:23:55 AM

Archived from groups: comp.dcom.lans.ethernet (More info?)

About 18 months ago we upgraded all of our key servers to use fiber optic
gigabit ethernet cards. We went with Compaq NC6136 cards attached to an
Extreme Networks Summit 48 gigabit ethernet switch, and several servers are
attached to Cisco 2948 switches with gigabit ethernet modules added. To
my horror, in chasing down some other network issue, I have seen today on a
sniffer that every one of the machines with these cards is giving repeated
checksum errors on TCP connections. I verified carefully that the only
interfaces giving checksum errors are the gigE cards, and all of our 100
megabit over copper interfaces are working perfectly.

Is there some trick to configuring settings on a gigabit ethernet card under
Windows 2000, or alternately to making these cards work with a fiber optic
card on an ethernet switch? I had thought that this would be a pure plug
and play operation, and that fiber optic gigE would reduce latency at very
least. A few bad connections I could possibly believe might be caused by
dirty fiber cables, but because every one of six interfaces is exhibiting
the same defect, I am more inclined to believe that we have messed up on
some configuration issue for the cards under Windows 2000, or alternately
some settings on the switch.

Any advice on what might be causing these checksum errors is appreciated.

--
Will
westes AT earthbroadcast.com
Anonymous
October 28, 2004 6:02:58 PM

Archived from groups: comp.dcom.lans.ethernet (More info?)

CHANGE USERNAME TO westes wrote:
> About 18 months ago we upgraded all of our key servers to use fiber optic
> gigabit ethernet cards. We went with Compaq NC6136 cards attached to an
> Extreme Networks Summit 48 gigabit ethernet switch, and several servers are
> attached to Cisco 2948 switches with gigabit ethernet modules added. To
> my horror, in chasing down some other network issue, I have seen today on a
> sniffer that every one of the machines with these cards is giving repeated
> checksum errors on TCP connections. I verified carefully that the only
> interfaces giving checksum errors are the gigE cards, and all of our 100
> megabit over copper interfaces are working perfectly.
>
> Is there some trick to configuring settings on a gigabit ethernet card under
> Windows 2000, or alternately to making these cards work with a fiber optic
> card on an ethernet switch? I had thought that this would be a pure plug
> and play operation, and that fiber optic gigE would reduce latency at very
> least. A few bad connections I could possibly believe might be caused by
> dirty fiber cables, but because every one of six interfaces is exhibiting
> the same defect, I am more inclined to believe that we have messed up on
> some configuration issue for the cards under Windows 2000, or alternately
> some settings on the switch.
>
> Any advice on what might be causing these checksum errors is appreciated.
>


If the a GIG ethernet cards is based on the intel gig ethernet chip
(which the Compaq NC6136 are) you need to turn off the "offload
checksums" options

go to the card configuration - open network connections, right click on
the card and select propertoes. Click on the "configure" button, then
select the "advanced" tab.

Make sure "offload receive IP checksum", "offload receive TCP checksum",
"offload transmit TCP checksum", and "offload transmit IP checksum"
are all set to "off" (these are the settings in the intel driver - I
assume there is something the same or similar in the Compaq Driver)

I found that out by running a sniffer for something totally unrelated -
and I saw exactly what you say you see. Doing what I describe above made
the checksum errors go away.

-T. Sean Weintz
!