Sign in with
Sign up | Sign in
Your question

GA-965P-DS3 Windows XP Pro Install Issue (RAID 0)

Last response: in Motherboards
Share
August 24, 2006 3:38:58 AM

Thanks for reading this post. I hope that someone can offer a solution to my problem.

I want to perform a clean install of XP on my RAID 0 array, composed of two 250GB SATA disks. During setup I press F6 and supply the drivers that I downloaded from the Gigabyte website. My array is visible to the install routine and I am able to partition and format the drive. The rest of the install goes as planned until the final reboot at which time I get the Windows XP splash screen for just a couple of seconds and then my system reboots itself. This loop goes on for as long as I let it. It doesn't matter if I choose Safe Mode or any other option, the system crashes every time.

I read another post where the same problem was solved by disabling everything in the BIOS except the bare essentials. I did the same, leaving just USB support for my keyboard and mouse and loading fail-safe defaults for everything else. I right-clocked my CPU for the install and underclocked my RAM to 533 MHz. I even disconnected the USB keyboard and mouse and went to PS2 for one attempt. Same result. My BIOS revision is at F4 - the latest that I could find on the vendor's website. I updated it after first discovering this problem when I was at revision F2.

I got around this problem once by installing XP on a lone SATA drive which I then cloned to the RAID array using Symantec Ghost. I don't want to have to do this again because a) I now have 100 gigs of MP3s on that SATA drive and b) This should just work. I have installed XP dozens of times (maybe hundreds of times) on RAID arrays without any trouble. I know that the hardware is working properly because I am working from the array at this very moment. I suspect a conflict of some sort but I'll be d*mned if I can find it.

Any thoughts? Thanks in advance!


*Update September 24, 2006*

Blew away all partitions and started from scratch. No go.

Tried Windows Vista RC-1. It installed using the Win XP F6 driver but went into the same reboot loop. No problem installing Vista on single SATA drive. My first experience with Vista - it looks promising. Too bad that it didn't solve the problem.

Contacted Gigabyte support. Technician suggested different procedure for making F6 disk. Gave it a shot - same result. Note - be sure to use phone support. E-mail support takes 7-10 days to get a canned answer. No thought went into reply. Thank God for Tom's forumz!

Updated to BIOS F5. Same result.

Maybe I have that one particular mix of hardware that causes a problem. The thing is, I can load XP onto a regular drive and then use a cloning tool like Symantec Ghost or Acronis True Image to clone XP onto the RAID drive. This works every time. The computer boots from the array too.

If you have any thoughts - please disregard the overclocking info in my sig when formulating your answer. I perform all installs at stock speeds.

Thanks.
August 24, 2006 1:03:17 PM

Quote:
Have the BIOS updated to F4 and try again.
Leave your CPU at stock speed too udring Windows installation. :wink:


Thanks, wusy.

I have entertained the thought of updating the BIOS again. I used the Windows version of the Gigabyte updater to flash it the first time. I think that I'll go back to the good 'ol fashioned floppy disk next time.

Downclocking the CPU was the first thing that I tried, of course. I kept the memory timing loose during the install too, just in case.
August 25, 2006 10:35:00 PM

I downloaded the RAID driver for that board. Looking at the txtsetup.oem file that comes with that driver, it looks like when you try loading the driver from the floppy with F6, you should see a menu like this:

Quote:
GIGABYTE GBB363 RAID Controller (Windows 2K/XP/2003)
GIGABYTE GBB363 AHCI Controller (Windows 2K/XP/2003)
GIGABYTE GBB360 RAID Controller (Windows 2K/XP/2003)
GIGABYTE GBB360 AHCI Controller (Windows 2K/XP/2003)
GIGABYTE GBB366 RAID Controller (Windows 2K/XP/2003)
GIGABYTE GBB366 AHCI Controller (Windows 2K/XP/2003)
GIGABYTE GBB361 RAID Controller (Windows 2K/XP/2003)
GIGABYTE GBB361 AHCI Controller (Windows 2K/XP/2003)


If this is the case, I'm guessing you chose the wrong controller when you attempted to install XP. It's possible one of those drivers is very close to the correct one. Close enough that the Windows installer can see the array and copy files to it, but not exactly right so you get a BSOD and an automatic reboot when you try to get to the desktop.

Sadly, Gigabyte's website doesn't tell me which controller this board uses. Same goes for the manual. But since you have XP running on the RAID array right now, you might be able to find out. Here's what you do:

Open the Device Manager and find the RAID controller. Right click -> properties. Click the details tab and select Hardware IDs from the dropdown box. Then look in the RAID floppy you created for txtsetup.oem and pop it open in Notepad. Look for a bunch of lines that start with "[HardwareIds.scsi." See if the hardware ID in the Device Manager matches up with anything that comes after "id = " in txtsetup.oem. That'll tell you which controller in the menu is the one you're using.

For example, let's say you see the hardware id "PCI\VEN_197B&DEV_2360&CC_0104" in the Device Manager. Then you see the line 'id = "PCI\VEN_197B&DEV_2360&CC_0104", "Jraid"' in txtsetup.oem. Look at the line above that: [HardwareIds.scsi.JMicron_RAID_360]. Take the bolded part and look for it near the beginning of txtsetup.oem, under where it says "Component section." Lo and behold, there's a line that starts with "JMicron_RAID_360," and to the right of the = is "GIGABYTE GBB360 RAID Controller (Windows 2K/XP/2003)." Then that's what you need to select when loading the driver with F6.

I don't know if what I just wrote makes any sense at all. LOL! But I hope it helps should you need to reinstall Windows.
Related resources
August 26, 2006 5:17:04 AM

Wow, great post, smeghead4269. A very detailed reply, which I appreciate.

Yours was a good guess, but I had already tried both the 363 and the 360 driver. My board must use the 363 because when I chose the 360, Windows setup reported "no disk drives found". The 363 RAID driver is the only one that lets me see the array during setup.

I spent another few hours trying to get this to go, with no luck. I would outline everything that I tried but it's late and I'm toast. I think that a file called JGOGO.SYS is at the root of the problem. I'll research it tomorrow.

Thank god for Acronis True Image. It allowed me to take a snapshot of my working copy of Windows and after all of the experiments had failed, I used it to revert to my original configuration.
August 26, 2006 2:09:47 PM

Hey wusy,

Thanks again. Unfortunately, Gigabyte didn't enable the RAID support in the ICH8R and hence had to add their own RAID controller to the board.

I'm starting to miss my ASUS P5LD2 with its Intel Matrix RAID. I loved having both RAID 1 and 0 on the same two drives.

I flashed the BIOS to F4 again using the QFlash utility in the BIOS, for insurance.

I borrowed a spare SATA drive from work and loaded Windows on it. The array was visible to the OS and everything was working well. When I cloned the lone C partition to the RAID C partition, Windows would boot but would never build the desktop. I have a feeling that it has something to do with the fact that there is a D partition on the array where all of my data is stored. This technique worked the first time, but I had only a C partition at the time and the rest of the drive was just free space. I know better than to trust my data to a RAID 0 array so I have a seperate full copy of my stuff on an external USB drive. I may just blow away everything on the array and start over.
August 26, 2006 7:37:37 PM

Quote:
Oh, thanks for telling me that. Didn't realise DS3 used ICH8 instead of ICH8R.
My bad.

I just re-read you original post again and realised all my above suggests are all wrong! :oops: 

The problem is definitely a bug in the driver which isn't unusual for such a young controller.
If you haven't, try the latest driver 1.12.01.00 (08/01) here and try again.

Good luck!


I appreciate you taking a shot at it just the same!

I agree - it has got to be a driver bug. I think that I will make a F6 disk using the drivers off the CD, not the website, and then I will blow away all of the partitions and start over. I might even try XP 64 bit for the h*ll of it though that means giving up on my 5 year old ATI TV Wonder. This particular copy of Windows that I'm using is stable for the time being. I just wish that I had taken a snapshot of it before I started loading applications and whatnot. I like to have a squeaky clean image to fall back on just in case I break Windows XP while experimenting with drivers and programs.

I'll report my experience with the clean install as soon as I summon the patience to try it again.

Thanks!
August 26, 2006 8:09:12 PM

Quote:
Yours was a good guess, but I had already tried both the 363 and the 360 driver. My board must use the 363 because when I chose the 360, Windows setup reported "no disk drives found". The 363 RAID driver is the only one that lets me see the array during setup.


Did you try the others (366, 361) ?

It's an oddity of the Windows XP text-mode install interface, but when you pull up the driver from your floppy disk, only 4 lines of text (4 drivers) are shown on the screen, with no indication (no scroll bar) that there might be more. Use the down arrow on your keyboard to scroll to the other drivers.

Try the 366 and 361 drivers if you haven't already.
August 27, 2006 2:53:51 PM

SomeJoe7777,

I'll kick myself if you're right! I knew about the scrolling thing but I hadn't thought of it in this case because I didn't know what controller was being used. When the 363 worked instead of the 360, I assumed that I had the right driver.

I'll give the others a try and will report back. Thanks!
a b V Motherboard
August 27, 2006 3:21:39 PM

forgive me if im wrong, but i think it was the 363 that was the right 1... I have the same board, and went to great lengths to disable raid. However, under my device manager properties list, it only lists the device as "gigabyte GBB36x Controller" implying the pc doesnt know...

Here's some pretty pics incase others can make a better call, but i believe its the 363


August 27, 2006 10:25:39 PM

Quote:
The controller uses on the DS3 is a JMicron JMB363.

http://www.jmicron.com/Products.html
JMB363- PCIe to 2*SATA II and 1*PATA Host Controller


Yeah, I have been using the 363 driver all along. I'll have a look to see if I can download the driver directly from the vendor. The problematic driver has been the newest one which I obtained from Gigabyte's website.
September 29, 2006 3:12:38 PM

Did anyone find a solution for this? I'm having the exact same problem.
Stayed up working all night on it.
Any help is appreciated.
September 30, 2006 12:45:24 AM

Thanks rushfan, your advice worked.

I installed onto a single sata drive, cloned it and copied to to my raid, wish there was an easier way, but it worked.

Thanks again.
October 15, 2006 5:52:11 PM

I have exactly the same issue installing Vista RC2 (and RC1 too) on my motherboard Gigabyte GA-965P-DQ6 bios F6 with GBB363 RAID Controller driver from Gigabyte site. It causes an error STOP 0x0000007B in an early stage of installation, clearly caused by the RAID Driver.
I've tried to load JMicron JMB36x drivers since I thought that Gigabyte renamed it GBB363, but it's not working at all (Version V5.1.2600.104, Feb 2006), I've just spent a full night of trials with no success.

Any idea where to get a recent working driver, since while Gigabyte advertises "Vista Ready" for this motherboard, they don't seem to care about drivers for their own chipset...

Thanks for any help!
October 15, 2006 9:23:39 PM

Have you tried the new drivers on Gigabytes website? They are dated 10/11/2006 that might help, you may also want to update your bios.

There is also a GBB36X version 1.16.1.0 driver available from windows update, but the only way to get it is through windows update, kind of a chicken and the egg thing going on. word of caution, update the driver through device manager NOT windows update.

I had to install my Raid like rushfan did. Install onto spare drive, load all drivers, then used XXclone (or ghost) to copy to raid.


Let me know if any of this helps.
October 15, 2006 9:33:13 PM

I updated the BIOS to F7 and downloaded the new drivers. I might give it another shot tonight. I'll post the results.
October 16, 2006 1:22:32 AM

BINGO! :D 

That last combination did the trick. I don't know if it was the BIOS upgrade or the new drivers but whatever it was, it worked! I had no problem whatsoever installing Windows directly onto the array.

As an added bonus, I learned a thing or two about cooling this week and was able to bring my E6400 back up to 3.40 GHz. The CPU idles at 45C (1.3625v) with the HSF at 2200 RPM and I'm pretty sure that there's a few ponies left in there. I read that BIOS F7 helps with overclocking. It might improve more than just that.

I can finally enjoy owning this DS3 to the fullest. The inability to install Windows on the GSATA II controller prevented me from feeling truly satisfied with this board. I can now state unequivocally that this is the best motherboard that I have ever owned.
October 16, 2006 2:18:33 AM

Glad it worked. I'm guessing it was the new raid drivers, but who knows.
Hopefully this will help others with the same problem.
Cheers!
October 17, 2006 2:44:13 AM

I’ve tried "new drivers" 1.14.0 on Gigabyte web site dated 10/11/2006... But actually when you download and open the zip file, it's indeed version 1.14.0, but the oldest file of the entire archive is dated July 2006 -- it just keeps rebooting during installation. It’s no “new version” at all.

Then I've found JMB36X driver 1.14.1 on http://www.x-drivers.ru/index.php?option=com_remository...
This time installation was able to go further, but just before final reboot, Vista setup tells that it has not been able to prep my system for final reboot and stops installation there. Failing so close to the end :-(

Finally I followed your advice and tried version 1.16.1 of the drivers downloadable through Windows Update for Windows XP, and I've finally been able to install successfully Windows Vista RC2 on a RAID partition controlled by Gigabyte GBB366 controller on my GA-965P-DG6 motherboard. At least it works! :-) Now I've 6xHD SATA 750GB controlled by Intel ICH8R (2/RAID1, 4/RAID10) and 2xHD SATA 500GB (2/RAID1) controlled by Gigabyte GBB366, all working together, nice (and warm !)

The tricky part is how to download files of driver 1.16.1 -- I've spent a long time around Windows Update site with no success. Finally I've updated the driver using a Windows XP partition (it breaks IDE access, so later a driver rollback is required), and then after installation (and before reboot of XP!) you find all files of driver 1.16.1 in an "install" subfolder of C:\Windows\SoftwareDistribution -- just copy these files on a floppy, and you're ready for Vista installation !

Here is the list of files for 1.16.1 package of drivers 32 bit for JMicron JMB36X and GIGABYTE GBB36X:
08/23/2006 02:56 PM 3,398 xraid_f.inf
08/23/2006 02:56 PM 4,464 xraid_i.inf
02/07/2006 07:52 PM 6,912 jgogo.sys
09/04/2006 01:48 PM 22,090 jraid.cat
08/23/2006 02:54 PM 42,752 Jraid.sys
08/23/2006 02:56 PM 3,595 jraid_f.inf
08/23/2006 03:21 PM 11,113 jraid_i.inf
06/06/2006 02:53 PM 3,275 txtsetup.oem

I suppose there might be a more direct method to download these drivers directly from some site, but if someone is interested, I've no problem sharing these files.

Thanks again for your suggestion to use this driver !
October 17, 2006 2:57:37 AM

Zorglub38, Glad to hear it worked.
Can you zip up the 1.16.1 drivers and post them?

Thanks.
October 17, 2006 11:54:38 AM

Cool, thanks. I wonder why these 1.16.1 drivers are so hard to obtain.
October 18, 2006 7:29:09 AM

i have almost the same problem , i have a GA-965P-S3 and after i set the partitions in win setup and it formats the drive , whan it start to copy the files to the drive from the floppy it saiz that i cant copy jraid.sys ..... and all the others on the floppy, and i can skyp them all but after the first reboot i have that same problem as all of you have and the latest driver posted didn't help
October 18, 2006 11:02:01 AM

Do you have the latest F7 bios? It sounds like it may be a problem with your floppy disk or floppy drive. Do you have a different on you can try? Others have said that they've had succes with the F7 bios, and the drivers dated 10/11/2006 off the gigabyte website.

For those who have gotten it to work, what kind of speeds are you seeing in sandra physical disk test? I'm getting 127MB/s.
October 18, 2006 8:47:35 PM

i have managed to get it to install properely by integrating the drivers into the windows xp setup cd with nlite .

i thought that the newest bios is F6 or atleast thats on their site)
I have the 965P-S3 not the DS3 ver
March 6, 2007 2:37:38 PM

Quote:
The controller uses on the DS3 is a JMicron JMB363.

http://www.jmicron.com/Products.html
JMB363- PCIe to 2*SATA II and 1*PATA Host Controller


Thank you!! Little nits like this drive me nuts. I know it probably doesn't matter what choice you make because the same driver files are used ... but then again I really don't know what is happening under the covers with Windoze drivers so I'd rather not leave choices like this to guess-work.

One point though. I think the correct chipset ID would be the JMicron JBM366, not 363.
JMB366: PCI Express to 2 SATA II port and 2 PATA port Host Controller

The Gigabyte GA-965P-DS3 supports 2 SATA and 2 PATA ports off of its JMicron. (1 PATA connector supporting 2 PATA ports/devices, no?)

As another person mentioned, when you use "press F6" to install these drivers during a windows' install you have to use down arrow to scroll down the list to select the "Gigabyte GBB366" controller in the list of drivers displayed. (Never knew about that either :(  :evil:  )

Anyway, thank you very much again Wusy!

-john, the ostensibly clueless redundant legacy-in-transition
a b V Motherboard
March 6, 2007 10:27:31 PM

no its only 1 physical pata connector. So its JBM363
March 6, 2007 11:29:43 PM

Quote:
no its only 1 physical pata connector. So its JBM363

Yes, digging into it further it appears you (and wusy) are correct and I'm wrong. Darn and tarnation! I hate when that happens! :evil: 

I went a step further and opened up the product brief PDF docs for the JM363 and the JM366. On the second page is a bullet point saying how many "storage devices" are supported. The JM363 supports up to 4 devices and the JM366 supports up to 6. Since clearly two of those devices are SATA that means the JM363 supports 2 PATA devices (1 connector) and the JM366 supports 4 PATA devices (2 connectors).

-john, the more clueless than usual dinosaur
a b V Motherboard
March 6, 2007 11:34:19 PM

ya live and learn, no worries.
January 8, 2008 3:12:21 PM

I have the exact same mainboard (GA-965P-DS3 F12) and just installed two WD3200AAKS drives into RAID0. Haven't installed windows on it yet but I will. First there's an issue that I can't figure out.
I've read many forums before and most people report very high transfer speeds for RAID0, as jmandawg did also, 127MB/s.
My results are way low. Sisoft Sandra reports 81MB/s for the RAID array. Could please someone tell me if I'm doing something wrong or not doing something in order to obtain that speed?
March 16, 2010 6:48:59 PM

I know this thread is old but I'm having the same problems.

First of all, does anybody have the 1.16.1 driver for XP, I cant find it and the link on this forum is dead. ALL the drivers people mentioned from this thread don't work for me with XP. Haven't tried the 1.16.1 driver though, thats why I want it.

Second, has anybody used this motherboard to install windows 7 with raid? I want to install windows 7 64bit with raid, but the drivers I get off the sites for 64bit are not working with windows 7. If anybody has gotten this mobo to work with windows 7 and raid please tell!!

Either way if I get XP or 7 working with raid I will be very happy!!
a c 177 V Motherboard
March 16, 2010 7:16:42 PM

Well, the only place I could find (other then the 'broken' link you already posted to is here:
http://www.famouswhy.com/download_sitemap.html
But, GFL! :fou:  I'm thinking by the time you locate it there, and verify it's actually what you want, we will all be using quantum entanglement storage to other probability dimensions...
March 16, 2010 8:05:56 PM

Ok I found out some things. The floppy I was using for my XP installation was bad, so I got a working one. The driver off the CD worked with XP (kinda). It saw the raid drive and copied the files over to it. Once it restarted after the I got this error:

Quote:
Windows could not start because of a computer disk hardware configuration problem. Could not read from the selected boot disk. Check boot path and disk hardware.

Please check the Windows documentation about hardware disk configuration and your hardware reference manuals for additional information.


I looked for solutions to this and some people were saying you needed to jump your hard drives for sata 150 instead of sata 300. I can't find a manual for my hard drive anywhere though, and theres no jumper directions on the hard drives themselves.

Well since the drives did get formatted to NTFS. I loaded up my Windows 7 64bit cd and loaded the 64bit raid drivers from the CD. It saw the raid setup and installed. After the first reboot I saw the windows 7 pulsating logo. About 5-7 seconds after that it just blue screens and reboots. I tried safe mode too it did the same thing.


Just for information I'm using two of these drives:
http://www.wdc.com/en/products/Products.asp?DriveID=732
Model: WD2003FYYS

If anyone knows any solutions plz tell, thanks in advance!!
a c 177 V Motherboard
March 16, 2010 8:37:04 PM

In the meantime, the 150 jumper:
http://wdc.custhelp.com/cgi-bin/wdc.cfg/php/enduser/std...*Wj&p_accessibility=0&p_redirect=&p_srch=1&p_lva=&p_sp=cF9zcmNoPTEmcF9zb3J0X2J5PSZwX2dyaWRzb3J0PSZwX3Jvd19jbnQ9MjA4LDIwOCZwX3Byb2RzPTIyNywyODMmcF9jYXRzPSZwX3B2PTIuMjgzJnBfY3Y9JnBfcGFnZT0x&p_li=&p_topview=1
I'll keep 'hunting' for info...

VERY good drive choice - I'm waiting for prices to descend a bit, need at least a half dozen. Gotta tell you a bit of a story, confirming your choice of WD 'enterprise' drives. Have a couple RE3s in a RAID1; 'bout ten months in, lost one... Took all of about two hundred seconds to go to WD site and: confirm drive was kaput... confim serial # was still 'in warranty'... guarantee a 'cross-ship with a credit card... TWO MORNINGS LATER, drive 'appeared' on my porch!! Took five minutes to 'unrack' the bad one, slide in the new; two hours later - array rebuilt, never a byte of my data 'at risk'! :love:  WD will sell me drives, pretty much forever! VERY glad to see they've finally started offering SSDs - wouldn't want one from ANYONE else!! Don't even wanna talk about what it took to fix one of my Seagate 1.5s with the dreaded "Seagate Stutter" firmware [:bilbat:3] And, recently 'lost' a 750 PSU - guaranteed a (so-called) 'cross-ship' - took THIRTY-ONE days for new one to arrive! :fou: 
March 17, 2010 5:49:10 AM

bilbat said:
VERY good drive choice - I'm waiting for prices to descend a bit, need at least a half dozen. Gotta tell you a bit of a story, confirming your choice of WD 'enterprise' drives. Have a couple RE3s in a RAID1; 'bout ten months in, lost one... Took all of about two hundred seconds to go to WD site and: confirm drive was kaput... confim serial # was still 'in warranty'... guarantee a 'cross-ship with a credit card... TWO MORNINGS LATER, drive 'appeared' on my porch!! Took five minutes to 'unrack' the bad one, slide in the new; two hours later - array rebuilt, never a byte of my data 'at risk'! :love:  WD will sell me drives, pretty much forever!



Yea I love their drives, the enterprise edition is like a beefed up black caviar. I guess all the jumper details they give for my drive are just for ssc. No sata 150 settings. go figure.

Just on a side note, if I use these as single drives, and install an OS on one. What's the performance increase I would get over my current desktop drive that has a 16mb cache (hitachi deskstar). I don't won't to reformat unless I will get a performance increase.
a c 177 V Motherboard
March 17, 2010 2:30:32 PM

I really don't think you're gonna see anything subjectively 'notceable' - these are BIG drives, not particularly fast drives (but they are fast for big drives - twin controllers and big cache)

Might want to take a peek here:
http://www.tomshardware.com/reviews/2tb-hdd-energy,2371...
!