Sign in with
Sign up | Sign in
Your question

The sims medieval wont play

Tags:
  • Sims
  • Games
  • Windows 7
Last response: in Windows 7
Share
May 21, 2011 9:57:50 PM

Hello,
I have installed the new game The Sims Medieval, but when i click on the icon, it does nothing and when i select autoplay, my computer crashes.

i have reviewed faq's from others that have had issues and installed .net version 4, sp1 and even tried disabling all windows products in case another program was interferring with it opening, all to no avail.

Does anyone have any suggestions to try that i haven't already tried?

More about : sims medieval wont play

May 21, 2011 10:46:26 PM

Try running it with admin privilages

Or else if still doens't work, then:
- Navigate to your Sims folder (go to computer > C drive > Program files .. .. ) something like that, and execute the .exe like that. There maybe a few exe's, so try each of them.

If still not work...
Uninstall the game (if it asks you to delete user data, click yes since you havn't played it)
- Uninstall .net framework
- then install the game. It may ask you to install .net framework or it may do it automatically.
- try it, if not work or says needs .net framework, install .net framework v2
m
0
l
May 22, 2011 7:56:17 AM

When you say "crashes" what exactly do you mean? A blue error screen? Reboot? I would go into computer properties (right click on computer, choose properties), then choose advanced properties, then startup & recovery, finally make sure that automatically restart isn't checked. That way you can see the blue screen error and let us know what it is. Also I would update your display drivers, and direct X. If that doesn't work I'd check to see if graphics card or chip isn't overheating, memory (RAM) isn't faulty(run memtest86 to check), and that your hard drive is ok(use seagate seatools or whichever program is for your manufacturer).
m
0
l
!