Read Only folder attribute always greyed out Win2k3

Archived from groups: microsoft.public.win2000.file_system (More info?)

More of an annoyance, but something that has puzzled me. Is the "Read-Only" attribute of a Windows 2003 folder obsolete with the addition of Inheritance and the complex security underlying the file system now. It appears that no matter what you check on the folder propertied for the "read-only" attribute it is always grey (as to say that only some of what that option does is selected). If you were trying to make it read only by selecting that, it does not work, even if you disable inheritance on the folder. If you go into the folder securit and manually make it "read-only" you still do not get and satisfying fully checked (not grey) check box. Inversely, if everyone has FULL access the checkbox does not show as "All white". If you look at the "?" help on the box it states that "initially" this folder is always in a mixed state (grey). How to you make it leave its mixed state?

We are trying to come up with an answer to calm those above us, that this "age old" method of making a folder read-only does not indicate what they are thinking it shows.

Thanks!
1 answer Last reply
More about read folder attribute greyed win2k3
  1. Archived from groups: microsoft.public.win2000.file_system (More info?)

    NTNEWS <anonymous@discussions.microsoft.com> wrote: > More of an
    annoyance, but something that has puzzled me. Is the "Read-Only" attribute
    of a Windows 2003 folder obsolete with the addition of Inheritance and the
    complex security underlying the file system now. It appears that no matter
    what you check on the folder propertied for the "read-only" attribute it
    is always grey (as to say that only some of what that option does is
    selected). If you were trying to make it read only by selecting that, it
    does not work, even if you disable inheritance on the folder. If you go
    into the folder securit and manually make it "read-only" you still do not
    get and satisfying fully checked (not grey) check box. Inversely, if
    everyone has FULL access the checkbox does not show as "All white". If you
    look at the "?" help on the box it states that "initially" this folder is
    always in a mixed state (grey). How to you make it leave its mixed state?

    So far as I can tell, setting the read-only option on a folder in any of
    the NT-series Windows versions has never had any significant effect. The
    only differance I can see on Win2K between a folder with the read-only
    attribute set and one without is that setting the read-only attribute
    causes Explorer to honor the desktop.ini options when that file is
    present. In this respect it's no different from the system attribute.

    --
    Gary L. Smith gls432@yahoo.com
    Columbus, Ohio
Ask a new question

Read More

File System Read Only Windows Server 2003 Windows