Sign in with
Sign up | Sign in
Your question

Restoring a raid 1 array that was created through Win XP Pro

Last response: in Storage
Share
August 27, 2006 6:36:15 PM

OK I have 3 drives in my system. One 80 gb ATA drive that is my system drive that has all my programs and windows installed on it. Then I have two identical 150 gb SATA drives.

I wanted to setup a RAID 1 array with the two drives but ended up buying a controler that didn't have the ability built in. Windows XP Pro, allows you to setup RAID 0 array through the OS, but only Windows 2003 Server will allow you to setup a RAID 1 (mirrored array) through the OS. However, I found an article on this site, and a couple other sites that explained how to trick Win XP Pro to think it's Window 2003 server and thus allow you to created a RAID 1 array.

I got this working, but with out even thinking I recently reinstalled windows. So now obviously my raid array doesn't show up. So I have a couple questions now.

1) If I edit the system file again in windows to enable mirroring should my raid array show up?

2) I bought another controller that has RAID 1 and RAID 0 on the card, but I have not installed it yet. If I plug these two mirrored drives into the new controller, will the controller recongnized that they were recently part of a mirror array?

3) I'm starting to understand that while a RAID 1 array does copy all the information to every drive, each drive is not formated the same as if it were on it's own. Am I right in saying that restoring data from one or more drives that were in a RAID 1 array is dependent on the controller used to initial setup the array?

4) Are there any kind of standards for how a RAID array is created. Or is "RAID" just the idea that you can mirror or stripe data across multiple drives, and each developer manufacture figures out their own way in which they want to do it?



Eric
August 27, 2006 7:13:51 PM

You are right about devices not using a particular standard. Software RAID through windows can be read by ANY windows machine. Just make the hack and import the disk it will say it's missing it's partner, import the second drive and it should start the rebuild.

If you have the controller make a RAID1 it will destroy your data and if the controller ever fails you need the same model or a compatible model to read the RAID array.

For that reason alone, if speed is NOT important, use windows RAID, then you can stick one of the drives in any computer and get your data back.

Quote:
3) I'm starting to understand that while a RAID 1 array does copy all the information to every drive, each drive is not formated the same as if it were on it's own. Am I right in saying that restoring data from one or more drives that were in a RAID 1 array is dependent on the controller used to initial setup the array?


Not quite sure what you meant by this, the drives are formatted exactly the same under windows when put in a RAID array, that's why you can boot from either and it will be the same. I assume you are refering to what I said above about how different cards may format differently than windows, yes it's the way they place the meta data describing the array that will be different. Most RAID controller brands use their own methods so you are locked into that brand.
August 27, 2006 7:26:08 PM

OK the old controler I have is an Adaptec SATAConnect 1205SA.

I'm running an absolutly fresh version of windows XP pro. I have the controler plugged in and one of the drives plugged in. When my computer boots, I see that it dectects the card. While the controler is running through it's bootup process I can press f3 to enter the "configuration utility". The options it gives me are

Press F1 to assign first (HDD) set
Press F2 to remove first (HDD) set
Press ESC to exit

I haven't done anything yet. But when I get into windows and go to device manager I neigther see the card nor the drives. Although I still need to do the hack to enable raid.

Eric
Related resources
August 27, 2006 7:26:51 PM

Oh and the manual for that card does not mention the configuration utility.


Eric
August 27, 2006 8:13:41 PM

Ok i found another manual and figured out that the "configuration utility" is for setting boot drives. Which i don't care about. I moved the controler up 1 PCI slot from the bottom to the 2nd from the bottom, and now windows sees the cards and the drives.

I plugged in one drive, and opend up diskmanager. It said the drive was stale, and when I right clicked on the disk I had the option to import the "foreign" disk. I didn't bother doing that, but in hind sight maybe I should have.

Turned off my computer, and plugged in both drives. Now both drives came up but each drive was colored red, and the status was "failed". Ugh

So I turned off my computer again, and uplugged one of the drives just to be safe.

If I right click on one of them the only option I have is to "reactivtate". I tried this, but the drive still says "failed". There no way that these drives have failed as they are both brand spanking new.

Now the only option I have is "remove mirror".

Is it saying the drive is failed because it knows it's part of a mirror, and can't find the other drive, thus the *mirror* failed not the drive? I had an option to "remove mirror". I did this, but now the drive is a "simple volume" but the status is still "failed".


Eric
August 27, 2006 8:19:57 PM

Any chance that the problem I'm having has to do with the fact that mirror between these two drives was created with XP SP2, and now I have a fresh (non-SP2) system??


Eric
August 27, 2006 8:20:31 PM

Definately choose import foreign disk, that's the key to the hole thing. After you do that to both you can reactivate (might do this automatically) then rebuild.
August 27, 2006 8:23:03 PM

SP2 will matter if SP1 wouldn't see the 150GB drives, limit of 147 so it's possible. Also, why didn't you just try the drives on the original ports they were plugged into? It will just make matters worse changing more variables like which controller they are on.

You should still be able to import as long as you didn't delete any partitions.
August 27, 2006 9:09:42 PM

OK I only got the import foreign disk option the first time I had one drive plugged in right after I moved the controller up one slot. But I did not do anything at that point

After that I figured I'd plug in both drives to see if windows would just reconginzed the array. It saw both drives, but then it said the drives have failed.

So then I shutdown, and unplugged on of the drives. Restarted and it was still "failed". There was an option to reactivate, so I did that but it still said "failed". That enabled an option to "remove mirror". I tried that and removed the "missing disk" mirror (the other unplugged drive).

Now that drive is shown as a "simple volume", and still has a "failed" status. And the only option I have is to delete volume, which I know is not something I want to do.

I'm not sure what ports they were originaly plugged into. The powersupply on my computer died recently, and I ended up moving everything into a new case. So I figured what the heck, might as well reinstall windows as well, which started this whole problem. So both drives are still plugged into the same (non-raid) 2 port controller, but I"m not sure if they are plugged into the exact same ports.

Windows recongnizes that the drive is 149.05 GB. I'm going to try upgrading to SP2 to see if that is the problem.


I'm still using the original controller the new one with raid support is still shrink wrapped in the box.
August 29, 2006 3:48:52 AM

Ok well after upgrading to SP2, I was able to restore the data off the drive I hadn't done anything too.

I started messing with the controller I bought with RAID support but now I'm starting to think that I'd prefer just running it through windows. Although I don't like the idea of having to edit system files with a hex editor to be able to access my data. Is there a more *legit* way of adding support for RAID 1 to windows XP pro?

Does anyone know what kind of software RAID vista is going to support?


Eric
!