Sign in with
Sign up | Sign in
Your question

Win98 SE Program Startup Question

Tags:
  • Control Panel
  • Windows
Last response: in Windows 95/98/ME
Share
Anonymous
July 23, 2001 7:56:07 PM

I have this one app -- starter.exe -- which is set to autostart on my Win98 SE machine. It is a Soundblaster Control panel applet that shows up in the system tray.
When I go into msconfig and disable it in the startup tab...it come back again checked. I cant get rid of the frikkin thing. Must be a registry key that keeps enabling the stupid thing. I like very little to load at startup on my machine. This annoys me. Can anyone help.

P.S. No it is not in c:\windows\start menu\programs\startup

and the program doesn't have any options/preferences to turn off auto start at boot up.


Thanks in adavance.

More about : win98 program startup question

July 24, 2001 1:18:49 AM

Kill it in the Registry. Run REGEDIT.EXE at the Start\Run-Command Line. Navigate to this key:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run.

I suggest that you export the key value to a folder on your hard drive before you remove it. This way, if there is a problem, you can put it back by double-clicking on the exported file. Highlight the value, and then click Registry\Export Registry File on the Toolbar.

To remove it, highlight the value, right-click, and choose Delete from the drop-down menu.

There are several other "Run" (RunOnce,Run Services, etc.) keys in the same area. Make sure that there is no reference to the icon in any of them.

To be sure of the removal, you should also look in these keys:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run

HKEY_USERS\.DEFAULT\Software\Microsoft|Windows\CurrentVersion\Run

If the key value reappears in the Registry after rebooting ... then there IS an on/off "switch" for the taskbar icon, and you've just missed seeing it in the program's options. This might also explain why you can't seem to kill it using MSCONFIG.

Be sure that there is nothing loading in the CONFIG.SYS and AUTOEXEC.BAT pertaining to the sound card software and this icon.

Post back here if this doesn't fix the problem, and we'll try something else! In Windows, there's always two or three different aspects to solving a problem; if one doesn't work, you just try the next one.

Toejam31

<font color=purple>My Rig:</font color=purple> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=6847" target="_new">http://www.anandtech.com/mysystemrig.html?rigid=6847&lt;/A>
Anonymous
July 24, 2001 5:37:23 AM

tried everything you suggested but it is still there.

the only way I can close it out from the system tray is to ctrl-alt-del and end task on starter.exe. If I then launch c:\windows\starter.exe...it puts it back in the tray and you still can't shut it down without the three finder salute.

I re-checked the utility for some way to disable auto start from within the program but no go. Since I can't even exit the program from the tray I'm not surprised that I can't disable auto start.

This is the first time that disabling an entry in MSCONFIG startup does not keep the program disabled.

Is the thing possessed.

A similar problem...I can't disable my proxy server settings from IE5's Tools | Internet Options | Connection | LAN settings | Use automatic configurations settings.

I don't want to use my Cable providers proxy server as I find it slows down my Internet browsing somewhat. I uncheck the box...delete all mention of "http://proxy:8080" in the registry and reboot. When the system comes back up, the proxy settings are still gone...but I launch IE5 and then go check again and the address is back. Not sure what to try here either. If you or anyone else has another idea I would appreciate it.

Thanks again.
Related resources
July 24, 2001 2:11:51 PM

A couple of things come to mind.

You could temporarily remove the sound card, and delete all trace of the software from your system. Then you could reinstall the OS, without letting it detect the card. That should remove any Registry keys that point to this icon. Then, install the card, but without the sound card software ... nothing but the hardware drivers for the card.

If you decide to reinstall the sound card software, be sure and do a custom installation, without the CD-Auto Detect service ... things like that. Like most bloatware (and that's what I'd consider SoundBlaster software) it tries to install far too many items, most of which are useless and/or redundant.

As for the proxy server ... did you use an installation disk from your cable provider to set up your Internet settings, or did you do it manually? Is the modem USB, or running on an NIC card?

If you used a CD ... jot down your networking settings so you can redo them later, and uninstall the software.

If not, you might have to remove the network settings from your system, and redo them manually.

Post an update!

Toejam31

<font color=purple>My Rig:</font color=purple> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=6847" target="_new">http://www.anandtech.com/mysystemrig.html?rigid=6847&lt;/A>
July 24, 2001 2:23:48 PM

Aother thing that the blaster live does is create an entry in the autoexec file "set blaster=220 blah blah" and no matter how many times you delete it, it comes back!!, anyone know where/how this happens?


Next time you wave - use all your fingers
Anonymous
July 24, 2001 5:06:30 PM

Thanks ToeJam31,

Yeah I made the mistake of installing the @home software from CD. I have since removed all of it but I guess it still lying around somewhere.

Same for the Soundblaster SW. I have removed the software but the starter.exe file is still loading at bootup. I am going to try renaming it to c:\windows\starter.sav and reboot and see how Windoze likes them apples. Probably I will get the message: The registry or system.ini file mentions the file starter.exe...blah blah blah. But we'll see.

I think I'll take your advice and uninstall Network componenets (TCP/IP, adapter, Client for MS) and redo the settings manually.

Thanks. I'll let you know how that turns out.
July 24, 2001 5:35:51 PM

Have you tried running msconfig.exe from the run menu? This often has worked for me in the past. If this does not work I would use file find to find all refferences to the file.
Anonymous
July 24, 2001 10:27:50 PM

Yes I tried that. I uncheck the box and it keeps coming back.
Anonymous
July 24, 2001 10:33:37 PM

Well...I don't know what I did...but it's gone!!!

I was getting ready to rename c:\windows\starter.exe to *.sav to see what wonderful message windows would give me when I tried to boot, and I happened to notice that the icon was not in the system tray. So I reboot and watch for it and it is not appearing.

Thanks for all the help everyone.
July 25, 2001 11:49:16 AM

It must have been reading your posts on this forum :smile: Clever software.
!