Sign in with
Sign up | Sign in
Your question

Service Fails to Start, Path Not Found

Tags:
Last response: in Windows 2000/NT
Share
Anonymous
November 11, 2004 12:05:05 PM

Archived from groups: microsoft.public.win2000.file_system (More info?)

I'm getting an error that a service fails to start because it cannot find the
path to the file that is the service, a License Manager.

I know why the path is not found, as it is on a mapped network drive, V:,
that is a share on a local disk, F:. I have no idea why this mapped drive
was referenced. (Done long before I got here and it's known that when the
server reBOOTs, this service MUST be started manually. Yes, the service is
set to start automatically, and yes, there is an error entry in the Event
Viewer.)

Here is what I have done with no positive results:
- Created a batch file to map the V: drive and
referenced it from the Computer Startup policy.
- Configured the recovery of the service to run this
same batch file and then restart on 1st failure.

Being as neither of these worked, I would like to change the path of where
to find the file, make it the F: drive, but I cannot find a place to change
the path in the service. It is displayed in the properties of the service,
but I cannot change it.

Any and all help greatly appreciated.

AdvThanksance,
John
Anonymous
November 11, 2004 10:47:45 PM

Archived from groups: microsoft.public.win2000.file_system (More info?)

"=?Utf-8?B?Sm9obiBELg==?=" <JohnD@discussions.microsoft.com> wrote in
news:C475ADE4-D549-4406-A66F-9521E15BFF2A@microsoft.com:

> I'm getting an error that a service fails to start because it cannot
> find the path to the file that is the service, a License Manager.
>
> I know why the path is not found, as it is on a mapped network drive,
> V:, that is a share on a local disk, F:. I have no idea why this
> mapped drive was referenced. (Done long before I got here and it's
> known that when the server reBOOTs, this service MUST be started
> manually. Yes, the service is set to start automatically, and yes,
> there is an error entry in the Event Viewer.)
>
> Here is what I have done with no positive results:
> - Created a batch file to map the V: drive and
> referenced it from the Computer Startup policy.
> - Configured the recovery of the service to run this
> same batch file and then restart on 1st failure.
>
> Being as neither of these worked, I would like to change the path of
> where to find the file, make it the F: drive, but I cannot find a
> place to change the path in the service. It is displayed in the
> properties of the service, but I cannot change it.
>
> Any and all help greatly appreciated.
>
> AdvThanksance,
> John
>
>

What you tried was very creative but it can't work like that. You can't
load a service from a network drive, only a local drive. You can change
it by directly editing it in the registry. All services and drivers load
from the key

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services

Run regedit and go to the services key and find the specific service.
You will be able to edit the load of the file there.

Leonard Severt

Microsoft Enterprise Support

--
This posting is provided "AS IS" with no warranties, and confers no
rights.
Anonymous
November 11, 2004 10:47:46 PM

Archived from groups: microsoft.public.win2000.file_system (More info?)

Thank you very much, Leonard. That's exactly what I did, and it worked.
Thanks for the help!

John

"Leonard Severt [MSFT]" wrote:

> "=?Utf-8?B?Sm9obiBELg==?=" <JohnD@discussions.microsoft.com> wrote in
> news:C475ADE4-D549-4406-A66F-9521E15BFF2A@microsoft.com:
>
> > I'm getting an error that a service fails to start because it cannot
> > find the path to the file that is the service, a License Manager.
> >
> > I know why the path is not found, as it is on a mapped network drive,
> > V:, that is a share on a local disk, F:. I have no idea why this
> > mapped drive was referenced. (Done long before I got here and it's
> > known that when the server reBOOTs, this service MUST be started
> > manually. Yes, the service is set to start automatically, and yes,
> > there is an error entry in the Event Viewer.)
> >
> > Here is what I have done with no positive results:
> > - Created a batch file to map the V: drive and
> > referenced it from the Computer Startup policy.
> > - Configured the recovery of the service to run this
> > same batch file and then restart on 1st failure.
> >
> > Being as neither of these worked, I would like to change the path of
> > where to find the file, make it the F: drive, but I cannot find a
> > place to change the path in the service. It is displayed in the
> > properties of the service, but I cannot change it.
> >
> > Any and all help greatly appreciated.
> >
> > AdvThanksance,
> > John
> >
> >
>
> What you tried was very creative but it can't work like that. You can't
> load a service from a network drive, only a local drive. You can change
> it by directly editing it in the registry. All services and drivers load
> from the key
>
> HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
>
> Run regedit and go to the services key and find the specific service.
> You will be able to edit the load of the file there.
>
> Leonard Severt
>
> Microsoft Enterprise Support
>
> --
> This posting is provided "AS IS" with no warranties, and confers no
> rights.
>
!