Sign in with
Sign up | Sign in
Your question
Closed

Safely Remove Hardware icon for internal Hard Drive???

Last response: in Storage
Share
September 3, 2006 6:27:59 PM

I have a WD Raptor 150gb HD that I recently installed on a new build. I didn't notice this problem at first I don't know what made it show up but there is always an icon in my taskbar (the safely remove hardware icon like when you plug in a USB device) asking if I want to safely remove my Hard drive anyone have any ideas? its a sata drive if that has anything to do with it.

AMD Athlon X2 4200+ OC to 2.4
Asus M2N-E MOBO
1GBX2 Corsaird XMS2 DDR2 RAM
HIS Ice-Q ATI X1900XT 512MB
NZXT 500w PSU
WD Raptor 150GB HD
Samsung DVD-RW
Cretive X-Fi Xtreme Sound Card
3x120mm fans & 1x90mm fan in NZXT Lexa Case
September 3, 2006 6:42:59 PM

Quote:
I have a WD Raptor 150gb HD that I recently installed on a new build. I didn't notice this problem at first I don't know what made it show up but there is always an icon in my taskbar (the safely remove hardware icon like when you plug in a USB device) asking if I want to safely remove my Hard drive anyone have any ideas? its a sata drive if that has anything to do with it.

AMD Athlon X2 4200+ OC to 2.4
Asus M2N-E MOBO
1GBX2 Corsaird XMS2 DDR2 RAM
HIS Ice-Q ATI X1900XT 512MB
NZXT 500w PSU
WD Raptor 150GB HD
Samsung DVD-RW
Cretive X-Fi Xtreme Sound Card
3x120mm fans & 1x90mm fan in NZXT Lexa Case


The safely remove hardware feature is designed to let you disable a usb device before unplugging it from your system. It is possible your hard drive is listed as a USB device in DISK MANAGEMENT and appears as such a device on your taskbar. I would just ignore it or possibly look into you WD drive in disk management under properties and see if it is listed as a USB device. Don't know the reason for that.

http://www.helpwithwindows.com/WindowsXP/howto-07.html
September 3, 2006 6:43:29 PM

I've seen hot swap capable sata controllers do this, two of mine do. My NVRAID or SI don't though. However I would suggest against ejecting your hard drive as you may notice a slight decrease in it's ability to do anything until you reboot :) 
Related resources
September 3, 2006 6:51:45 PM

Quote:
I've seen hot swap capable sata controllers do this, two of mine do. My NVRAID or SI don't though. However I would suggest against ejecting your hard drive as you may notice a slight decrease in it's ability to do anything until you reboot :) 


kinda like the time I removed Drive C to the recycle bin with my win 95 setup. I came within a click of not having a recycle bin to revert to 8O
September 3, 2006 6:53:38 PM

I have the exact same problem with my SATA HD, except mine is a Seagate 160 GB 7200.9. I use it with an ECS C51GM-M motherboard, and it has builtin SATA2 support. Its not a seriously problem, I'm just worried that I might accidently eject it when I eject my USB Flash drive. Otherwise I just ignore it.
September 4, 2006 6:46:17 PM

yea, i have the same issue.

Kind of curious if there's away to solve it. Since i do use my flash drive a bit, i'd rather avoid accidently turning off my C:. lol

Oh ya, its a 74gig raptor. P5N32 Mobo
September 21, 2006 10:10:22 PM

Same here...

Its annoying :-)

its a WD 200GB internal

I can optimize it for quick removal lol
Anonymous
a b G Storage
September 21, 2006 10:37:34 PM

That's no problem; thats normal behaviour. Live with it. or get the ignore fix.
September 21, 2006 10:40:26 PM

its not normal, just give us the fix... be constructive... i know you can do it :-)
September 21, 2006 10:48:14 PM

It is normal, its part of the SATA2 standard. If your a noob and you think its not normal heres something to google... hot swapping sata2. :wink:
September 22, 2006 6:52:11 AM

I have 4 PC's all with 2 SATA drives inside all with 2 OS's. And only on one OS it gives me that silly icon which I can't even use anyway. Now I would hardly call that normal from my point of view.

So please stop being sarcastic and arrogant. Why don't I have the icon on my other OS which has the SATA2 hd?
September 22, 2006 7:15:22 AM

Every pc i have ever built with a Sata2 drive has had this icon.

Also though, every one of these pcs has been a WD drive in it, so it could be a WD thing :?:

Have you got windows fully patched on all those systems your running :?:
September 22, 2006 8:26:33 AM

I have no clue... Thx sofar.. When I find out Ill put it here on the forum
September 22, 2006 9:55:28 AM

I think this icon is present because of the hot-swap capabilities of SATA HDDs. windows considers them like removable HDDs.

And this is not limited to WD discs : I saw this on a computer with a Maxtor DiamondMax10 sata drive.
If some of you don't have it, maybe it depends on your sata controller

It must be normal beahviour of the OS. anyway, it would have been smart to add a checkbox somewhere to specify that the disc is internal and cannot be removed. On the other side, it can be useful when your HDD is in a rack
September 22, 2006 10:06:06 AM

IMO, a software tool that permits the ejection of a spindle that is required for the currently-running OS(es) - or perhaps even because it contains open files - is an inept implementation of the standard. It would seem to me that the intent of the standard is not to dictate that a spindle must be swappable at any moment without restriction, but that a spindle might be swappable if its removal is done in an orderly fashion. If the "eject widget" can't effect an orderly shutdown of a device at any given moment, it shouln't offer. Otherwise, the user might as well just cut power to the device or unplug it.
September 22, 2006 1:02:51 PM

Sure, it's stupid to give the user a button to unmount the system drive... but if you try to do it, windows will simply tell you that the volume is still in use, and refuse to unmount it.
September 22, 2006 1:46:17 PM

Seems like there should be a process in Msconfig or something in the reg you could edit to get rid of that message...Although it will get rid of it for good even for other usb devices so maybe you don't want to do that. :-) I actually never "safely remove hardware"...ever. Always works fine anyway.
October 12, 2008 9:54:39 PM

Did anyone ever find an answer to this? My hard drives never used to show up, but since a motherboard upgrade they're suddenly in my list :( 
November 27, 2008 6:04:17 PM

I'm currently looking at this issue on my PC(s). I have one PC I built about 2.5 years ago with a MSI K8N board that has always had this issue until last night. This site (click me) explains how to remove the icon if you have a nForce board. This worked great for me (make sure you reboot, just killing and restarting explorer.exe didn't make it go away, it took a reboot), however I found this fix after I built my new PC last night and it booted up with the same icon. My new board is a Gigabyte (EP45-UD3P) and doesn't have nVidia built in so that entry doesn't exist in the registry.

If that folder exists in your registry, this fix will disable your HDD from showing up as removable while leaving the "safely remove" function for USB items unaffected. But if anyone can figure out how to apply this fix to other boards I would appreciate it. I've tried a couple different registry locations on my new board with no effect, but if I figure it out I'll post back and share.
December 16, 2008 2:14:18 PM

Right-click the task bar and select properties, and switch to Notification Area tab, and then click Customize, then confirm whether Safely Remove Hardware is set to "Always Hide" in Behavior column...
Anonymous
a b G Storage
December 16, 2008 9:12:51 PM

I found a solution to this problem at http://answers.yahoo.com/question/index?qid=20081111192.... I'm going to try the free software "USB DLM". There also is a walk-through on modifying the registry to remove the C: drive from the Safely Remove Hardware list.

Cori
July 17, 2011 7:24:55 AM

In your motherboard bios if you change your sata controller to IDE instead of ACHI it will fix the problem because it's ACHI that is making your drive hot swap capable.

If you want to change from ACHI to ide without reformatting you will want to read this


http://www.tomshardware.com/forum/269592-32-switch-ahci...


But ask yourself is it really worth all the effort to remove an icon? It's up 2 u


2 years later lol
August 8, 2011 2:43:32 AM

3 1/2 actually. Worth it though since that seems to be the case for me. I have enough lame icons down there, a shame I can't fix this without reverting to IDE.
October 1, 2011 11:46:33 AM

Wuzupmcs68 said:
I have a WD Raptor 150gb HD that I recently installed on a new build. I didn't notice this problem at first I don't know what made it show up but there is always an icon in my taskbar (the safely remove hardware icon like when you plug in a USB device) asking if I want to safely remove my Hard drive anyone have any ideas? its a sata drive if that has anything to do with it.

AMD Athlon X2 4200+ OC to 2.4
Asus M2N-E MOBO
1GBX2 Corsaird XMS2 DDR2 RAM
HIS Ice-Q ATI X1900XT 512MB
NZXT 500w PSU
WD Raptor 150GB HD
Samsung DVD-RW
Cretive X-Fi Xtreme Sound Card
3x120mm fans & 1x90mm fan in NZXT Lexa Case




This is for windows xp with via chipset...if you have a different one
I imagine it would be just as easy to find the correct drivers...
Just look in Device manager as shown below and try to actualize the driver for the ATA Controller,
it won't actualize it probably but it will give you the name of the drivers you need :) 

Everyone who has via chipsets follow this:
Safely Remove Hardware was showing my
sata drive in it... now the problem
is gone and not just hidden :) 

This will install new drivers for:
Look Here:
Device Manager-IDE ATA/ATAPI-Controller-
Via Serial ATA Controller-0591

Instructions:
Extract and install the zipped file
named VIA_HyperionPro_V523A.zip
You can find it here: http://www.via.com.tw/en/products/mainboards/downloads....
October 7, 2011 2:28:43 PM

I just encountered the same problem. I replaced the motherboard in my machine and in notification area i was given option to safely disconnect my internal hard drives and DVD ROM. Yes my hd's are running is ACHI mode. It was driving me nuts for a half day and then I finally installed proper mass storage drivers and problem disappeared. Motherboard chipset is Intel X58 so I installed Intel® Matrix Storage Manager downloaded from motherboard manufacturer (Asus) and this apparently replaced the crappy drivers included in Windows 7. I think this is proper way to go.
Cheers


nuka000 said:
This is for windows xp with via chipset...if you have a different one
I imagine it would be just as easy to find the correct drivers...
Just look in Device manager as shown below and try to actualize the driver for the ATA Controller,
it won't actualize it probably but it will give you the name of the drivers you need :) 

Everyone who has via chipsets follow this:
Safely Remove Hardware was showing my
sata drive in it... now the problem
is gone and not just hidden :) 

This will install new drivers for:
Look Here:
Device Manager-IDE ATA/ATAPI-Controller-
Via Serial ATA Controller-0591

Instructions:
Extract and install the zipped file
named VIA_HyperionPro_V523A.zip
You can find it here: http://www.via.com.tw/en/products/mainboards/downloads....
August 10, 2012 2:49:44 AM

This is a common problem when running on the generic AHCI driver supplied in Windows 7.
The solution is to install the correct AHCI driver for your computer.

First - find the AHCI driver. These usually come in the motherboard CD if this were a custom build. For a laptop you would need to see if there is one in the manufacturer's downloads section, contact the manufacturer, or find out the brand of motherboard, check the specs, and see if you can find a suitable driver. The generic Intel driver works for many boards based on Intel chipsets and can be found on Intel's website.

Once you have the correct AHCI driver you install it thus:
Open Device Manager
Navigate to IDE/ATA/ATAPI Controller > ***AHCI Serial ATA Controller
Right click > Properties
Choose: Update Driver
Browse to the folder that contains the AHCI driver you downloaded > Select > OK
“Successful” Message > Close
“Must Restart > Restart
Drivers Install > Another Restart necessary > Restart
Drivers successfully Installed. Remove Hardware Icon no longer showing.
*** : the name of the AHCI device is different for different systems, but it should be the only one with AHCI in it's name.

See if that will help.
August 10, 2012 2:49:46 AM

This is a common problem when running on the generic AHCI driver supplied in Windows 7.
The solution is to install the correct AHCI driver for your computer.

First - find the AHCI driver. These usually come in the motherboard CD if this were a custom build. For a laptop you would need to see if there is one in the manufacturer's downloads section, contact the manufacturer, or find out the brand of motherboard, check the specs, and see if you can find a suitable driver. The generic Intel driver works for many boards based on Intel chipsets and can be found on Intel's website.

Once you have the correct AHCI driver you install it thus:
Open Device Manager
Navigate to IDE/ATA/ATAPI Controller > ***AHCI Serial ATA Controller
Right click > Properties
Choose: Update Driver
Browse to the folder that contains the AHCI driver you downloaded > Select > OK
“Successful” Message > Close
“Must Restart > Restart
Drivers Install > Another Restart necessary > Restart
Drivers successfully Installed. Remove Hardware Icon no longer showing.
*** : the name of the AHCI device is different for different systems, but it should be the only one with AHCI in it's name.

See if that will help.
January 28, 2013 8:02:39 PM

Hello I'm new here,

I recently bought an Asrock Z77 Extreme 6 and had the same problem. This mobo has 4 SATA 2.0 ports and 2 SATA 3.0 ports all of these from the Intel Z77 chipset and an additional 2 SATA 3.0 port from Asmedia. I can control (disable) the hot-swap functionality of all Intel Sata ports from the BIOS, but the 2 SATA ports from Asmedia had no functionality at all here. So I had removed the "Safely Remove Hardware" option in the notification area for the hard drives connected to Intel's ports, but I still had the hard drive connected to the Asmedia port :??: 

What I did to disable the hot swap functionality of the remaining hard drive was:

Go to Computer > Manage > Device Manager > IDE ATA/ATAPI controllers > Asmedia 106x SATA Controller > Properties
In the Asmedia 106x SATA Controller Properties dialog I went to the tab named Policies and unchecked "Enable safely Remove Disk"and finally I restarted Windows. And with this bye bye annoying hot swap function in the The notification area! :bounce: 

I don't know if this will work for other controllers, but check out the properties of your IDE ATA/ATAPI devices and the Storage options in the BIOS.

Just for the record, I have an Asrock Z77 Extreme 6, a SSD connected to Intel SATA 3.0 port 1, one hard drive connected to the other Intel SATA 3.0 port 2, and another hard drive connected to the Asmedia SATA 3.0 port. And I have AHCI on.

April 1, 2013 6:54:02 PM

ANSWER TO ORIGINAL QUESTION: (Win7)
Go to properties for the hard drive and select "Polices",
In there you will see "Quick Removal" and "Better Performance".
By default better performance is selected and is the reason you will see the HHD in the safely remove.
Don't worry though as you can't remove it while it's in use anyway. Only a hard drive that is not being used can be removed.
So unless you want to swap it and no longer see it in that list just ignore it and not worry as it's not possible to disconnect your C drive.

Hope this helps,
Sorry if this has already been posted.
!