NTFS scanning directories painfully slow

Archived from groups: microsoft.public.win2000.file_system (More info?)

Hi All,

I am having a problem where my NTFS volumes are taking a very long
time to do directory scanning tasks.

For example, a directory containing ~2500 files will take twice as
long to show the files in explorer than a FAT32 directory containing
~15000 files.

Even a directory with only 20 or so movie files in it will take ~30
seconds before it retuns control back to the explorer window and show
the listing.

It seems to affect some directories and not others.

I have disabled indexing services and last accessed date setting.

This has happened on 3 different hard drives, a Western Digital,
Seagate, and Maxtor.

Anyone have any ideas?
5 answers Last reply
More about ntfs scanning directories painfully slow
  1. Archived from groups: microsoft.public.win2000.file_system (More info?)

    If you defrag the drive and look at the report what is the status of
    your mft? You will find this under volume information. It sounds like
    it may be fragmented into multiple parts.

    Utilities like perfect disk and diskeeper can do a boot time defrag
    that will consolidate the mft.


    --
    wanderer
    ------------------------------------------------------------------------
    Posted via http://www.mcse.ms
    ------------------------------------------------------------------------
    View this thread: http://www.mcse.ms/message1339675.html
  2. Archived from groups: microsoft.public.win2000.file_system (More info?)

    In article <6725u0l4j710h9kcq1fcdmjptpvp8chmr1@4ax.com>,
    <snotty2000@iinet.net.au> wrote:
    >Hi All,
    >
    >I am having a problem where my NTFS volumes are taking a very long
    >time to do directory scanning tasks.
    >
    >For example, a directory containing ~2500 files will take twice as
    >long to show the files in explorer than a FAT32 directory containing
    >~15000 files.
    >
    >Even a directory with only 20 or so movie files in it will take ~30
    >seconds before it retuns control back to the explorer window and show
    >the listing.
    >
    >It seems to affect some directories and not others.
    >
    >I have disabled indexing services and last accessed date setting.
    >
    >This has happened on 3 different hard drives, a Western Digital,
    >Seagate, and Maxtor.
    >
    >Anyone have any ideas?


    download the eval version of PerfectDisk (www.raxco.com) and analyze
    the disk. Do a reboot defrag (I _think_ the eval version will let you
    do that.

    I have no relationship with Raxco other than being a long-time
    satisfied customer.

    --

    a d y k e s @ p a n i x . c o m

    Don't blame me. I voted for Gore.
  3. Archived from groups: microsoft.public.win2000.file_system (More info?)

    I tried defraging the mft a while ago, but it didn't help the problem.

    Maybe it's a hardware problem in my system somewhere or something.

    Whatever it is, it's making me seriously think about converting to
    fat32 on those drives.
  4. Archived from groups: microsoft.public.win2000.file_system (More info?)

    In article <rilju05fo3tnogsuvtv6hcri61eftkkg0f@4ax.com>,
    <snotty2000@iinet.net.au> wrote:
    >I tried defraging the mft a while ago, but it didn't help the problem.
    >
    >Maybe it's a hardware problem in my system somewhere or something.
    >
    >Whatever it is, it's making me seriously think about converting to
    >fat32 on those drives.


    Were you _able_ to defag the $MFT ?


    Perfectdisk can, during a reboot-defrag.

    --

    a d y k e s @ p a n i x . c o m

    Don't blame me. I voted for Gore.
  5. Archived from groups: microsoft.public.win2000.file_system (More info?)

    Maybe? Turn off indexing service? Turn off short filename or 8.3 name
    creation? Turn off LastAccessDate? It might speed things up a bit...
    but then it may not make any noticable difference. Just ideas.

    John

    snotty2000@iinet.net.au wrote:

    > I tried defraging the mft a while ago, but it didn't help the problem.
    >
    > Maybe it's a hardware problem in my system somewhere or something.
    >
    > Whatever it is, it's making me seriously think about converting to
    > fat32 on those drives.
Ask a new question

Read More

NTFS Windows