Error: 0x80240020

Archived from groups: microsoft.public.win2000.file_system (More info?)

Can anyone help me out here? I have a huge problem with Windows Updates. I
fix computers for a living and this is for a client's PC. The client PC is
running Windows 2000 Professional Edition.


I'm having issues with Windows Updates. Prior to getting to this point I
removed a lot of spyware including Look2Me. I had to use a L2MFix remover
which did take control of some registry keys as well as deleted some
registry keys. I don't know if this is the exact cause of my current issues
but I just thought I'd throw this out there.


I've searched all of Google's Groups as well as exhausted all options on
Microsoft's Newsgroups. Whenever I attempt to use Windows Update, it will
download all available updates but as soon as it says initializing
installation, every single download fails to install. I go straight to my
WindowsUpdate.log and find that error # 0x80240020 is the culprit which
means something along the lines of there was no INTERACTIVE USER to input
data.


I've renamed and deleted the SoftwareDistribution folder, re-registered
numerous .dlls, almost everything and anything I can think of. The
administrator group includes my user name as well as test user names I
created in hopes I could get the other user accounts to do the Windows
Updates.


Now I'm wondering if anyone here has any extensive knowledge on how Windows
Updates works. I'd like to know exactly what it looks for before going
ahead with the installation of the downloads.


People are speculating that it is some type of permissions issue. I've also
had this issue come up with a Windows XP Home installation. To alleviate
the WinXP Home problem I just did an overlay of the OS. However, I do not
have a Windows 2000 Pro Upgrade CD so I cannot do an overlay at this time.


I'd love for more than anything to solve this issue. Even Microsoft
themselves cannot seem to solve this issue. I've been talking to them
through e-mails and we are still unable to resolve this situation.


I know this is long and drawn out, so here are some cliff notes:


CLIFFS:


Windows 2000 Pro installation

Removed spyware

Unable to do Windows Updates

Receiving error: 0x80240020 which means no interactive user available to
input data

Need to resolve said error

Tried numerous things and nothing has worked

I believe it has something to do with the registry permissions and or some
other type of Local Policy Settings


--
Nocturnal
1 answer Last reply
More about error 0x80240020
  1. Try this. This problem happened to me in a winxp with sp2.
    In the windowsupdatelog under c:\windows\

    Service WARNING: GetUserTokenFromSessionId failed with error 800704dd for session 0
    Report REPORT EVENT: {D8D7C455-F92D-4249-9CBA-A303C85375B4} 2007-06-22 10:08:01:484+1200 1 162 101 {8F771EC5-FCD3-4A6B-ADA6-7D6F0927F080} 102 0 WindowsUpdate Success Content Download Download succeeded.
    Agent * WARNING: Exit code = 0x80240020
    Agent *********
    Agent ** END ** Agent: Installing updates [CallerId = WindowsUpdate]
    Agent *************
    Agent WARNING: WU client failed installing updates with error 0x80240020
    COMAPI >>-- RESUMED -- COMAPI: Install [ClientId = WindowsUpdate]
    COMAPI - Install call failed
    COMAPI - Reboot required = No
    COMAPI - WARNING: Exit code = 0x80240FFF; Call error code = 0x80240020
    COMAPI ---------
    COMAPI -- END -- COMAPI: Install [ClientId = WindowsUpdate]

    basicly Error Code 0x80240020 Exit Code 0x80240FFF

    Check if Notify_Disabled subkey exist under, if exist delete "nodify_disabled"
    HKLM\software\microsoft\windowsNT\currentversion\winlogon

    check if SensLogn exist under
    HKLM\software\microsoft\WindowsNT\CurrentVersion\Winlogon\notify
    if "SensLogn" doesn't exist u need to create one and import it.

    create a simple txt file call anything u want. copy and paste the following.

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\Notify\SensLogn]
    "DLLName"="WlNotify.dll"
    "Lock"="SensLockEvent"
    "Logon"="SensLogonEvent"
    "Logoff"="SensLogoffEvent"
    "Safe"=dword:00000001
    "MaxWait"=dword:00000258
    "StartScreenSaver"="SensStartScreenSaverEvent"
    "StopScreenSaver"="SensStopScreenSaverEvent"
    "Startup"="SensStartupEvent"
    "Shutdown"="SensShutdownEvent"
    "StartShell"="SensStartShellEvent"
    "PostShell"="SensPostShellEvent"
    "Disconnect"="SensDisconnectEvent"
    "Reconnect"="SensReconnectEvent"
    "Unlock"="SensUnlockEvent"
    "Impersonate"=dword:00000001
    "Asynchronous"=dword:00000001

    then save it. Then rename the txt file to *.reg
    double click the file to import it into ur registry. restart computer.
    This fix works for me, might not work for you.

    I originaly found the fix here
    http://groups.google.com/group/microsoft.public.windowsupdate/browse_thread/thread/4ab6f738f0552244/783370b8554aeec5?lnk=st&q=error+no+0x80240020&rnum=5
    Thanks to Patti Macleod.
Ask a new question

Read More

Windows