Sign in with
Sign up | Sign in
Your question

New core duo system with no display?!

Last response: in Systems
Share
September 13, 2006 2:26:43 PM

Hi recently put together my new homebuild system which consisted of the following:

Asrock conroexfire-esata
Core Duo 2 e6300
1gb dual channel ddr2
xpertvision 256mb 7600gt
250gb samsung sata hdd
Thermaltake soprano case
Thermaltake W0061 420W TR2 ATX 2.0 PSU
plus optical drives etc.

When i built it and powered it up for the first time i recieved no display on the monitor, however, all the components seemed to power up fine all the fans were spinning and the leds were on. Firstly i tried reseating all the components still had the same problem. Then i tried the system with just the cpu and graphics card in place and still had the same problem. Throughout this i was also not getting any beeps from the motherboard. The only problem i have found that it might be is that on the chipset of the mobo it says the bios is version P1.10 and on the asrock website it says the bios needs to be version P1.2 for the core duos to work. Is this the reason i am getting no display? If not could anyone suggest what else it might be?
September 13, 2006 2:58:45 PM

I think you've answered your own question. Without the right BIOS version your computer will never boot up. My advice would be Option 1) buy a cheap celeron D, slap it in and update the BIOS then sell the puppy on ebay (or keep it around for a budget fileserver or something?). or Option 2) take the computer to a local shop and pay them to flash the BIOS for you. Then there is always the RMA option to Asrock and see if they will update your motherboard for you, but I have no idea how good Asrock's customer service is, because I've never bought one of their boards.
September 13, 2006 4:43:10 PM

Quote:
You need to be more awair of what you buy. Everything i have found about the motherboard says it will not support a C2D. The chipset on that board will not support the C2D acording to intel.


It's strange that you came to that conclusion when the Asrock supported processor list for this MB includes the e6300.

http://www.asrock.com/support/CPU_Support/show.asp?Mode...

But then again, maybe Asrock doesn't know what CPU's will work in their MB's.

Back to the "no display upon posting problem". This sounds like a common Conroe bios compatibility issue and it seems like you've identified your problem as the P1.10 bios.
You may need a Celeron or Pentium D to post and update BIOS for CD2 support.

Another option is to call Asrock for a chip containing the latest version. Some vendors will provide it free, others will charge about $20.

A friendly local shop might reflash it for free if you're real nice and promise to buy a bunch of stuff from them in the future. :lol: 
Related resources
September 13, 2006 6:17:50 PM

I phoned the supplier and they said they would flash the bios for a charge of £10 for the postage so i will let you know if this resolves the problem.
September 19, 2006 12:34:07 PM

Hi,

Got exactly the same problem,

Using a Esata 2 with a Leadtek 7900GS, 1GB Crucial DDR2 RAM (512 x2), Thermaltake PSU, Celeron 3.2 GHZ intel.

No beeps, nothing, this is the second GPU card in there, the first was a 7600GT which I sent back as I thought it was faulty. It sounds like ASROCK have issue, I'd be curious to know how the flashing went.
September 19, 2006 7:29:30 PM

I seem to be having a similar problem, though I also have a problem with my power switches not working. Everything boots when I plug in the system with the PSU turned on even before I touch the front panel switches. Then after it's all on, the front panel switches don't respond. The front panel LED is on, and lights come on, but no switches.
I originally posted my problem with a PSU here, but I've resolved that.
September 19, 2006 9:04:13 PM

Try disconnecting the front panel switches from the MB to verify it doesn't turn on in that case. Then, carefully short together the two front panel power switch pins on the MB momentarily, to see if the system turns on. Something like a screwdriver blade usually works well.
September 20, 2006 4:01:27 PM

it turned out to be a fualty motherboard the supplier are sending me a replacement.
!