Sign in with
Sign up | Sign in
Your question

New external drive not recognized

Last response: in Storage
Share
September 13, 2006 9:15:02 PM

Just picked up a Western Digital 500GB Caviar SE16 [WD5000SK(RTL)] and a Vantec NexStar 3 [NST-360SU-BK]. Installed the new drive into the enclosure. Installed the included SATA to eSATA bracket in the desktop. Hooked up all the cables, turn it on, machine can't see it. WinXP Pro SP2, tried using its disk management snap-in and it doesn't see the drive. WD's software doesn't see it either. I tried reconnecting all external cables, no change. Tried turning the drive on and off, and rebooting the machine, no change. When I turn the drive on, the logo LED lights up so I know it's getting power. I have the internal SATA cable (from the bracket) connected to the mobo. The internal, boot HD is connected to the other mobo SATA port and works fine. I did not try switching which cable goes to which port.

System specs:
Dell 8400 w P4 5x0 (3.2GHz)
Intel 825X (EX?) based mobo
WinXP Pro SP2

I emailed Vantec but I doubt they'll respond quickly or solve the problem. I did not try hooking it up with the available USB2 connection. Yes, I could try it that way, but I want to use the eSATA connection so....

Any suggestions appreciated. Thanks.
September 14, 2006 3:25:14 AM

Problem solved.

I took the drive out of the enclosure and hooked it up internally. No change.

Someone suggested checking the BIOS; I didn't think to try because I thought that SATA is hot swappable so there'd be no reason to ever disable the ports.

Turns out that Dell stupidly disabled SATA ports/channels 1-3; only channel 0 was enabled. Once I figured that out, everything worked fine.

One thing, though. If I turn the drive off and turn on my computer (with SATA channel 2 - the one the external drive connects to) enabled, the BIOS complains with a no drive found, F1 to continue or F2 to enter setup error. If I hit F1, the computer loads up fine. If I then turn on the drive, I would expect that it would automatically mount at that time, just like sticking in a USB thumb drive. However, that's not the case; it doesn't auto mount. I haven't tried repeating that scenario and then going in to the drive management snap-in to see if I can mount it manually.

So what's the deal with SATA (not?) being hot-swappable?
Related resources
!