Sign in with
Sign up | Sign in
Your question

Problems running 3D with HIS 1900gt graphics card

Last response: in Graphics & Displays
Share
September 15, 2006 7:51:00 AM

I have an 'ASRock conroe esata 2' mobo and the HIS 1900gt graphics card. I am trying to install this card. I have used the drivers which came with the card and when I look in the device manager, there is nothing outstanding to install (ati control centre even recognises this card and I can play with the basic and advance settings). Under the system display: - I can see the system is aware that a 1900gt card is present and running the display. The problem occurs when trying to run a game(e.g. Far Cry). After installing far cry and the card drivers several times, I try to start the game each time and it doesn't even show any menus. It just immediately stops running (no error messages).
I also tried Sim City 4. Can't even install this onto system.
My pioneer 111b dvd drive is running fine (dvd movies work ok).
How do I fix this problem?
September 15, 2006 9:29:14 AM

Can you try a different card on the motherboard, or try the card in a different computer? It sounds like the 3D bit of the card is bust.
September 17, 2006 4:40:18 AM

Where did you get your card and how much did you pay for it?
Related resources
September 18, 2006 7:48:10 AM

I got the card from overclockers for £155.


I tried a new install with the 6.8 drivers and 2.0 .net files. I also used direct x 9.0c.

This game and others don't work. I get an access violation message. I looked in the windows32 folder and checked directx and it isn't the 9.0c version. I have tried to load the 9.0c version but it doesn't seem to load. I think there is a problem with the direct access memory.

Any solutions?
September 18, 2006 11:28:26 PM

Quote:


Any solutions?

I would try driver cleaner from driverheaven.com, if that didnt work, I would format and reinstall windows.
September 19, 2006 11:29:44 AM

Fixed the problem. It was my OS (windows XP). There were a few bugs on it. Tried a friends and it worked fine.
!