Sign in with
Sign up | Sign in
Your question

X1900XT Mem/Core Clock Problem - Please Help

Last response: in Graphics & Displays
Share
September 19, 2006 5:41:08 PM

My Sapphire X1900XT Shows default clocks of 500 core/600 memory and i get lower 3DMarks from THG's scores although it was tested with an AMD FX-60. when i try to increase clocks to XT 625/725 default system hangs up. My system specs are

Core2 Duo E6700
Asus P5W DH
4 Gb Corsair XMS DDR2-800
Sapphire X1900XT
Seagate 7200.10 250Gb x2 in RAID 0
Sound Blaster X-Fi Elite

Any help would be appreciated...
September 19, 2006 5:44:01 PM

Those are 2D clocks, in 3D applications, it goes up.
September 19, 2006 5:48:06 PM

after i installed catalyst control center and activated overdrive,my score in 3Dmark dropped about 1000 marks in 1280x1024 :) My initial test was only with the basic drivers no control center installed, i think there is something wrong here :?
Related resources
September 19, 2006 5:53:55 PM

yes i understand its really noob :D  i would never ask a question like this but it is really weird that after installing catalyst control center my 3d mark score dropped. All default settings with v6.8 drivers
September 19, 2006 6:03:54 PM

before i reinstalled windows i ran a test with only plain 6.8 drivers with 3dmark settings 1280x1024 4x aa 8x af and get about 8500 3dmarks now i get about 7500 3dmarks. I compared it with the x1900xtx in THG's test x1950xtx test article. It does not mention (or I could not see) the driver settings (performace/quality). when i got 7500 marks it was the default settings i did not change anything. When i got 8500 marks there was no control center to change anything :) 
September 19, 2006 6:24:08 PM

i tried increasing clocks with ati tools. Actually sorry for being a ati noob :)  this is my first Ati card. I learned why it locks i am as dumb as hell :)  I learned from a site that there is no tool for ati to control both 2D and 3D frequencies. in 2D not only clock speed but voltage to the core also drops and thats why it hangs when i try to increase clock speed to 3D default to 2D default :)  I have a lot to learn :) 
!