Sign in with
Sign up | Sign in
Your question

MS-DOS will not start

Last response: in Windows 95/98/ME
Share
July 29, 2001 3:07:36 PM

This is my system and settings: PII 350Mhz, 256MB ram, swapfile 300MB,Intel 440BX-2 MOBO, Geforce2 MX, 6 GIG HD, 20 GIG HD(swapfile is here), Win98 System.ini setting vchache min=0 max=65536, conservative swapfile=1, IRQ11=4096 (same IRQ as Geforce). AGP aperture is set to 64MB, tried 256MB but no change. When I try to start in ms-dos mode I get a hardware list but no C: prompt. Do I have win98 system.ini optimized for my system. Please help. BTW win98 works fine.
DB

More about : dos start

July 29, 2001 4:31:05 PM



Does it look OK when booting from StartUp floppy?
July 29, 2001 7:30:59 PM

You get a hardware list?

I'd change the vcache to at least 2048 minimum and 32meg max. But as far as the dos prompt not working, I'm wondering if you just got a bad install. Every other time I install win98 (read:Nes98), it will default the EMS enabled in the dos prompt. I didn't select anything out of the ordinary, it just decides that it want's to automatically set up EMS rather than just setting up XMS and no EMS.

Whatever.....
Related resources
July 29, 2001 11:12:13 PM

Thanks, I will try setting vcache min=2048.
DB
Anonymous
July 31, 2001 12:22:52 AM

i've thought about this one, and cant say as how i think that DOS would care about your virtual memory settings. the swap file is windows specific - it has nothing to do with DOS, which is a completely different operating system. i think you should look to another issue to solve you DOS problems......

ignore everything i say
July 31, 2001 5:49:00 AM

One day I found that I couldn't run MS-DOS Prompt (I saw DOS applet for a moment), neither restart in MS-DOS Mode.
I spent some time on analyzing DOS Startup environment, files. Finally gave up and reinstalled Win98SE in the same directory. I didn't want to overwrite my updates, therefore answered NO on all requests to change/rewrite. It helped. Still don't know the right remedy and what caused the problem.

Microsoft has confirmed<A HREF="http://support.microsoft.com/support/kb/articles/Q232/9..." target="_new"><font color=red> this </font color=red></A>to be a problem in Windows 98 Second Edition.
July 31, 2001 11:43:57 AM

I can use the win98 statup disk to start ms-dos that works fine. I did notice that I have no memory allocated to EMS, that's what SANDRA shows. If the root directory has too many files in it will that cause ms-dos not to start? I will try and move some file and see if that helps. I will let you know!
DB
July 31, 2001 6:40:02 PM

Its funny how these problems happen. I ran my system after the annual format last year and I had the same problem. This year no problem.

Check out the properties of the shortcut. You might be able to tinker some kind of result there. In the memory bit, make sure all the options are on Auto, and the HMA box is ticked. Try double clicking on the command.com file, rather than using a shortcut.

<b>
"Now drop your weapons or I'll kill him with this deadly jelly baby." :wink:
</b>
August 2, 2001 12:29:43 AM

This is what happens when I startup in ms-dos: I get a dos header that includes the version of dos and then skips down to a hardware description of the CD-ROM then stops with the flashing prompt then nothing. Its like dos freezes. I can get a dos prompt in windows just fine I can also get to dos mode with a startup disk. I checked the root dir. to see if I had too many files in there but that was OK. It seems like ever since I tweaked my system.ini file it stopped working but I know that is only a win98 file not a dos file. The only thing that I can think that may cause this would be memory allocation or something like that I give up. Help!
August 2, 2001 8:45:58 AM

From what I can understand of the problem
Windows DOS mode works ok.
Windows boot disk works ok.
Windows restart in DOS mode fails.

Have you tried pressing F8 at the POST passed beep and selecting "Command prompt only" or "Safe mode command prompt only" if "Safe mode command prompt only" works but "Command prompt only" fails then look at your autoexec.bat and config.sys files as they may be calling a faulty driver or the like.

Only the insane prosper.
Only those who prosper can judge what is sane.
August 2, 2001 7:04:16 PM

Had exactly the same symptoms on my box when restarted into DOS. Was there any error message when opening Start>Programs>MS-DOS Prompt? I don't remember from that time, but it didn't work on me either. Just a moment splash.

Funny thing: I have another Win98SE box from which I mirrored the harddrive onto that troublesome box. No problem at all on the "original" box with the same programs installed but the box itself is slower and with only 64 MB of RAM.
The "mirrored" guy with 128 MB of RAM got a DOS problem after couple months of flawless run. Don't remember that I installed/downloaded or uninstalled something specific.
I tried to find the setting differences between two boxes, but I couldn't and gave up.
As I mentioned previously, I fixed the problem by reinstalling the Win98SE into the same Windows directory, answering NO on all the questions.
But I don't see this like a proper way of fixing problems, that's why that DOS-prompt disappearence still bothering me.
!