Sign in with
Sign up | Sign in
Your question

TCP/IP Config help - Broadband & NAT + LAN

Last response: in Networking
Share
January 2, 2006 3:04:15 PM

Guys, who can help me with the following.

I have this network

3 WinXP computers to a 10Mbps HUB
1 Prestige 650R to the same HUB (this is a modem+router that gives me NAT)

I used to have this config:

Prestige: 192.34.34.1
PC1: 192.34.34.100
PC2: 192.34.34.101
PC3: 192.34.34.102

All the computers had manually fixed IP with "Default Gateway" to 192.34.34.1 and the Primary DNS to the same.

Internet works fine, and I have some ports redirected to PC1 that has VNC, FTP, etc.

I never used Folder Sharing or anything related to SMB.
I've only used that when PC3 was W98 and I just shared a folder to be able to access from PC1. No prob.

Once, I've noticed that trying to upload via FTP (from PC2 to PC1) that PC1 just HANGED.

Ok here's the deal. I now have all the PCs running XP and I wanted to access from PC3 to PC1 (a shared folder).

Go to My Network Places -> Entire Network -> Microsoft Windows Network and it takes a very long time just to show "Workgroup"

Then, if I double click there, it just hangs and have to kill it and restart Explorer (the desktop).

If, I just type \PC1 it takes like a minute, and shows me the shared resources. I can click, type the username and password, and after some time, it shows me what's inside, but it takes a long time, and the "exes" don't have an icon. If I try to copy from one to another, it just can't (no message. I guess that after 10 minutes it will).

I just turned off/disconnected the Broadband Router, and everything worked fine and fast.

So I guess I'm missing to configure TCP/IP correctly, since it seems that Windows will only try to go through the Default Gateway even for those addresses in the same range and within the same mask (255.255.255.0).

So what I've tried is to set up the modem like 192.168.0.1 and give the computers an address there, and another in the 192.34.34.x range. But it doesn't work either.

Should I just add the computers addresses to the LMHOSTS file, or what shall I do to make them co-exist?

Regards,

David.
January 2, 2006 3:49:26 PM

I assume that all of the PCs are in the same workgroup for starters.
I would definitely set the Modem/Router's LAN side IP to a private IP of 192.168.1.1 (or 192.168.x.1, whatever you choose) and give the PCs a static private IP in that range (or enable DHCP and let it handle this. Actually, it may help the router's DNS cache keep track of the connected LAN side PC's a little better).
It seems like to me the main reason it's taking so long to connect to a UNC (\PC1) is because the router may be trying to lookup the IP on your ISP's or other DNS servers since it's a public IP and not a private IP.
January 2, 2006 4:24:01 PM

I did DHCP and manual 192.168.....

no success.

It might be that I have to tell the modem/router not to bother.

Since, as I have read, XP uses DNS to resolve hostnames. Anyway, once solved, it should work.
Related resources
January 2, 2006 5:16:25 PM

I wish I could help more. I just don't have a setup similar to that to test. My cable modem is just a modem to my knowledge. I have my IPCop router, two Domain controllers, and two DNS servers on my local LAN. I don't use my router as the primary DNS, I have the DHCP in the router set to give the IP's of my two local DNS servers (which they are set to forward queries out to my ISP DNS servers) as the primary and secondary DNS servers and one ISP DNS server as a tertiary DNS. I am also using 192.168.1.x/24 IP range.

If I had a modem/router similar to yours that I could look through the config, I could help more. If you do happen to find a resolution, please let us know.
January 2, 2006 7:08:06 PM

I will try this...

1) Disable NetBIOS over TCP-IP since it's obsolete.
2) Activate the modem DNS

Since up to now, it's only passing the request straight to the ISP DNS.
January 2, 2006 8:20:31 PM

Quote:
I will try this...

1) Disable NetBIOS over TCP-IP since it's obsolete.
2) Activate the modem DNS

Since up to now, it's only passing the request straight to the ISP DNS.


#2 sounds like it would most likely solve your issue now that I know that the modem/router's DNS caching was disabled
January 3, 2006 6:33:27 PM

Your delay is coming from DNS moving to NetBIOS over TCP/IP.

When you don't use the FQDN in XP, it moves over to NetBIOS which takes forever to figure things out and it forwards the request out past your router, etc. etc. The delay takes forever. It's manually searching for everything.

If you disable it, you should be fine as long as you have some form of DNS in state, like your ISP, but you'll have to use the FQDN (fully qualified domain name) in order to find things. ex. computer1.mshome.com if you're running on mshome workgroup name.

DNS is so much better and faster than netbios/wins.

So instead of typing computer1, you'd want to do computer1.mshome.com or use the IP address. I wouldn't recommend browsing through the Entire Network portion as that will take forever to search all over.
!