Sign in with
Sign up | Sign in
Your question

One Way Network

Last response: in Networking
Share
January 4, 2006 2:52:56 PM

My new laptop can see my MainPC (which has many shared folders) but when I click on MainPC icon from View Network Computers I always get Access Denied.
My MainPC can see my laptop and access shared folders.
All IP addresses etc are OK.
Both can access broadband.
Same result from Server.
Any and all advice gratefully sought.

History:-

Main PC was part of domain but practically was only used as stand-alone, so when I got the laptop (17/12/05) I removed MainPC from the domain (no need to have server running domain - ungreen) and created workgroup: now scenario as above.

Infrastructure and background:-

This is all a home network - Active Directory and Domain for study purposes only.

Main PC:- AMD XP2400, 1GB RAM, 40gb + 80 gb, Ti 4200, XPPro SP2

Laptop:- Brand new Dell Inspiron 1300, Celeron M 340, 768Mb, 40Gb, XP Home SP2 (£498 - nice for the price!)

Server:- AMD XP 2500, 512 Mb, 80 Gb, Win 2000 Server, Active Directory, Domain Controller

Broadband into ADSL Router that is also DHCP server linked by ethernet Cat 5 to Switch to which rest of network is connected.

PS Happy New Year to Everybody.

More about : network

January 4, 2006 5:51:46 PM

Have you shared anything on the MainPC? Is simple file sharing on or off?
January 4, 2006 6:02:55 PM

Yes, as I said there are many shared folders and File and Printer Sharing are enabled.

I have been through all the configuration options I can think of. I've even used the Wizard! All to no avail. My MainPC remains stubbornly "Access Denied".
Related resources
January 4, 2006 6:07:09 PM

any firewall on the MainPC?
January 4, 2006 6:51:56 PM

All firewalls etc checked out ok - as I said all the network side is fine.
I am so frustrated - I have been through everything I can think of.

Does anyone know if leaving a domain to join a workgroup can cause these problems?
January 5, 2006 6:04:59 PM

Are you running the same username/password on each of the computers? Win XP's default's to not allow anonymous logins. If you setup a Username or set your administrator account with a password that is the same on both systems, you should be able to connect.

Otherwise, if you don't want to do this, you can go in and look through some of the Local Security Settings in the Administrative Tools and set Windows to allow anonymous logins. I have done this successfully in the past when I was just using a workgroup. You will need to change a few settings in the Local Security Settings under the Security Options. I can't remember exactly which ones without trying it in a workgroup though.
January 5, 2006 6:50:00 PM

I am using the same username/password on both MainPC and laptop, but still can only see MainPC in Workgroup Computers - double clicking on it results in Access Denied.
January 5, 2006 11:00:20 PM

Can you ping the desktop computer (by name and ip) from the laptop?
Can you access the shares via the run prompt?
(backslash)(backslash)computername(backslash)share
(wouldn't let me put in backslashes for some reason... damn new forums...)

After making a share using simple filesharing, disable simple file sharing, enable the guest account, and add the guest account to the shares permissions and security. Do the same for a folder on the laptop.
I've had to do that on several occations in the past regardless of the same account being on both comps. That would also negate any ties the computer might still try to have with the domain (though it shouldn't have any).

Just double check to make sure all the accounts on the computers are the same. All local users including the administrator account.
January 6, 2006 1:14:39 AM

Thanks for replying.

Yes I can ping by name and ip address.

Yes I can do a dir command on a shared folder (!)

I do not fully understand your second paragraph, I have enabled the guest account, but the workgroup sharing is either shared or not (with option for change files) there is no option to select which user or group may access the share, it's all or no-one.

I get exactly the same result from my server - you can look but you can't touch!
January 7, 2006 8:02:02 PM

Now that I think about it I dont think you can disable simple file sharing in XP home. Usually you have to disable it on both computers but it might work to disable it on just one. Go to your XP pro desktop computer:
open mycomputer, go to tools>folder options, go to the view tab, scroll all the way down, and uncheck simple file sharing.
Now see if your laptop/server can see the computer.
January 8, 2006 4:42:50 PM

Which accounts show up in your share permission?
January 9, 2006 7:49:09 AM

The Right Answer!

I unchecked Simple File Sharing and lo! all was revealed.

Many thanks indeed - although I wonder why that worked as it seems a bit counterintuitive.
!