Sign in with
Sign up | Sign in
Your question

P5B Deluxe won't boot/post, dead on arrival?

Tags:
  • Asus
  • Boot
  • Motherboards
Last response: in Motherboards
Share
October 2, 2006 7:25:05 AM

G'morning folks,

Yesterday I finally got my hands on my new gear, P5B Deluxe, 2GB Crucial Ballistix, e6300 and Sapphire 1900xt. I assembled everything like I've done dozens of time before, switched on the psu (400w nb-fortron) and pressed the power... and nothing. Absolutely nothing happened.

I rechecked all the connections, found no errors and tried to boot up again but to no effect. First I thought that my psu was inadequate for the new rig, so to test this theory I removed the graphics card from my system. It still didn't boot. At this point I felt the first tendrils of dread creeping up on me. I tried removing parts until there was nothing left but the mobo hooked to the psu, and even then nothing happened (at this point it should have at least beeped).

Mobo does power up when I switch the psu on. At least, the blue asus-logo in the bottom of the board lights up and when I try to switch the system on, it flashes orange for about .2 seconds before turning back to blue and the fans I have on my system rotate a few notches. If I press the power again nothing will happen. I must reset my psu to see these small signs of life again.

I must admit, I'm running out of ideas fast. As I said earlier I've assembled dozens of computers before and this is the first time I've ran into problems like these. It is either the psu or the mobo and I've had no problems none whatsoever with this psu before. Help?

More about : p5b deluxe boot post dead arrival

October 2, 2006 10:09:53 AM

Well hey,

i went through a similar situation just the other day with the P5B WiFi. Well after spending hours troubleshooting it, i told NewEgg i wanted to RMA it and went out and bought a different brand MoBo. I didnt want to play the waiting RMA game, so i switched to a different board all together.
So far i am completely happy.

In my search to find a solution, i found many net forums ripping that board. It seems a lot of people have had issues with that board.

I would return it.
October 2, 2006 10:48:29 AM

Hey OG,
I'm with you on the mobo thing. That DEFINITELY sounds like a mobo prob. Have you ever tried DFI mobo's? I have never owned one but I have always heard good reviews about it.

From what you describe about removed componants for boot test seems to point to the mobo. Way I see it, a 400w PSU should be able to post that board no problems.

Hope you can get your $$$ back for it.
Related resources
October 2, 2006 11:44:14 AM

Hey i had the same problem with my wifi edition but turns out i just forgot to plug in the 6 or 4 pin power thing above the cpu. Very stupid mistake but maybe u made it? Good luck
October 2, 2006 3:46:02 PM

Hate to state the obvious but sometimes we triple check all the hard stuff and over-look the simple so be sure to double check the power/reset switch connections.

Good luck, I hope it is that simple.
October 2, 2006 4:32:25 PM

Well I found the problem at last. It seems that the +12v lines and ground were short-circuited in the 4/8 pin cpu power feed. My trusty fortron had good enough protection but when I tried the mobo on my friends psu, the psu literally exploded. Bang-and-smoke you know... Well now I've a brand new p5w, but it cost me more than I was prepared to pay :/ 
!