Sign in with
Sign up | Sign in
Your question

Using Gigabit and Fast Ethernet on computer

Tags:
  • Computers
  • Ethernet Card
  • Windows XP
  • Networking
Last response: in Networking
Share
January 14, 2006 11:01:29 PM

Hi,
Ok here is what I want to do. I have two machines both running XP Pro and connected to the internet with a di-624 router and fast ethernet. I also have gigabit ethernet on both machines and they are connected via a crossover cable. I want to use the gigabit ethernet exclusively for transferring files from one machine to the other. The fast ethernet is using dhcp machine a is 192.168.0.100 machine b is 192.168.0.101. On the gigabit side the addresses are 192.168.2.3 and 192.168.2.2 respectively. I cant figure out how to get it to exclusively use the gigabit for file transfers most of the time it ends up using the fast ethernet. Any help would be greatly appreciated.

More about : gigabit fast ethernet computer

January 16, 2006 10:37:46 PM

Assuming that you're using mapped drives...

You could try mapping the drives by IP address rather than using the machine names.

For example, use //192.168.2.3/myshare instead of //computername/myshare and you can be sure to always use a particular interface.

You could also disable File and Printer sharing on the fast ethernet interface, and that should force file sharing to your gigabit interfaces also.
January 16, 2006 11:41:57 PM

Hi Stranger,
Thank you for the reply. I have tried the disabling the filesharing on the fast ethernet connection and that didnt work. I will try what you said about the interface and using the ip I didn't know you could do that.
Thanks again,
Steve
January 17, 2006 12:47:46 PM

If I understand correctly then each machine has two network connections (a gigabit and a slower one).

XP uses something called METRIC to assign whighting for each network card connection. The weighting determines which card it will use. Normally XP does this automatically but you can do it manually.

use the following command to display your current config:
"route print"

Change the metric manually using this method:

When multiple Internet connections are available, WXP uses the one
that has the lowest "metric" value.

To assign a metric to a network connection:

1. Open the Network Connections folder.
2. Right click the desired connection.
3. Click Properties | Internet Protocol (TCP/IP).
4. Click Properties | Advanced.
5. Un-check "Automatic metric".
6. Enter a number between 1 and 9999 for the "Interface metric".


Personally I have never got this to work properly so I always disable the slower card when I want to copy large files and then re-enable

:lol: 
!