Sign in with
Sign up | Sign in
Your question

WoW/Raptor Question

Last response: in Components
Share
October 6, 2006 4:48:43 AM

Heya,
Yes I'm a big WoW player, don't pretend you're not either! Anyway, I recently bought a WD Raptor. While I wasn't really expecting zones to load that much quicker, I didn't expect for them to load slower.
If you play WoW you know what I'm talking about when I speak of the delay between entering instances, portaling, etc. I don't really mean the blue loading bar, I just mean running into a instance and out the otherside. My old WD 7200 loaded these very fast. Now with the Raptor there seems to be quite a delay, about 7 seconds or so to load it. Anyone have any idea why this would happen on a faster HD?

Old HDD: WD 7200rpm, 74gb 8mb Cache
new HDD: WD 10k rpm raptor, 74gb 16 mb cache

More about : wow raptor question

October 10, 2006 10:56:25 PM

Quote:
Heya,
Yes I'm a big WoW player, don't pretend you're not either! Anyway, I recently bought a WD Raptor. While I wasn't really expecting zones to load that much quicker, I didn't expect for them to load slower.
If you play WoW you know what I'm talking about when I speak of the delay between entering instances, portaling, etc. I don't really mean the blue loading bar, I just mean running into a instance and out the otherside. My old WD 7200 loaded these very fast. Now with the Raptor there seems to be quite a delay, about 7 seconds or so to load it. Anyone have any idea why this would happen on a faster HD?

Old HDD: WD 7200rpm, 74gb 8mb Cache
new HDD: WD 10k rpm raptor, 74gb 16 mb cache


have you tried defragmenting your drive?
October 11, 2006 4:53:37 AM

Try clean installing WoW, unistall it completly and reinstall it. If you use an imaging software to move all the data its possible that thats whats causing the delay.
Related resources
October 11, 2006 5:44:28 AM

Reinstall on raptor, defrag, and do a msconfig in the "run" program in your start menu and get rig of some of the stuff that starts with your pc, carefull though some may be required like norton and what not.

Also instences kinda also have to do with your net connection im sure.
October 11, 2006 5:56:49 AM

Yep I've done all of the above.
I've found out some other info:

The burst speed is faster on my older HDD because its SATA II. However, my gf has the same drive, but has a slower burst speed than me (her controller must not be SATA II) and she loads even fast like before. So I've got faster burst speeds and everything else...So wtf? Its so strange..epecially when every now and then it works like a million bucks.
October 11, 2006 6:18:00 AM

I dont understand then either, you have a real nice system.
October 11, 2006 7:26:34 AM

well... whether its sata150 or sata300, it wont matter, no single drive is fast enough to use the full bandwidth of either interface, burst, sustained, or otherwise... ...it COULD be an issue with NCQ on the 74GB raptor (maybe), if you disable that, you might have improved performance (it could be under disk drives in device manager, but im not sure)

it could also be an issue maybe with your controller drivers, or another driver, or possibly a bios setting of sorts, because the raptor itself should be consistantly fast, not having intermittant slowdowns like youre experiencing

try disabling the pata ide channels in the bios, see if that changes things any, updating drivers is also an option too, if you havent already
October 11, 2006 8:46:24 AM

Get one of the new segate 200gig drives. Bigger capacity, quieter, better performing then raptors.

I RMA'ed my 74gig raptor, it was horrible. My new segate .10 drive rocks :D 
October 11, 2006 9:21:48 AM

I have a 150 gb raptor and it runs faster than my old sata2 7200rpm hitachi with 16mb cache. weird.
October 11, 2006 1:23:38 PM

Aye aye...here's a catch. When I goto the Properties of the drive in Device Manger, I have the option of disabling Tagged Queing, and Synchonrous Transfers. The drive is supposed to have NCQ but I don't see it anywhere nor know how to shut it off IF it is somewhere. BOTH the drives have tagged queing so I know its not the same as NCQ. Anyway, I disabled the TCQ, but left the Syncronous Transfers cuz I didn't really know what it means. Anyone want to shed some light?

Keeping all of this in mind guys, its really just WoW that has performance issues...The rest of my apps/programs run like a breeze. I'm sure there's nothing physically wrong with my drive.
I disabled all IDE channels (except of course my dvd-rom), and even disabled the other controllers for the Intel ports. So...Yeah I dunno unless NCQ is hiding somewhere and I can't shut it off.
October 11, 2006 6:43:20 PM

Quote:
Aye aye...here's a catch. When I goto the Properties of the drive in Device Manger, I have the option of disabling Tagged Queing, and Synchonrous Transfers. The drive is supposed to have NCQ but I don't see it anywhere nor know how to shut it off IF it is somewhere. BOTH the drives have tagged queing so I know its not the same as NCQ. Anyway, I disabled the TCQ, but left the Syncronous Transfers cuz I didn't really know what it means. Anyone want to shed some light?

Keeping all of this in mind guys, its really just WoW that has performance issues...The rest of my apps/programs run like a breeze. I'm sure there's nothing physically wrong with my drive.
I disabled all IDE channels (except of course my dvd-rom), and even disabled the other controllers for the Intel ports. So...Yeah I dunno unless NCQ is hiding somewhere and I can't shut it off.


Hey Wolfman,

If I'm not mistaken, the only Raptor model which had NCQ was the 150 GB version, but whether it does or not, wouldn't make that much of a performance difference. As your suggest, the issue is likely with WoW itself, as I too play it, and my specs are also nothing to sneeze at.

I experience similar issues to your own from time to time, and what's interesting is that I have two 36 GB Raptors in RAID 0. I did make some changes to my system settings to help alleviate this, but no solution is perfect. If, overall, you find that performance is fairly fluid with the occasional hiccup, then you're not doing too bad.

I'll also try to find my documentation on the registry changes you can make to help speed things up, I don't remember what they were off hand, but one was to clear your page file on each shutdown and the other was to better utilize system RAM in excess of 256 MB. Once I made these changes, my overall system improvement was fairly significant, and may help you as well. I'll post them if I find them.
October 12, 2006 2:01:04 AM

OK,
Definately let me know about the registry changes. I believe one you may be talking about is AlwaysUnloadDLL...Which I do have done. But the other I am unfamiliar with. Please let me know! Thanks!
October 12, 2006 2:12:10 AM

Quote:

If I'm not mistaken, the only Raptor model which had NCQ was the 150 GB version, but whether it does or not, wouldn't make that much of a performance difference. As your suggest, the issue is likely with WoW itself, as I too play it, and my specs are also nothing to sneeze at.


yeah, both the 74GB and 150GB versions include NCQ and TCQ (it was only the 36GB variant that didnt have it, it only had TCQ)...

the site i read before, posted about the possible negative impact of NCQ for a desktop user, and that they had it both enabled and disabled when testing it, (dont remember which site it was though that posted it)

they found that NCQ helps alot more with server usage than desktop, and with NCQ disabled on a desktop system, the performance was be increased

it might not be a huge difference, but i thought i might point that out
October 12, 2006 2:42:06 PM

Yes I know my hdd has NCQ cuz it even says it right on the retail box. But now it is the eternal question...WHERE THE HELL do you go to disable it??? I checked Device Manager, no dice. Just can disable tagged queing. I checked BIOS, nothing there either. I know that my JMicron chip allows it because it says right in the manual "use AHCI mode (which I am) to allow for more advanced SATA features such as NCQ" So I know its allowed...I just don't know how the hell to shut it off! I want to see if there is any performance difference. I read somewhere that someone had to do it somewhere in the Registry. Maybe I should talk to WD.
October 12, 2006 3:18:04 PM

To use NCQ, both the drive AND the controller have to support it. :cry: 
October 12, 2006 3:20:35 PM

If you don't have the drivers installed properly, the Raptor's performance will be screwed up, and usually you won't be able to address the whole "150" GB's.

Edit: Odds are that if you can't find the settings to adjust Raid/NCQ stuff, the drivers aren't right.
October 12, 2006 3:34:38 PM

Aye...I reinstalled Windows using the Gigabyte (JMicron) drivers loading at Windows install with F6. I had AHCI enabled in BIOS, which (According to the board's instruction booklet) that enables more advanced features to be used, such as NCQ. So...Supposedly the ports and the driver do allow for NCQ...and as far as I know everything is installed correctly. Windows went and installed SATA drivers for the other ports, but they're not being used so it doesn't matter. I even used the lastest drivers from Gigabyte, which were updated even just yesterday.

So bottom line: Everything is installed correctly, I'm using the right drivers, and the ports/drivers/Raptor do allow for NCQ. So I'm awaiting a response from WD to see how to disable it.
October 12, 2006 4:22:07 PM

Weird. I haven't ever used a gigabyte board, but all companies can have their driver issues, that's for sure. Maybe you even got the rare bad HD. It's certainly possible. Do you have any non-WoW issues that are similiar?
October 12, 2006 4:46:12 PM

No issues that I know of...boot time isn't as quick as I had hoped, but everything else zooms. Installations, disk defrags and cleanup, it all goes wicked fast. And the HD Tach speeds are definitely better than my older hdd. Strangely, Sentinel worked on the hdds when they were in the Intel ports, but it doesn't work when they're in Gigabyte ports. But anyway, even when they both were in Intel, Sentinel reported 100% condition so...I dunno.
!