XBox 360 networking

10 answers Last reply
More about xbox networking
  1. I think you need to either enable Windows Internet connection sharing (ICS) or Bridge the Ethernet and Wireless Network Connections in the PC where you have the Xbox connected.

    You enable ICS in the Network Connection Properties Advanced tab.

    You enable bridging by opening Network Connections, selecting
    the two adapters you want to bridge, right click and select Bridge Connections.
  2. I've been told I need an ethernet crossover cable.

    Enabling ICS results in an error along the lines of "Cannot enabled ICS as the IP needed is in use"
  3. You might need a crossover cable, but I'm not seeing how the
    computer you're connecting the Xbox into is then connecting the
    Xbox to the network.

    I don't know why you're getting the ICS error. Did you try using the Network Setup Wizard (in Control Panels)
  4. You might need a crossover cable, but I'm not seeing how the
    computer you're connecting the Xbox into is then connecting the
    Xbox to the network.

    I don't know why you're getting the ICS error. Did you try using the Network Setup Wizard (in Control Panels)
  5. Yeah, I've been told the ICS error is becuase my router has an internal IP 192.168.0.1 and that is the IP needed for ICS. When I get the crossover I will change IP's and see what happens.
  6. When you enable ICS it defaults one of your nics to 192.168.0.1, which your router is already using. I dont think you can ICS from one nic to another though. I believe ICS is only for internet connection to nic (ie, if your dsl modem was right on your computer and you had a pppoe connection made)
    I'm pretty sure you will want a bridge in this situation. I've never made one in windows before but we might be able to figure it out ;)

    If the nic you are plugging the xbox 360 into on your computer is gigabit you do not need a crossover cable, gigabit nics are auto switching (xbox360 has a gigabit nic). If the nic in your computer is not gigabit you will need a crossover.

    Lets try something like this:
    router: 192.168.0.1

    select the two network adaptors, right click on them and select bridge.
    right click on the bridge and go to properties
    click on internet protocol (tcp/ip), click properties
    give it:
    ip 192.168.0.2
    sub 255.255.255.0
    gateway 192.168.0.1
    pri dns 192.168.0.1
    Make sure only the two network cards you chose are checked under adapters.

    if the xbox does not recieve an ip via dhcp give it this:
    ip 192.168.0.3
    sub 255.255.255.0
    gateway 192.168.0.1
    pri dns 192.168.0.1

    Hopefully that does something, lol.
  7. My bro's PC (the one who I'm setting this up for) doesn't have a gigabit nic, so will have to wait until the crossover arrives. I was thinking I may have to bridge the connections too.

    Cheers,
  8. Oh, and cheers again, I didn't realise I could enter the router IP as the DNS address and it wold still work. I'd been entering the actual DNS addresses. :roll:
  9. If you know your isp's dns servers you might as well use them (router will forward to those anyway). I just usually suggest using the router IP because most people dont know their isp dns server addresses :)
  10. Right, after hours of messing around I finally got it working.

    You need to use ICS, not a network bridge.

    Firstly, ICS requires that IP 192.168.0.1 is free, by default my router is that IP. So, I changed my router IP to 192.168.1.1

    Then, I altered my 3 PC's to have IP's of 192.168.1.2/3/4 (Putting them on 192.168..2/3/4 resulted in timing out when I tried to access anything - Can anyone tell me why?)

    Then, using a cross over ethernet cable I bought, I connected the Xbox360 to my onboard NIC. I set that NIC IP to 192.168.0.2, it's gateway to 192.168.1.1, and the DNS server to 192.168.1.1

    At the Xbox end I set it's IP to 192.168.0.3, gateway 192.168.0.2 and the DNS server to 192.168.1.1

    AFTER all that, it worked!!!! 8O :D
Ask a new question

Read More

Xbox 360 Networking