Sign in with
Sign up | Sign in
Your question

wierd sound problem plz help

Last response: in Components
Share
October 9, 2006 10:34:17 AM

hi!
i have an onboard ALC888 codec (your regular onboard soundcard...) and for some reason when i play games or when i play songs on itunes and even on system sounds i get wierd crunchy sound (something that sounds like really bad quality 8bit samples) but when i play the exact same songs on winamp and media player it sounds just fine... my guess it would be drivers (or codecs?) but i have the latest drivers installed and dxdiag shows no problems and also checked on windows's default playback and everything and nothing looks different (also dx is on full hardware acceleration) anyone have any suggestions/ideas on how to work out this thing?
October 9, 2006 11:19:28 AM

Could be a driver issue, could be windows doing summat odd.

How about uninstalling the drivers in Control Panel then reinstall them?
October 9, 2006 2:10:37 PM

nope... didnt work... still sounds bad any other ideas? again with winamp/media player everythings fine but with messenger/games sounds bad
Related resources
October 9, 2006 2:40:11 PM

I once had this a long time ago, but it was with an old Sound Blaster live like crackling and weird audio in games, a possible solution that worked for me is turning (if you have this feature in your BIOS) the PCI Latency down to 0, by default its 32, it might not do anything because i'm not sure if the onboard sound uses the PCI bus but it might do.

If you can't select this feature in the BIOS there is a patch on the net where you can do it in windows google "PCI Latencty 0 win xp"

Hope this is a help, if not buy a PCI card they sound so much better!
October 9, 2006 4:38:45 PM

well i dont understand how it would be the issue as it would affect my all the programs... this is why i think its a driver/codec issue - if it was hardware related it would sound the same everywhere...
October 10, 2006 4:51:40 AM

The problem is itunes and not your soundcard. Go to quicktimes preferences, click the audio tab, and in the "sound out" area change "size" from 24-bit to 16-bit, click apply and ok. Your problem should be fixed. Many people ran into this problem because apple has a different way they process 24 bit audio that is incompatable with many codecs. This should fix your problem with itunes. Tell me if you still have anymore issues with sound and I will try to help you out.
October 10, 2006 8:46:39 AM

not necessarily many programs use the sound card in different ways and more traffic on the system can make the pci bus less of a priority, hence you'll loose sections of the audio and the audio system will try to compensate usually adding noise crackling pops bangs etc lol

hope the itunes solution helps you though
October 10, 2006 8:46:43 AM

thanks! this worked out for itunes :) 
but what about the games and a few messenger sounds? this just shows its a codec thing but i dont find anywhere that allows 24bit playback on this device anyway - any suggestions about that?
October 10, 2006 8:51:09 AM

you could try removing your audio codecs manually in control panel and then adding them in again, this can be a pain but might be worth it, there in --> control panel --> "Sounds and Audio Devices" --> "Hardware" tab --> "Audio Codecs" just double click them, however it may need you uninstalling all audio related programs 8O
October 10, 2006 8:54:06 AM

thats something im trying to avoid... im not sure of how winxp will reinstall those codecs and if itll do all of them anyways i checked everyone and none have a 24bit playback option
October 11, 2006 12:31:18 AM

Quote:
thanks! this worked out for itunes :) 
but what about the games and a few messenger sounds? this just shows its a codec thing but i dont find anywhere that allows 24bit playback on this device anyway - any suggestions about that?


Change any games from 24-bit sound down to 16-bit. If you're lucky you can install the klite mega codec pack which contains a gazillion codec's that may help solve your problem. I agree that it may be a codec issue in regards to the non-itunes-related problems as its not unheard of for them to be incompatable with certain sound cards. If the codec pack doesnt work reinstall MSN and your games, check your sound in the control panel and see if anything refers to 24-bit audio, change anything you see to 16-bit audio. There is a sounds tab in the "sounds and audio devices properties" window that can have you choose sound schemes as well as individual sounds windows uses. Go through all those tabs and change any "high" settings to medium or to a low point. Test your change and work your way back up to the highest setting possible without distortion. Hope this helps.


1. Install Klite Mega Codec pack
2. uninstall and reinstall msn and the games you have trouble with
If steps 1 and 2 don't work go onto step 3+
3. Check "sound and audio Devices" in control panel
4. Change settings to low or lowest
5. Test msn/game for distortion in audio

If this does'nt work let me know and give me details on exactly what sound/problems you run into as well as a description of the sound you are getting. Ie. high pitch, choppy, metallic.


One last thing, if EAX is enabled and your card doesnt support it that may cause distortion, worth a shot in regards to your games.
October 11, 2006 8:30:17 AM

well.. i uninstalled the klite codec pack and reinstalled a newer version - and also none of the games i play have 24bit playback options nor does messenger + this soundscard has eax 2.0 capabilities - but again its not enabled in none of the games i play... the sound is like a bad 8bit sample its like i hear a static aftereffect - hope this tells u something and thanks again for the help guys :) 
October 11, 2006 9:12:22 AM

could you get a recording of the sound and post it on the net just so we know exactly what it sounds like?
October 11, 2006 10:25:19 AM

Quote:
thats something im trying to avoid... im not sure of how winxp will reinstall those codecs and if itll do all of them anyways i checked everyone and none have a 24bit playback option



The auzentech X-Plosion plays back in 24-bit........google it, read it, and you may find that it's for you.

Antec P180 Performance Case
SeaSonic S12 600w PSU
Asus A8N32 SLI S-939 (bios 1103 V02.58 )
RealTek 97 Onboard
ATHLON 64 X2 4800+ Toledo Core (AMD v 1.3.1.0/MS hotfix/ Dual Opt)
2 G's of Corsair 3500LL Pro @ 400Mhz 2-3-2-6-1T
2- BFG 7900 GT OC in SLI (NV 91.31)
WD RAPTOR 74.3 G's / XP Home / SP2 & Apps
Maxtor SATA II 250 G's /Gaming / Movies / MP3's
Maxtor SATA II 250 G's /backup (unplugged)
Sony CDrom 52X
Plextor 708-A DVD/CD rom
Razer DiamondBack Optical mouse
Logitech Z-5500 Dolby Digital 5.1 THX 500w
October 11, 2006 10:59:53 AM

well... im not looking for a new soundcard nor do i need one - on my old computer i have the alc650 codec which works just fine... im just trying to find out and fix the driver/codec thats causing the bad sound - and the solution for itunes worked fine - but the thing is i cannot find it for games (checked in dxdiag and nothing there about playback bitrate) and btw except for specific sounds in messenger (logon and new instant message) the rest of the sounds are just fine which makes this even wierder!

oh and one more thing i changed the playback quality in quicktime back to 24bit and it sounds just fine now... so wtf?!
October 12, 2006 12:33:51 AM

Quote:
well.. i uninstalled the klite codec pack and reinstalled a newer version - and also none of the games i play have 24bit playback options nor does messenger + this soundscard has eax 2.0 capabilities - but again its not enabled in none of the games i play... the sound is like a bad 8bit sample its like i hear a static aftereffect - hope this tells u something and thanks again for the help guys :) 


I want to say it's a codec, I really do! But if itunes sounds fine than it almost has to be a setting. This is a long shot, but is your onboard sound enabled in the bios? MAYBE if its set to failsafe mode or whatever it might have disabled the card. Beats me why itunes works and you still have problems with the games/msn. Try reinstalling the games and msn. This may help since you've updated your codecs. Check to see if any and all eax effects are on and turn them off, follow that by making sure the slide-bar is set to zero AND is checked as off. Somebody had an issue somewhat like your's and this solved his problem. At this point i'd recommend checking the forums of your motherboard maker for somebody with a similar problem, if you still can't find a solution try contacting your mobo's support. Someone mentioned a codec remover, try using that and starting fresh with up-to-date codec's and a fresh install of your games/msn. But, like I said, I don't think its a codec issue. Best of luck. Please let me know how you situation unfolds.
!