Sign in with
Sign up | Sign in
Your question

Dlink DGL-4100 + Linksys WRT54G Acting as an access point?

Tags:
  • Configuration
  • D-Link
  • Linksys
  • Wireless Networking
Last response: in Wireless Networking
Share
December 6, 2005 10:56:55 PM

Hello, I've had a Dlink DGL-4100 for afew months now and I love it (It's wired only) But I just purchased a Linksys WRT54g along with a new laptop (Dell 9300).

I'm wondering if its possible to use the WRT54G as a wireless access point for my lap top, I've got it running "ok" at the moment with default settings (a lan cable running from the 4th port on the DGL-4100 to the WAN on the WRT54G) And the only thing I've changed are the routers pass and it's security mode (wap2).

The problem is I can't see my home computers that are on the wired routers network (the DGL-4100).

Is there a way I can get the laptop to jump onto the DGL-4100's LAN and just use the WRT54G as some kind of a wireless signal broadcast.

Thanks, basically alls I want to do is transfer files from this computer and wired computers freely.

More about : dlink dgl 4100 linksys wrt54g acting access point

December 7, 2005 11:15:09 AM

You won't use the WAN port on the Linsys. You need to uplink the switch, the LAN side. Disable DHCP on the Linksys as well. It'll then be used as an AP only. Well that and the extra switch ports.

You can use the WAN port in theory but you'd either need to enable RIP on both routers or you'll be double NAT'ing. Not preferred. Unless you have a compelling reason to segment the nodes using the Linksys. If not, then just drop the routing functionality with the aforementioned steps above.
December 7, 2005 1:36:20 PM

If I Uplink / disable dhcp I can still use wap 2 right?
Related resources
December 7, 2005 5:10:48 PM

Ok, Nevermind my previous Question. I got it working, but now I can't access the second routers config page via 192.168.1.1 (the WRT54G)

Had to set the WRT54G to router mode instead of gateway to get it to work.
December 7, 2005 5:24:10 PM

My mistake. Left that out. Manually assign the device a unique IP on your current LAN's subnet. The only reason you need an IP is for management but yeah, you probably want to setup security or whatever. So if your current router is 192.168.1.1 or whatever then set the second device, the AP with a local IP of something like 192.168.1.254. That way you'll never run into problems with your DHCP leases. You can adjust your scope on the original router I'd imagine but most "dynamic" IP's are semi static anyway with home based routers and clients. They only get a new IP if the one they've been using gets taken while that node is turned off or something.
December 7, 2005 8:29:32 PM

Yeh my DGL-4100 is 192.168.0.1 (main router)

So I must assign the Linksys router a static ip on the DGL-4100 (the main router?)

Right now the Linksys is on it's default 192.168.1.1 for its admin page? I didn't change that. The DGL-4100 router set it's lan ip as 192.168.0.148 (Like this computer is 192.168.0.122, my other three pcs are 133, 144, and 120 I have them all static).

I Still can't figure out how to access the linksys router's config page though. The linksys's static ip is now 192.168.0.148 through the DGL-4100.

I guess I had to have changed something or set the Linksys to something else before changing it to routing mode. Could it be their subnet masks conflict or something?

Thanks for all your help sofar by the way :D 
December 8, 2005 11:34:38 AM

hey dude, you must set the linksys router to have the same ip range with your dlink.make the linksys to have a 192.168.0.2 as the gateway ip and disable its dhcp server and connect the ports to regular ports on both router. :wink:
December 8, 2005 1:45:48 PM

Oh ok :<

But still :(  I can't get into it's config page now, must I reset it to factory defaults?
December 8, 2005 2:27:59 PM

yes,you need to reset the router back to factory settings. :wink:
January 18, 2009 1:28:39 AM

Hi, I need some extra help on a similar issue. I have FIOS and a linksys WRT54GX4. My wife does not like wireless where the verizon fios router is so i disabled it. I have a ethernet cable from the FIOS router's ports to upstairs where i have a linksys WRT54GX4. I am having some NAT issues and after reading some threads realized i have to disable NAT on my linksys to allow it to act like an access point (thanks). As soon as i check NAT mode to be disabled, no wireless devices can cannect, they can see my wireless but it keeps saying acquiring ip address but not connect. Is there something else i have to do? THere also seems to be another tab that has a dropdown that has automatic config (DHCP), static IP, Internet IP Address, Subnet Mask and gateway as a drop down, Is it possible to give me step by step how to disable NAT (DHCP) on the linksys router, Thanks, Raffaele
!