Sign in with
Sign up | Sign in
Your question

Using Netgear router as an access point

Last response: in Wireless Networking
Share
February 8, 2006 2:24:20 AM

I have been trying to get my Netgear MR814v2 to stop doing NAT and just provide me an access point in my house, since my previous access point got stolen (don't ask). I have in-wall ethernet and a Netgear 16 port switch in "the nerd room". I am using a computer to do NAT right now.

The reason I don't want the Netgear to do the routing is because it doesn't let more than one computer establish a UDP connection to the same server at the same time (example, two computers both connecting to a Quake 3 server). I've contacted Netgear multiple times and been given the response that they do not recommend the router for online gaming (wtf?). If anyone has a fix (hacked firmware or something.. I've already tried updating firmware) let me know. Otherwise, I'd just like to use this thing as an access point - WAN connected to switch, and wireless broadcasting an SSID for my new laptop.

Any suggestions? I have no use for this damn router and I don't want to buy another access point!
February 8, 2006 1:34:29 PM

To make your Router/AP a dedicated AP, login to the admin console and disable DHCP. Bypass the WAN port completely and just uplink a LAN port on the switch side of the device. That's it, it's now an AP/switch combo instead of a Router/AP/Switch combo. At least one of the ports that connects the AP to the rest of your existing LAN will need to be Auto MDI/MDX or you'll need to use a crossover cable. You can buy a X-over cable in any electronicx store.
February 8, 2006 4:54:43 PM

Are you kidding me, it's that easy? Yeah, my 16 port Netgear switch is one of their decent ones, with auto-uplink. I'll go try that.

Edit: I'm still playing with it. I have port 1 on the router to port 6 or so on the switch, and I can access the router control panel from my DHCP/NAT server (port 12 on switch or so), but I can't get wireless to connect to the network. Wireless will connect to the router but I won't get an IP, and if I specify an IP and specify DNS I'm still not connected. What gives?

Edit #2: I'm connected to the router through port 4, wired connection. I get an IP from my DHCP server (computer) and the internet works fine. Why doesn't wireless get an IP? 8O 8O 8O
Related resources
February 8, 2006 5:45:26 PM


That is my network. Much of the cabling goes through the wall, but that shouldn't matter because it seems the situation is isolated to the wireless settings in my router (Netgear MR814v2). However, I know wireless works normally in the router (in a "normal situation") and my wired connection works. Agh!
February 13, 2006 4:38:05 AM

Bump: anyone?
February 13, 2006 12:01:21 PM

Your setup should work, although I suggest giving the router a static IP so that you can always get to the admin screen. Also, be sure all your connections are to the router's LAN ports.

A quick look over at the MR814v2 support page
http://kbserver.netgear.com/products/MR814v2.asp

shows some symptoms that sound like your problem. I suggest you upgrade to the latest firmware if you already haven't. You'll probably have to re-do your settings after the flash.
February 13, 2006 8:40:43 PM

I'm running firmware 5.3_05 or whatever the newest one is. What do you mean by giving the router a static IP? It's set to an internal 192.168.0.254. "WAN" is on "auto detect" or whatever, since I'm not using it. Should that be set to something? That wouldn't really make sense..

It's really weird that the switch works as a switch, and gives me an IP, but the wireless part lets me connect but I can't get through.. argh!
February 13, 2006 8:56:37 PM

Sorry, I meant to make sure that the router's internal IP is set to an *unused* address in your LAN's range. If it's now set to 192.168.0.254, then all the other LAN machines, INCLUDING the IP address of the "Server" in your diagram, must use 192.168.0.X addresses.

If your other machines are on a different subnet, say, 192.168.1.X, then change the NETGEAR internal address.
February 15, 2006 6:12:19 PM

All the machines are on 192.168.0.x. Remember: the wired connection to the router works. I have NO idea why it's not working. :[
February 15, 2006 6:20:56 PM

Well, that's all I got! :)  Sorry.
March 22, 2009 12:01:21 AM

Wipeout, your CAT cable may not be a cross over cable. Buy a cross over cable and it should all work
Anonymous
November 29, 2009 4:24:50 PM

Wipeout said:
All the machines are on 192.168.0.x. Remember: the wired connection to the router works. I have NO idea why it's not working. :[



I'm having the same problem.
Did you fix it?
!