Sign in with
Sign up | Sign in
Your question

Configuring a wireless laptop and router

Tags:
  • Configuration
  • Laptops
  • Routers
  • Desktops
  • Wireless Networking
Last response: in Wireless Networking
Share
Anonymous
a b D Laptop
September 27, 2005 9:08:53 AM

Archived from groups: (More info?)

I have successfully managed to connect my desktop pc to a wireless
router [LinkSys WRT54G] using mixed mode [B&G] with MAC filtering and
WEP enabled.

However, my laptop [also running mixed mode B&G] does not see the
desktop PC, but can ping the router. The desktop PC shows an icon in
the HOME workgroup for the laptop but does not allow access, stating
'not accessible'. I have shared out folders on the laptop and been thru
the Network Setup Wizard to ensure that File and Print Sharing is
turned on but still no luck.

The laptop does not show an icon for the desktop pc in the home
workgroup, and strangely, although it shows an icon for itself, will
not allow access. Prior to installing the router, all worked fine and
the two machines would happily communicate.

I've turned off MAC filtering, WEP, rebuilt the network from ground up,
am using the same username and password on both machines, and DHCP,
turned off the firewall on both machines, ensured the router is handing
out sufficient IP addresses, where am i going wrong???

Both machines are using XP professional - clearly the problem is either
with the router or laptop - but as I can't see shared folders from the
laptop under it's own machine name in the HOME workgroup, I'm guessing
this is where to start!

Any experts out there????

More about : configuring wireless laptop router

Anonymous
a b D Laptop
September 27, 2005 10:03:58 AM

Archived from groups: (More info?)

Make sure that there isn't a setting in your wireless router preventing
wireless client-to-client communications.
Anonymous
a b D Laptop
September 27, 2005 10:35:34 AM

Archived from groups: (More info?)

nonymouse wrote:
> I have successfully managed to connect my desktop pc to a wireless
> router [LinkSys WRT54G] using mixed mode [B&G] with MAC filtering and
> WEP enabled.
>
> However, my laptop [also running mixed mode B&G] does not see the
> desktop PC, but can ping the router. The desktop PC shows an icon in
> the HOME workgroup for the laptop but does not allow access, stating
> 'not accessible'. I have shared out folders on the laptop and been
> thru the Network Setup Wizard to ensure that File and Print Sharing is
> turned on but still no luck.
>
> The laptop does not show an icon for the desktop pc in the home
> workgroup, and strangely, although it shows an icon for itself, will
> not allow access. Prior to installing the router, all worked fine and
> the two machines would happily communicate.
>
> I've turned off MAC filtering, WEP, rebuilt the network from ground
> up, am using the same username and password on both machines, and
> DHCP, turned off the firewall on both machines, ensured the router is
> handing out sufficient IP addresses, where am i going wrong???
>
> Both machines are using XP professional - clearly the problem is
> either with the router or laptop - but as I can't see shared folders
> from the laptop under it's own machine name in the HOME workgroup,
> I'm guessing this is where to start!
>
> Any experts out there????

Try this networking diagnostic page:
http://www.michna.com/kb/WxNetwork.htm

Q
Related resources
Anonymous
a b D Laptop
September 27, 2005 2:23:25 PM

Archived from groups: (More info?)

Thanks for the advice, but I'm a bit of a muppet when it comes to
networks. What kind of setting might prevent wireless client to client
communications??
Anonymous
a b D Laptop
September 27, 2005 2:24:54 PM

Archived from groups: (More info?)

On 27 Sep 2005 05:08:53 -0700, "nonymouse"
<bearintheair@fastmail.co.uk> wrote:

>I have successfully managed to connect my desktop pc to a wireless
>router [LinkSys WRT54G] using mixed mode [B&G] with MAC filtering and
>WEP enabled.
>
>However, my laptop [also running mixed mode B&G] does not see the
>desktop PC, but can ping the router. The desktop PC shows an icon in
>the HOME workgroup for the laptop but does not allow access, stating
>'not accessible'. I have shared out folders on the laptop and been thru
>the Network Setup Wizard to ensure that File and Print Sharing is
>turned on but still no luck.
>
>The laptop does not show an icon for the desktop pc in the home
>workgroup, and strangely, although it shows an icon for itself, will
>not allow access. Prior to installing the router, all worked fine and
>the two machines would happily communicate.
>
>I've turned off MAC filtering, WEP, rebuilt the network from ground up,
>am using the same username and password on both machines, and DHCP,
>turned off the firewall on both machines, ensured the router is handing
>out sufficient IP addresses, where am i going wrong???
>
>Both machines are using XP professional - clearly the problem is either
>with the router or laptop - but as I can't see shared folders from the
>laptop under it's own machine name in the HOME workgroup, I'm guessing
>this is where to start!

It's MSHOME not HOME. The workgroup name should be the same on both
machines. To make it easy, you should have identical user accounts on
both machines, with identical passwords.

Just for fun, you might wanna try doing the networking thing without
the wireless. Just plug your computahs into the router using CAT5
ethernet cables. Turn off the wireless devices. See if it screws up
the same way.

The WRT54G has a feature called "AP Isolation" located on the
Wireless -> Advanced Settings
page. It really should be call "client isolation" as it will prevent
client to client connections. Disable this feature.

It's also possible that you don't have file sharing setup correctly.
First, make sure the Windoze firewall isn't getting in the way.
Control Panel -> Windoze Firewall -> Exceptions
Be sure that File and Print Sharing is checked as an exception. (I'm
assuming you've installed XP SP2).

Here's the basic instructions for setting up Windoze file sharing.
http://www.wown.info/j_helmig/wxppntsh.htm
Verify that you've done it correctly.


--
Jeff Liebermann jeffl@comix.santa-cruz.ca.us
150 Felker St #D http://www.LearnByDestroying.com
Santa Cruz CA 95060 http://802.11junk.com
Skype: JeffLiebermann AE6KS 831-336-2558
Anonymous
a b D Laptop
September 27, 2005 2:35:02 PM

Archived from groups: (More info?)

On 27 Sep 2005 10:23:25 -0700, "nonymouse"
<bearintheair@fastmail.co.uk> wrote:

>Thanks for the advice, but I'm a bit of a muppet when it comes to
>networks. What kind of setting might prevent wireless client to client
>communications??

The WRT54G has a feature called "AP Isolation" located on the
Wireless -> Advanced Settings
page. It really should be call "client isolation" as it will prevent
client to client connections. Disable this feature.


--
Jeff Liebermann jeffl@comix.santa-cruz.ca.us
150 Felker St #D http://www.LearnByDestroying.com
Santa Cruz CA 95060 http://802.11junk.com
Skype: JeffLiebermann AE6KS 831-336-2558
Anonymous
a b D Laptop
September 28, 2005 2:53:32 PM

Archived from groups: (More info?)

Many thanks. Have disabled the AP isolation feature, have SP2 installed
and have turned off the firewall just to make sure that wasn't the
problem. Both machines are running XP Pro and have simple file sharing
turned on. Have checked out the article you pointed me to, but still no
luck
Anonymous
a b D Laptop
September 29, 2005 3:04:03 AM

Archived from groups: (More info?)

On 28 Sep 2005 10:53:32 -0700, "nonymouse"
<bearintheair@fastmail.co.uk> wrote:

>Many thanks. Have disabled the AP isolation feature, have SP2 installed
>and have turned off the firewall just to make sure that wasn't the
>problem. Both machines are running XP Pro and have simple file sharing
>turned on. Have checked out the article you pointed me to, but still no
>luck

Keep going. Drag both the machines to the router and use an ethernet
cable to make the connection. That will eliminate the wireless from
the puzzle. Try again.

Disable BOTH windows firewalls for now.
Make sure you have the same Workgroup name.
Identical account names and passwords on both machiens.
Can you ping each other?
Can you see directories with:
Start -> Run -> cmd <enter>
\\machine_name
or
\\192.168.1.123 (IP address of other machine)
These should show the available shares.

--
# Jeff Liebermann 150 Felker St #D Santa Cruz CA 95060
# 831.336.2558 voice Skype: JeffLiebermann
# http://www.LearnByDestroying.com AE6KS
# http://802.11junk.com
# jeffl@comix.santa-cruz.ca.us
# jeffl@cruzio.com
!