Sign in with
Sign up | Sign in
Your question

how to reset sapphire x1900xt bios to its original?

Last response: in Graphics & Displays
Share
October 26, 2006 7:30:55 PM

hello people, i made a mistake in flashing the xt bios to xtx and now it goes blank and loud.

i've tried to do it with geforce mmx agp card and tried to flash it backward via safe mode but no luck, if i try to run it in normal mode, the windows restarting itself. i used asrock 775dual-vsta so i can run both agp and pcie. everytime i try to run the x1900xt the system won't reboot and still blank.

i wonder how to reset my sapphire x1900xt to its original bios which i have saved before i flash with atiwinflash with force option enabled?
October 26, 2006 10:29:50 PM

You'll probably need a cheap PCI card to boot, and flash proper BIOS back onto the X1900XT. The X1900XT has to be in the PC, with the PCI one.

Try that, could work.
October 27, 2006 4:24:36 AM

ERROR 0FL01 (adapter 0 not found)

still got the same error message though i tried change the number from 0 to 6.

guess i really screwed up my vga card. a lesson to learn :( 

thanks for the help here..
October 27, 2006 10:44:28 AM

woohoo!! i tried it again with new atiflash software from http://www.techpowerup.com and a little help of command line from techpowerup.com forum, and it works! i get my vga card back to normal again.

thank you very much prozac26 & wuzy!! i really appreciate it!! woohooooooooooooo :D 

to wuzy: it's me enorhc at your ym list hehe :p  nice to have you back here again though not so often.

for all the people who experience the same like me could do the trick with atiflash, another pci vga card or another card if you can go with dual agp/pcie card, floppy disk, your default bios rom/bin, and the command line:

atiflash -p 0 -f -newbios thebiosfilenamehere

(e.g: atiflash -p 0 -f -newbios r580.rom)

good luck.. as i've been trying straight 6 hours to get my card back to normal and i finally did it after being helped here and there through forums like this. you guys are awesome!
Related resources
!