Sign in with
Sign up | Sign in
Your question

BIOS shows up, but can't use keyboard.

Last response: in Systems
Share
November 5, 2006 8:39:16 AM

Hopefully this is the right section... Thought of trying the motherboard forum first, but figure this place'd reach a wider number of people who rarely look at the MB forum. Sorry, if it's in the wrong place.

The subject pretty much describes my problem. Now for the details... First I tried plugging in my keyboard into the front then rear USB, then I tried a PS2 keyboard. No luck. I was fooling around and seeing if I couldn't get past the BIOS, so I inserted my XP CD for the hell of it, and it actually worked (for a while, more on this later). Managed to successfully install and load XP, keyboard worked the whole time.

Then I updated my BIOS, since I hoped it'd fix my problem. So, I follow the manual's instructions to the letter (extra paranoid first time builder), update my BIOS from Windows, reboot, then get a blank screen (no signal). My CDless CD/DVD drive is whirring for no reason, so I'm like, oh crap and clear my CMOS. That works, screen is back, DVD drive isn't whirring needlessly, all good. Except my BIOS has been successfully updated (thought CMOS reset the BIOS?), my keyboards still aren't recognized, and now I can't even use the trick of getting into XP using my CD.

Also contacted ECS tech support, but I heard they're late and/or not too useful, so I figured I'd try out this place first since lots of smart and helpful people are here :)  So that's my problem and any help would be much appreciated.

Specs: (Except for the MB, don't think they matter, since when XP actually loaded, my system was recognizing all the parts. Something weird during BIOS though :cry: )

E6300
ECS P965T-A 1.0 (Won't get such a cheap MB next time :evil: )
512MB x 2 Corsair value RAM
7600GT
Seasonic 410W PSU
Liteon DVD

Note: I use a non-standard, i.e. foreign, keyboard (Japanese to be exact). Both the PS2 and USB keyboards were Japanese. Not sure if it has anything to do with the trouble, but I do know that in games, I often have trouble bringing up consoles (When playing games, if I want to bring up a console, I have to hit shift-` instead of ~, since the ~'s been replaced by a key that lets me switch between English and Jap). Then again it isn't an issue with my current laptop (no trouble fooling around with the BIOS)... :?

(If you're reading this catnip, sorry for leaving like that. Something came up :(  Thanks for trying to help me out. And that other guy, P-something, thank you too. Sorry for forgetting your name.)

More about : bios shows keyboard

November 5, 2006 11:52:54 AM

I would suggest switching to a USB keyboard, such as the Saitek Eclipse which requires no install disc or drivers.
You probably have a PS/2 japcrap keyboard that requires a installation/drivers disc, i can't explain why it worked thru the BIOS but that would explain why Windows doesn't recognize it.
November 5, 2006 5:02:01 PM

Actually, Windows recognizes both the USB (Microsoft) and PS2 (Jap) keyboards all the time (was able to log on a few times). The BIOS does only once I get past the initial setup-or-boot screen (hit DEL to enter setup, F12 to boot), and by get past, I mean when the machine decides to skip the screen and makes sure my HD, RAM, and CPU are fine.

I was able to use the keyboard and poke around the BIOS immediately after clearing the CMOS (just that once by the way) and everything looked fine (well, least according to the manual :) ).

Is there anyway to just set things up so that the machine auto-boots up instead of giving me the option to setup-or-boot? It does it sometimes, I just don't know how or why :?

Sorry for not using enough tech talk to clear up the problem, not exactly a techie here.
Related resources
November 5, 2006 6:17:30 PM

Hrm did some looking around at the driver updates on the ECS website. You should try doing a bios update the old fashioned way (with a floppy disk)
November 5, 2006 7:36:45 PM

Bit of an update...

Ok, whenever I get the OS to load, it POSTS (I think) my video card, motherboard, CPU, memory, and HD in that order, then goes on to Windows. Everything's normal. Whenever I get the keyboard problem, only the videocard + MB, or videocard + MB + CPU are checked. Memory + HD don't get touched.

I would've assumed that if my CPU + memory are defective or incorrectly plugged in, I wouldn't be able to load up Windows at all. Is this a fair assumption to make?

Also, I've noticed my machine makes a series of barely audible clicks in rapid succession whenever I get the keyboard problem. It doesn't sound like a beep at all, but could it be a beepcode? I just assumed it was my case because I'm using a cheapo case :)  Beginning to wonder if it's a keyboard problem at all since I only have trouble with the keyboard only at a very specific point. Wonder if my machine's freezing? I see "_" that thingy flickering though, so assumed it isn't freezing.

Oh, and one more thing, I've only tried it twice, but I'm pretty certain clearing the CMOS lets me access the BIOS and go on to loading Windows. Not sure if that narrows things down, but thought I'd mention it.

Thanks for the suggestion, Hayt. There don't seem to be any relevant driver updates, but I will try updating the BIOS with a floppy.

Edit: It's an Award BIOS by the way.
December 7, 2009 11:58:58 AM

My problem seems similar,maybe you guys can help. I get to the screen where i can hit f9 ,f12,etc. but my keyboard does not seem to be responding..? Maybe you can help me out, I have tried 3 different keyboards but they all have the same affect. 2 are ps2 and the other is usb. They all blink once when plugged in intially but they do not respond from there on. Some times when im at that screen and hitting f12 repeatedly it will intermittently leave the f9,f12,etc screen and just go to a black screen,other times it will just stay at the f9,f12 screen...? Im stumped,got a new hd in there and all the hardware was up and running before my previous hd crashed. Please reply to me james.deasy@yahoo.com
!