Sign in with
Sign up | Sign in
Your question

Bios update killed Ethernet!

Last response: in Networking
Share
February 15, 2006 8:35:36 PM

Hi there,
I recently updated the bios on my Gigabyte GA-K8NF-9 to f11. All went ok except that I can no longer connect to the network (2 Computers wired to Linksys router) using the onboard LAN. I have tried re-installing the drivers several times. Windows says the device is working fine, shows the following info:

Physical Address: 1B-D7-71-EA-0F-00
IP Address: 192.168.1.100
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.1.1
DHCP Server: 192.168.1.1
Lease Obtained: 15/02/2006 22:02:10
Lease Expires: 16/02/2006 22:02:10
DNS Servers: 194.168.4.100, 194.168.8.100
WINS Server:

'Connection Status' shows packets being sent but none received. Also I can not ping the other devices on the network. I have switched off the firewall (Zone Alarm) don't use the Windows one, makes no difference.

If I add a PCI card and connect using that, everthing works fine.

Does anyone have any idea what might have messed up the onboard connection?

Thanks in advance.
February 16, 2006 9:05:03 AM

Is your DNS working ? (try pinging www.microsoft.com)
Does it work in Safemode with Networking ?
February 16, 2006 4:32:25 PM

Hi there,
thanks for your reply.

Quote:
Is your DNS working ? (try pinging www.microsoft.com)
Does it work in Safemode with Networking ?


No it's not. Reports that 'Ping request could not find host'
Good idea about safe mode, I had forgotten you could do that! But sadly gets the same result :( 
Related resources
February 16, 2006 7:35:21 PM

Check your LAN connection properties->TCP/IP settings. Is it marked to auto obtain the IP address ? Otherwise make sure you have the correct information typed in. Try pointing at your router for DNS server as most of routers can forward the DNS requet to your local DNS servers.

,,
February 17, 2006 7:07:44 AM

I agree ....

Make sure your network card is set for DHCP ....

click me !
February 17, 2006 4:28:57 PM

Thanks for your help guys!

I have reverted back to the original F1 bios and now everything is working fine. Would like dual core support though so going to try F7 this weekend and see what happens! :) 
March 13, 2006 5:00:21 PM

Hi there,

I had the same problems connecting to the internet after I update my BIOS from F1 to
F11. I tried going from F1 to F2 or any other version and it's the same result.

The internet is working fine in version F1. When I did this test, all the
drivers' version are constant when using F1, F6, and F11.

But now I found the solution:

The network adapter address is reporting backwards!

This what i read on some forum from a guy that solved this so it might help you :

I finally had another go at updating from F1 to the latest F8 Bios. I had
always gone back to F1 because of the onboard LAN not working. After some
browsing I found the solution!! The network adapter address is reporting
backwards!

If you go to network adapter properties and look at your Mac address, if
your network connection is not working, go into the adapter properties ,
then configure, advanced, and in network address manually enter the Mac
address as reported but backwards and without the dashes!

And voila it works!!
March 13, 2006 5:41:31 PM

Just had a look, and you are right, it is backwards!!

Many many thanks!! Will try updating again at the weekend. :D 
March 14, 2006 7:55:36 AM

That is freaky ! 8O

Nice find :p 
!