Sign in with
Sign up | Sign in
Your question

Win2000 networking

Last response: in Windows 2000/NT
Share
Anonymous
August 8, 2001 8:31:08 PM

I tried setting up a home network between my Win2000 PC and my Win98 PC. At first it wasn't working, but I messed with the subnet masks and IPs and stuff till I got the two to recognize eachother. Now that they recognize, they still don't like eachother. I try to access files on one computer from the other, and Access is denied, apparently I don't have permission.

One of my friends says it's because Win2000 and Win98 can't be friends unless the Win9x box is connected to and validated by a Win2000 server. I don't have the money for that, and a different friend, the one who talked me through setting up the network, has Win9x and Win2k machines networked and working just fine.

Did I miss something? Can someone help me get these two PCs to be friends and live happily ever after?

More about : win2000 networking

Anonymous
August 9, 2001 12:42:44 AM

Hi,
What you need to do is create a user account on the Windows 2000 computer (right-click My Computer,Manage,expand Local Users and Groups,then right-click Users and create new user. Use the computer name and password (if any) of the Windows 98 machine. I believe that should solve your problem. Good luck...
August 9, 2001 7:09:08 PM

Also make sure that you have shares (i.e. folders, printers) on all networked machines, and you didn’t mark the shares as Read Only accidentally.
Normally folders are used as shares on a network, not the whole drives. But make the shared folder mapped as a drive on the Win2000 workstation.
Check also: the Server Service must startup on the Win2000 workstation.
Related resources
August 10, 2001 12:04:01 AM

Another work around for this is to change the user name to Administrator in win9x.

"I drank what?" -Socrates
Anonymous
August 10, 2001 2:05:39 AM

Ok, I changed the Win9x name to 'Administrator", and now the Win2000 machine can access the Win9x machine. BUT, the Win9x still can't access the Win2000 computer...

Any more suggestions would be great, thanks a bunch.
August 10, 2001 5:03:12 AM

It is not necessarily to change the user names on Win9x machines; it doesn’t have any sense to log in as Administrator for everybody.
The unique computer names, user names and passwords work just perfect on a network. From Win2000 computer you log in as Administrator to make changes on your network.
I assume that you looked through your TCP/IP, users on Win2000 very attentively, and what already have been posted, and the shares as it were suggested to you.

Can you ensure that in your peer-to-peer network both computers belong to the same Workgroup? Not to Domain? And TCP/IP is taken. Let’s check together.

A - From DOS prompt on each computer can you implement PING xxx.yyy.zzz.nnn command?
The xxx.yyy.zzz.nnn is the IP address for your computer, try both.

B - On Win2000 computer:
1 - Double click on [Entire Network] > [Microsoft Windows Network].
Can you see your Workgroup there? Now right click on your Workgroup, read Properties.
There must be Type: "Microsoft Windows Network".
2 - Double click on your Workgroup icon now. You must see both your computers there.
Right click on your Computer icons once in a time. You can read different computer names but the same workgroup there.
3 - Now, double click on computer icons one by one. Can you see the shares for each computer? Can you copy and paste the files?

C - On Win98 computer:

1 - Double click on [Network Neighborhood] > [Entire Network]
Can you see the same your Workgroup there?
And inside the Workgroup, can you see your both computers there?
2 - Can you repeat on them the same procedures that you’ve done on Win2000 machine?

For example, on Win98 right click: > Properties > Net Watcher
(do you have Net Watcher installed? From Control Panel > Add/Remove Programs > Windows Setup.)

Anyway, you don’t see the users there, but you see the shares for Win98.
And it’s OK for Win98 machine on this type of network.

3 - Now right click on Win2000, > Properties.
You must see the computer name, and that Win2000 machine belongs to the same Workgroup.
And it’s also good.

4 - Can you double click on either computer icon, and see the shares?
Can you do copy files?

5- If not, where do you actually start to see the problem? And what’s the exact Error message?

Feel free to ask more questions. We can go through you network further.
August 10, 2001 12:22:22 PM

Probably an easy way around it is to enable the guest account on the 2k machine.


Next time you wave - use all your fingers
August 10, 2001 2:43:29 PM

Yes, if you didn't assign any user, the Guest would help. But it might create another problem because the Guest is pretty powerless group with minimal access to the system. From tyl0r's posts I see that there're already enough limitations with the access there, but the computers can see each other.
Don't forget that a Win2000 workstation works as a server in a Workgroup on a peer-to-peer network with a Win9x machine. So, you want to gain access on a share level from the Win9x workstation, you must provide enough rights.

But I don't see a problem with the Guest here. It works just fine with disabled Guest.

Just trying to guess from what’ve been posted, where you’re having the problem.

Check on <b>Win2000 workstation</b>:

Start > Programs > [Administrative Tools] > [Computer Management] > [Local Users and Groups] > Users.

Must be there for your Win98 workstation:
[Win98 User Name] , [Full Name] , Description : [Windows 98 Workstation].

In Properties for that [Win98 User Name] check:
User cannot change password. Password never expired. (it’s for initial stage, until you establish your network, later you can put whatever you can.)

You can leave Member of Users, (or add Power User, whatever, up to you)
By the way, as a User (or Power User) you are able to exchange files from both machines, even rename folders, files from Win98 machine on Win2000 machine. As you see, you don’t need to rename your Win98 machine to gain access over Win2000 machine. You are free to delegate different rights to Win98 workstation user, if you want.
Don't make more complicated, don't assign the Guest.

OK, if you don’t have theWin98 user’s name, do as rlj505 already suggested: [Action] > [Add user] and fill out the fields.

Sure, Win2000 workstation can live without that, but don't hesitate to restart the systems after changes.
!