Sign in with
Sign up | Sign in
Your question

Sapphire x1950xt woes.

Last response: in Graphics & Displays
Share
November 16, 2006 3:56:34 PM

Does anyone in this forum happen to have this card??

I just installed it last night and have had nothing but problems since. Here they are: The drivers off the ATI/AMD site won't install.- I get a "INF error. video driver not found".
My games won't run/launch anymore.(FEAR, NWN2) (HL2:Lost Coast will run)
And the big one - The card info says the vpu clock is at 500Mhz, and the memory is at 594Mhz!!! WTF!!

I've tried using ATItool but it won't recognize the card...maybe I have an old version of the tool - I'll check that later.

When I go into the ATI control centre/overdrive, my options to overclock are limited to the specs of the card. For example it says the memory is currently at 594, and on the slider it only goes up to 900 which I thought is what it should be running at now!

I upgraded from a Sapphire x800xl Hybrid, so I have no experience with the x1xx series of cards... TheGreatGrapeApe told me to get the 1950pro...should've listened. damn it. :oops: 

And lastly, I've gone to the ATI knowledgebase and found some drivers I thought might fix the problem, but they didn't work(sample_8-203-3-060104a-029367E.exe). The Sapphire site hasn't been to helpful either. I'm in pickle here... 8O

More about : sapphire x1950xt woes

November 16, 2006 4:50:19 PM

Install the drivers from CD first. Did you do that? Then I would download latest (6.11), and then install them

The clock speeds you are seeing in Catalyst are 2d speeds. They will go to the rated speed when in a 3D application.

Also, memory is Double Data Rate, or DDR. Therefore the memory is showing at 594MHz, which is about 1200MHz effective.

Don't worry, clock speeds are fine. :wink:
November 16, 2006 5:41:37 PM

Thanks for the info about the clock speeds! I was freakin' out. :o 

In regards to the drivers: First I tried to use the 6.11's -didn't work.

Then I uninstalled the 6.11's and installed the drivers from the CD - worked great. But I still can't install the 6.11's now.

When installing either v6.10 or 6.11, a dialog box pops up with the title: Thunk.exe and the message says "INF error. Video driver missing" or something to that effect. I've never had this issue with an ATI based video card before.

So I'm assuming this driver issue is why my games won't launch, but I can't fix it. Very strange.

I'm going to assume that the sapphire drivers for the x1950XTX should work for this card? maybe I'll try them later...

I did find this on the ATI site: "This display driver is not compatible with the display adapter(s) installed in your system" or "Severe! INF Error. Video Driver Not Found"

This error occurs when the automatic installer fails to recognize the ATI graphics adapter installed in the system.


I'm not sure if it's your timely advice or the fact that your alias is "prozac", but I feel much calmer now.. Thanks dude. :lol: 
Related resources
November 16, 2006 6:31:42 PM

Use driver cleaner pro, uninstall any previous driver that is ati or nvidia or both if you were using an nvidia card.

Good luck
November 16, 2006 7:16:31 PM

Please post back if you get it running, I just bought that card today & am very curious.

I dont think it is because of your drivers, like the previous poster said, use a driver cleaner.
November 16, 2006 7:51:42 PM

If the X1950XT is anything like the X1950Pro when it came out, there's going to be no initial driver support except for the hacked drivers that come with the CD.

You may see support in a later release but not for now. If you really want the 6.11s, you can try letting the installer unpack into that C:\ATI\...

After the installer dies from not seeing the video card, go to the Device manager and replace the drivers with the drivers in the unpacked directory directly. It will probably be the "Radeon X1950 Series" and "Radeon X1950 Series Secondary" that should work. Since they're probably made for the X1950XTX, it's probably close enough to work.

Of course, you may want to keep a System Restore in case this kills your drivers.
November 17, 2006 3:03:30 PM

Good day.

Today, Sapphire has their version of the new 6.11 drivers available. So I used driver cleaner pro as suggested and then installed these new drivers.... I got the same error, and have reverted back to the drivers that shipped with the card.

I would like to post this bit of info though: The Sapphire x1950xt is "certified" by ATI, which according to their site means you get support directly from ATI (http://ati.amd.com/products/certified/index.html) and can use their drivers etc. This is the only saving grace with this card because I'm hoping ATI will be able to fix the problems faster than Sapphire.

On a plus side, I did play HL2: Episode One last night, and it looks amazing with all the settings maxed!! Game play was very smooth at 1280 X 960.

a123456: I tried your suggestion, but the .inf file must be wrong because I still couldn't manually install the driver.
November 17, 2006 3:09:16 PM

In that case, I guess it's either wait or edit the INF file yourself. What happened when you tried it? If you do the "Have Disk" thing and turn off the "Show only compatible things," it should bring up a gigantic list of every series that ATI has released.

I just poked inside the INF file (C:\ATI\SUPPORT\6-11_xp-2k_dd_37616\2KXP_INF\CX_38529.inf assuming you have XP). There are a couple lines that look like
"Radeon X1950 Series" = ati2mtag_R580, PCI\VEN_1002&DEV_7240
"Radeon X1950 Series " = ati2mtag_R580, PCI\VEN_1002&DEV_7248
"Radeon X1950 Series Secondary" = ati2mtag_R580, PCI\VEN_1002&DEV_7260
"Radeon X1950 Series Secondary " = ati2mtag_R580, PCI\VEN_1002&DEV_7268

One of those is the set that you want. It's there and should force install fine.

The drivers on the Sapphire site look identical to the ones on the AMD site, so I don't think it's anything real, just a fuzzy link for convenience.
November 17, 2006 3:26:24 PM

I'm using Win XP 64bit, and there isn't a "have disk" option, but there is something similar that lets you choose the location of the driver. Anyway, like I said before it doesn't see the card. :evil: 

So I'll just have to wait for ATI to fix the problem. In the mean time, I'm at the mercy of this card as to what games I can play!! :roll:
November 17, 2006 3:46:56 PM

Quote:
I'm using Win XP 64bit


...

Go back to win xp pro....save yourself the hassle...and just wait for 64bit compatable vista.
November 17, 2006 4:04:26 PM

Quote:
I'm using Win XP 64bit


...

Go back to win xp pro....save yourself the hassle...and just wait for 64bit compatable vista.

Thought about it, but no. The O/S seems way faster than 32 bit. Why would 64 bit compatible Vista be any better than 64 bit XP?!? It's not like in two months a boat load of 64 bit apps are going to magically show up. I can't see a lot of people moving to 64 bit computing until it's much more mature... but this is a discussion for another thread...
November 17, 2006 5:32:49 PM

Oh, you're using x64. I don't think there are any supported drivers for that yet. Not sure what to tell you except wait. Sorry.

I had similar issues with x64 and just decided to forget it even though I was giving up the advantages (including the extra RAM space and 64-bit processor) because too much software was dying in x64 versus normal XP Pro. *shrug*
November 21, 2006 3:20:29 PM

I just thought I'd post an update:

After installing and uninstalling the v6.11 drivers and using driver cleaner pro about a dozen times, I've settled on using the drivers off the CD that came with the card(v6.10). I created a trouble ticket with ATI about the 6.11 drivers, and am still waiting. For the time being I just have to wait until the 6.12s are available.

I did get F.E.A.R and NWN2 to run and the performance of the card is amazing! And the fan isn't any louder than my case fans(2 X 120mm)...or I just haven't stressed the card enough. So after all my initial problems, I'm liking this card now! :D 
November 25, 2006 1:24:51 AM

After doing some research on the net, it seems that the Sapphire x1950xt is not yet supported by the official ATi drivers.

Over at driverheaven pretty much every x1950xt user is experiencing this problem.

The cause is the digital signature on the card is not what ATi assumed it to be.

The line that says
"Radeon X1950 Series" = ati2mtag_R580, PCI\VEN_1002&DEV_7240
"Radeon X1950 Series " = ati2mtag_R580, PCI\VEN_1002&DEV_7248 "
is wrong, and instead the card is named Radeon x1950 (small x).

Changing the line in the inf or ini does not fix it - because while installing the drivers the executable is unable to detect that you have a vga capable graphics card installed (or something along those lines) and asks you to install the VGA drivers first.

The only solution right now is to wait for either Sapphire to release a fix which flashes the Sapphire to the proper hardware name or for ATi to 'hack' a new line into the infs for the next catalyst recognizing that Sapphire x1950 (with small x) is indeed a valid ATi card.

Catalyst drivers suffered the same fate, as they used a copy paste of the .11 inf, but their creator said he will have a solution up soon.

After having this card for a week now, I must say with the 6.10 Cats that came with the CD, the performance of the card for its price is truly amazing. 1600x1200 supreme commander with everything maxed ran average of 78 fps on benchmark, and get this, 165 average fps @ 1240 x 980 (lcd) in Company of Heroes. 6912 3dmark06

Here is the Cats 6.12 beta: http://drivers.softpedia.com/get/GRAPHICS-BOARD/ATI/ATI...

From this thread: http://www.driverheaven.net/showthread.php?t=123709

Edit: Here's a 2nd mirror just incase http://www.station-drivers.com/page/ati%20catalyst.htm
November 25, 2006 2:58:08 AM

Thanks for the info.. I agree with you about the performance of the card. Very much worth the extra $ compared to the x1950pro.

I think I'll wait until the official 6.12's are release rather than use those beta drivers though..
December 7, 2006 12:14:56 PM

theres fixed catalyst 6.11 drivers knocking around google them.
December 8, 2006 1:02:35 PM

Maybe i should chime in on this....

i just purchased the sapphire 1950XT, works like a charm..... I have windows XP PRO and yet to have a problem with the card/drivers.....
August 11, 2007 2:27:13 PM

The 1950xt mem clock speed is supposed to be 1800Mhz

I Have just installed mine with latest ati drivers and have noticed the 500 core and 594 mem.

Does this mean that the latest ati drivers are useless still.

Thanks
!