Sign in with
Sign up | Sign in
Your question

DirectX9 Games cause complete crash

Last response: in Windows 7
Share
June 14, 2011 5:04:12 AM

Hello, and thanks in advance for any help you may be able to offer.

I've recently been having an issue with any game that runs with DirectX9; I get a system crash with an error message that reads somewhat along the lines of:
"Error: [character string] has referenced memory at location [character string] that no longer exists. Press OK to terminate the program." (I would have the actual character strings for you, but I don't get enough time between when the error appears, and when my computer crashes, to write them down.)
At first I wasn't sure what was causing the issue, as the error message didn't always pop up. Because of that, I thought it was an overheating problem, despite my computer never reaching what seemed to be overly high temperatures, based on external temperatures. Even so, I downloaded SpeedFan, and I've found that it runs at around 50ºC, which is by no means excessively hot for a stock heat sink.

Next, being that the error message made mention of a memory issue, I figured that it was a problem with my RAM. Having gone through the motions with tech support, it was determined that my RAM worked fine.

Finally, it was when I switched from DirectX9 to DirectX7 (Mount & Blade: Warband, thankfully, had an option to switch; that's what let me figure out the root of this issue), I had no more crashed from that game. However, any other game that uses DirectX9 (Vindictus, Magicka, and, most recently, Duke Nukem Forever (which depresses me to no end)) cause the same crash.

I've tried running the DirectX End-user download, and it informs me that all my drivers are up to date and, therefore, have no reason to be altered. I've rolled back to the August '09 release of DX9 on the advice of a friend, and it has not fixed this issue.

Another forum suggested that it may be a Catalyst issue, but attempting to update caused my screen to turn a washed-out blue color, reset my resolution to 800x600, and set my maximum resolution to 1400x1050 (down from 1920x1080). That is, after causing a BSOD.

I'm at the end of my patience with this issue, and I'd really like to avoid sending my computer in, as I live in a rural area, so I'd be without for a good 3-4 weeks.

I'll list the specs from my dxdiag report below.

I'll admit up front that I'm not extremely adept at computers. I know enough to fix many crashes, and avert some small disasters, but nothing like this.

--System Information:
Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601)
Language: English
System Manufacturer: ASUSTeK Computer Inc.
System Model: G73Jh
BIOS: BIOS Date: 10/30/09 15:13:23 Ver: 08.00.10
Processor: Intel Core i7 CPU Q 720 @ 1.60 GHz (8 CPUs), ~1.6GHz
Memory: 8192MB RAM
Page file: 2711MB used, 13519MB available
DirectX Version: DirectX 11


--Display:

-Device:
Name: ATI Mobility Radeon HD 5870
Manufacturer: ATI Technologies, Inc.
Chip Type: ATI display adapter (0x68A0)
DAC Type: Internal DAC(400MHz)
Approx. Total Memory: 4079 MB
Current Display Mode: 1920x1080 (32 bit) (60Hz)
Monitor: Generic PnP Monitor [built-in display]

-Drivers:
Main Driver: atiumd64.dll,atidxx64.dll,atidxx64.dll
Version: 8.683.0.0
Date: 12/17/2009 4:50:55 AM
WHQL Logo'd: Yes
DDI Version: 11
Driver Model: WDDM 1.1
-DirectX Features:
DirectDraw Acceleration: Enabled
Direct3D Acceleration: Enabled
AGP Texture Acceleration: Enabled

Notes: No problems found.
June 14, 2011 5:24:43 AM

Unfortunately, that did not resolve the issue. Thanks anyways.
m
0
l
June 14, 2011 11:13:25 PM

New developments: I've now experienced a BSOD and a complete hardlock (completely frozen and unresponsive, last second of sound playing repeatedly) in the last hour.
m
0
l
!