Sign in with
Sign up | Sign in
Your question

Can't install Catalyst drivers

Last response: in Graphics & Displays
Share
November 17, 2006 6:36:42 PM

Let me start off by saying the problem is almost certainly not with the ATI drivers or install package. I say that because, after failing miserably to get the 6.11 drivers installed despite following the instructions to the "T" and scrubbing the registry and disk, I couldn't reinstall the 6.10 drivers either. I had no trouble installing 6.10 a month ago. Also, last night my attempt to update network drivers also crashed and burned, leaving without net access until I did a lot of hand-jamming of driver files. Last time this happened to me, the culprit turned out to be a Micro$oft security update.

Anyway, the details: uninstalled 6.10 per ATI directions, rebooted, removed leftover ATI registry entries and disk files, and rebooted again. Ran the full Catalyst suite setup program (express install), and after much activity the installer stopped with the message along the lines of "Severe: Setup cannot complete the installation. Try installing a standard VGA driver and attempt the installation again". Tried cleaning up again and reinstalling, tried reinstalling 6.10, no joy. I've got this great X1900XTX idling while I'm running with the VGA drivers of last resort. Any ideas? Windows Defender is installed but turned off, freeware AOL antivirus is turned off, security patches are all up to date. Thanks!
November 17, 2006 8:13:06 PM

Im thinking sys restore also,sounds like vga errors or corruption from windows.You can also try reinstalling windows apps as needed
November 17, 2006 8:52:58 PM

Let's see --- latest .net is installed (2.0, with two security updates). No luck installing from the original CD or installing the drivers only. Backed out all M$ updates from October and November. Still can't install. Maybe the old Nvidia drivers didn't like being uninstalled and exacted revenge on their way out...
Related resources
November 17, 2006 9:31:22 PM

aha... make sure alll of your nvidia files are out,read this can be a major prob...somehow didnt know/read that on your post.Likely suspect
November 18, 2006 2:17:47 PM

I went back to a 2-day old system restore point and order was restored. Obviously I still don't know what the problem was, but it was triggered by one of three events:

1) a failed LAN driver update. Installation went normally but after reboot I had no net access. For those with GA-965P-DQ6 motherboards, it was the 2006/10/18 Marvell LAN driver

2) A botched Windows Update. I allowed Windows Update to upgrade Intellitype/Intellipoint for my wireless mouse/keyboard and it failed with an unknown error. I don't think Windows Update has ever successfully upgraded a device driver for me, but I had high hopes because it was updating Microsoft HW

3) The uninstall of the Catalyst 6.10 drivers. After returning to the restore point and running the ATI uninstaller to get rid of 6.10, the only thing that was uninstalled was ATI Tray Tools. This leads me to believe that the original uninstall failed at this point

Anyway, 6.11 is up and running. Only difference I've seen so far is a 100 point 3DMark06 improvement. Thanks to everyone for their help!
!