Sign in with
Sign up | Sign in
Your question

Switching back to English?

Tags:
  • Website Opinions
  • Chrome
  • Tom's Hardware
  • Macintosh
Last response: in Site Feedback
Share
March 11, 2010 12:24:00 AM

I started use Mac Chrome and mistakenly hit the "German" button when I first browsed to Tom's. Now for the life of me I can't get it back to English. I pressed the "My Tom's Hardware" link on upper left and choose "US English" but it still went back to www.tomshardware.de --- ditto when I click the US flag in upper right. I can manually type in www.tomshardware.com/us/ but if I do tomshardware.com it shift back to the .de site. IMMENSELY ANNOYING!!!

More about : switching back english

March 11, 2010 12:31:43 AM

Did you try just clicking the US flag in the top right? If that doesn't work, delete your cookies and it will allow you to set it up right.
!