Sign in with
Sign up | Sign in
Your question

Power Up......stumped.

Last response: in Systems
Share
November 20, 2006 4:17:45 PM

- Thermaltake Armor Case
- Thermaltake ToughPower 750W ATX PSU + PFC/EPS
- Intel Core2Duo Extreme X6800 2.93Ghz 4M 1066FSB
- Intel D975XBXLKR Socket 775 Motherboard
- (2) Seagate 320GB Serial ATA HD 7200/16MB/SATA-3G
- (2) Seagate 250GB Serial ATA w/NCQ 7200/16MB/SATA-3G
- ATI Radeon X1950XTX 512MB GDDR4 PCI Express x16 CrossFire Video
- Corsair TWINX 2048MB PC5400 DDR2 667MHz (2x1024)
- Plextor PX-716AL Slot-Loading 16x DVD Burner
- Lite-on Black 52xCDRW/16x DVD Combo Drive
- SAMSUNG 244t-BK Black 24" 6ms (GTG) Widescreen LCD Monitor

Well I hooked up the monitor this morning to the ATI DVI port and turned the system on for the first time. No beeps, smoke or noises, but I could not get anything on the screen......no bios? Help!!!

More about : power stumped

November 20, 2006 6:12:21 PM

Is your power strip on, Power Supply switched to the - toggle? Double check your power connectors to the motherboard and make sure they are going the right way. Make sure your ATX connector is seated tightly.

Are you getting any lights at all turned on? Sometimes if the mobo is getting power at all LED's will be on showing you. If those aren't on then its some connection from your power supply to the mobo, or power supply to the wall. Double check your power cord also, make sure its not bent or split or anything.

Just a few idears.
November 20, 2006 6:21:17 PM

Sorry, should have been more clear.

Everything seems to powerup, fans running, lights on, no warning beeps, nothing seems wrong on turn on.....

But the keyboard I am trying to use is the logitech g15, which needs the software installed before the keyboard is hooked up.

My monitor is okay as when I disconnect the dvi cord from the ati card the display shows that the signal is missing. When I reconnect the dvi cable the monitor light blinks green in 1 sec intervals which signals powersave mode. That is why I feel the issue is the keyboard not begin installed correctly.
Related resources
November 23, 2006 12:38:01 AM

My system is almost identical - 4 gig ram and 4 500 gig drives... another difference is that I just installed a second video card - The system initially booted ok, Windows said it found new hardware and installed something (pisses me of that it doesn't say what) and then on the next boot, I get no beeps, no video - disk-light hits once and from there complete failure - I pulled the memory and got the normal 3 beeps so I'm sure the system is basically OK- I just installed the new catalyst 6.11 'suite' before I started my update to crossfire.

I now think I am dying while initializing video (possibly caught in an endless loop) - possibly the new 'suite' updated the 1950xtx to support the new interface they were bragging about... DAMN.

Anyone know how to reset a 1950xtx flash? Have you had any success with this?

Joe
November 23, 2006 1:13:29 AM

The keyboard should power up as a standard usb keyboard and will work fine until you install your software, G15 is not the problem (make sure you hook it up though because you can't boot without a keyboard or mouse).

If you aren't even getting the intel start up screen (for the motherboard) then it doesn't look like you are posting, do you get the single beep for POST?

In order to POST you need motherboard, cpu, video card, one stick of ram, keyboard and mouse (monitor of course to see what you are doing). Unhook everything else and see what happens.
November 23, 2006 1:38:31 AM

Hey Waylander,

Thanks for looking...

I know exactly what he is seeing. 2 hrs ago I ran into the same problem.

I power-up, post hits the dvd (lite blinks, it is initializing/inspecting the ide interface), it hits the HD (lite blinks, it is initializing/inspecting the sata interface). Then when it should initialize the video card, it (IMO) gets into an endless loop and never returns control... No beeps and the video never comes shows a signal.

I removed memory to see if I was even running post and got the expected 3 beeps.

ATI/AMD is assignating the 975xbx MB with the new catalyst 6.11 release! I think I'm going to return both ATI cards to NewEgg and go with Nvidia...

Joe
November 24, 2006 10:25:40 PM

Here is my thread in Graphics Hardware ATI better outlining the issue and my final solution.

BOTTOM LINE - ATI has done the 'cover up' thing with their initial claim of allowing crossfire support with like x1900 cards and no dongle from the catalyst 6.11 documentation (they just give the 'duh what?' response and no assistance. They have removed all of this claim from the '6.11' release, not the 6.12 release!

Paraphrasing redshifted from my thread - " :x DAMN YOU ATI and/or AMD!!"

Oh, and bump (I'll get back to you with more info as it happens).

Joe
November 25, 2006 6:03:09 AM

small update... I have just tried two new video cards - x1300 and PCI. Both failed -

I have just ripped out my MB and am sending it back since it is also still in warranty.

DON'T USE an early version of ATI Catalyst 6.11. Probably anything with an Intel 975 express chipset will fry... My response from ATI was 'duh, what???' It is just not worth it at this time - they need to release a legitimate 6.12 release and own-up to the 6.11 screw-up...

Oh and BUMP. I will let you know more when I get more information,
Joe
December 3, 2006 2:52:08 AM

im curios
what did intel support have to say about your problem?

have you tried inserting the windows disk?

nvm if you cant see the post

i have the same mobo and i was thinking of buying ati i shudder at the thought of what could happen to my very expensive baby
December 18, 2006 8:51:23 AM

Guess I'll fit in here.

975XBX
E6600
X1900XTX
2gig Corsair Memory
2x HDD
G15
MX518

My PC was doing fine, and then, all of a sudden it would not post anymore. System starts up, fan spinning, cat clinging onto table for dear life, and the monitor won't initialize.

Fiddling around, I get it to start up, but I can't put my finger on the real fault...
!