Sign in with
Sign up | Sign in
Your question
Closed

Reboot and select proper boot device error

Last response: in Windows 7
Share
April 11, 2009 8:21:32 PM

Hello all,

I have a strange problem and wondering if anyone could help. I recently began to install Win7 x64 on a PC, it began the installation ok, I formatted the only drive on the PC during install and the install reached 39%.

When no progress was made for approximately 3 hours, I decided to eject the DVD. Windows gave an error, and wouldn't resume even when I put the DVD back in the drive.

When the PC reboot and I attempted to install again, my Blu-Ray drive just kept making strange sounds. The DVD would no longer read, so I decided to try another drive (other CDs wouldn't boot either).

I tried another drive, with Win7 x64 in the drive and kept getting the error "Reboot and Select proper Boot device or Insert Boot Media in Reboot and Select proper Boot device or Insert Boot Media in". I now tried another bootable OS and worked fine, the CD booted and recognised the connected hard drive (although blank).

I've tried re-burning Win7 3 times now and nothing, when I insert the DVD into another PC, the setup program begins, but constantly getting the error above with Win7 x64. I've tried wiping the hard drive again, burnt Win7 at 1x just in case, but I just can't understand what the problem is.

I'm not left with a PC that will install other operating systems, but a Blu-Ray/DVD Rom which doesn't want to read disks, and 3 Win7 coasters. Any suggestions?

Thanks
Daint
a b $ Windows 7
April 11, 2009 8:47:56 PM

Try a different drive other then the Bluray, or make sure the bios sees the BLu ray as the 1st boot device, and hard drive as the second. Sounds like your booting to the hard drive 1st, hence the error you get.
April 11, 2009 9:00:40 PM

Thanks for the quick reply.

I've removed the Blu-Ray drive for now as the strange noises it was making and the fact that it wouldn't read any DVDs, I suspect it's broken somehow.

The DVD drive I've temporarily put into the PC boots other OS DVDs, just not Win7 x64, it's also set as the 1st boot device, HD second, and the third is disabled.

I can't understand how the error seems to relate to hardware, yet the hardware works fine with another OS. Interestingly, one of the alternative OS's that works fine is Win7 x86 version.
Related resources
a b $ Windows 7
April 11, 2009 9:03:35 PM

Make sure your ports are in ide mode and not achi or raid, then grab a different W7 image and make a new disk, its possible the image you got is bad.
April 11, 2009 9:04:42 PM

I think my next step would be to re-download Win 7 and see if perhaps your copy is somehow corrupted. I'm assuming you're using a Beta download of Win 7 since you're talking about burning it.
April 11, 2009 9:07:58 PM

Well to add more complication, I know the download is ok as I've tried it on a laptop before I began to install it on my main PC, all worked fine.

I'll try the IDE/ACHI suggestion first, and then re-download if that's no good. Thanks
a b $ Windows 7
April 11, 2009 9:19:07 PM

Are all the other OS's on the same media? Some media is plain junk and just dont work.
April 11, 2009 9:25:10 PM

The Win7 x86 is the same media, yes. The other CD was a XP original which was fine.

I've checked the BIOS, and it's already set to IDE rather than ACHI, I've also tried loading default settings in the BIOS, but still nothing.

I'm currently downloading another copy of Win7 now.

Daint
April 11, 2009 9:33:58 PM

I'm not sure whether it has any relevance, but I've just tried removing the HD and boot via DVD.

The machine follows a similar pattern and time between messages, although the message now reads "CDBOOT: Couldn't find BOOTMGR". According to other forums, that error message seems to relate to a possible drive / motherboard conflict.
April 11, 2009 10:31:41 PM

Hello again,

I've downloaded a new copy and burnt, I'm now consistently getting the error message

"CDBOOT: Couldn't find BOOTMGR

BOOTMGR is missing"

I tried something else, I attempted to boot initially from the x86 version of Win7, then swap discs for the x64 version once the wizards show. This caused the disc to read for around 5 minutes, then a prompt for device drivers came up.

I can only assume the x64 version of Win7 doesn't get along with either my DVD Rom or the DVD Rom / Motherboard setup (seeing as it got 39% with the Blu-Ray drive initially). I'll try to get a replacement Blu-Ray drive, and then take it from there, unless anyone else has any suggestions?

Thanks for the help you've given me so far though.

Daint
April 12, 2009 7:25:43 AM

Have you tried to load another 64 bit OS before you tried windows 7?
April 12, 2009 8:00:57 AM

Yea, I've had Windows Vista x64 on there before. I'm now putting Win7 onto an external HD to see if I can install this way, all problems seem to point to the IDE interface of the device for some reason (despite the fact that other OS's disks load)

The Blu-Ray drive I had was SATA, so I guess that would be why I didn't experience the problem before? Maybe...
April 12, 2009 8:55:40 AM

A quick update...

Installed Win7 x64 via USB HD (instructions : http://kurtsh.spaces.live.com/blog/cns!DA410C7F7E038D!1665.entry?sa=74010677 )

The CD Rom (DVD not Blu-Ray) works fine when running the OS, so I guess this is DVD / Motherboard / IDE related.

Thanks for everyones help, now just to return a faulty Blu-Ray drive...

Thanks again
Daint
!