Sign in with
Sign up | Sign in
Your question

Wireless Internet Gaming - Problems

Last response: in Wireless Networking
Share
March 31, 2006 10:48:37 PM

Hello everybody - nice forum you have here. : )

I am in search for some advice on fixing my wireless internet connection.

Before I explain the problem I will give you some information that you may need in order to help me:

_______________________________________________

Computer Specs:

Microsoft® Windows® XP Home Edition SP2
Intel® Pentium® 4 516
Cache memory 1MB
2.93GHz
533MHz
512MB DDR
HDD size 160GB


Wireless Internet Set Up:

NETGEAR DG834G 54Mbps Wireless ADSL Modem Router:



2.4GHz
802.11g

Firmware Version 3.01.25

NETGEAR WG111 54Mbps Wireless USB 2.0 Adapter:





_______________________________________________


Ok, so now for the problem.

Problem

The wireless internet connection runs smoothly with no problems whilst browing websites and downloading files, however whilst playing an online game (for example: counterstrike) my internet suffers from sudden 'bursts of lag' roughly once every 60 seconds. These lag bursts cause the game to freeze momentarily (roughly 2 seconds, never more, never less). Apart from these lag bursts online games run very smoothly with no problems whatsoever.

I have recieved feedback from somebody who mentioned that the problem may lie within the WG111 USB Adapter - they said that USB Adapters often give these 'lag bursts'. This person suggested that I replace my USB Adapter with a wireless PCI Card - but I would like to be sure that this would solve the lagging problem before I purchase a PCI Card.

Thank you for reading, any response would be greatly appreciated. :) 

- Joe
April 1, 2006 3:59:24 PM

I've been putting some thought into wireing up my internet instead of using wireless. My parents will not allow me to run a cable through the house (upstairs to downstairs) so that is not an option.

However I was wondering if I could reverse the current setup of my internet connection, meaning having my computer upstairs wired, and the downstairs computer wireless. This would mean the router beeing upstairs in my room wired to my computer, and the USB wireless adapter connecting the computer downstairs.

My room currently has no phone sockets, etc in it at all.

What exactly do I need to do to enable my router to be upstairs in my bedroom ? (e.g. have a phone socket installed ?)
April 5, 2006 7:33:48 AM

Unfortunately, that type of lag is inherent with wireless, it just wasn't designed with gaming in mind. You need to hard-wire your PC one way or another. Without knowing your home setup more specificly I couldn't tell you where to move your router to because you probably would have to move your cable/dsl modem or whatever also if you can't run any cables. If you are on dsl, no phone jack is likely going to kill that idea.

Something that may help, however, is to make sure that if you must use the wireless - make sure your PC is the only one turned on and connected to the router (make sure your wireless network is secure so your neighbors aren't hopping on!) - sometimes they will handle a single machine better than multiple machines.

Also, make sure your signal quality is maxed, not just your signal strength. Quality > Strength.
Related resources
May 5, 2006 7:56:43 AM

well if you plan on having phone jack installed-

one alternative is buying another dsl modem and connecting it to your computer in your room
May 5, 2006 11:33:53 AM

It's OK, I have fixed it and written a tutorial for anyone with the same problem.

__

Before you start, please make sure you are using the WG111v2 54Mbps Wireless USB Adapter.

If you are unsure which it is, it looks like this:



If you are still unsure if you have v1 or v2 of the USB adapter, make sure you download the drivers for BOTH versions so that if you accidentally install the wrong one, you have the correct drivers on your PC downloaded and ready to use.

I recommend that you create a system restore point before attempting this tutorial, please also make sure that you have your WG111v2 USB installation CD in case something goes wrong.

If something does go wrong during this tutorial and you do not want to continue, use your installation disk to reinstall your WG11v2 back to how it was.

___________________________________________________________________

Before we start, you should check that you do have the exact problem this tutorial aims to fix, you can do this by:

Step One

- Click on "Start"
- Click on "Run"
- Type "cmd" and click OK
- In the black screen, type "ping -t 192.168.0.1"
- Let this test run for a minimum of THREE minutes
- After THREE minutes, press Control + C to stop the test
- Check that your results are similar to the following:

"Ping statistics for 192.168.0.1:
Packets: Sent = 194, Received = 194, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 2109ms, Average = 28ms
"

- (if next to Maximum it has a large number - like 2109 - then you DO have the problem and should follow the tutorial
- If next to Maximum it has a lower number (for instance - 15) then your connection is fine, and you should NOT follow the tutorial

If your test showed a large number by maximum, continue to step two

If your test showed a very small number by maximum, do not continue with this tutorial.


Step Two

> Go to http://kbserver.netgear.com/release_notes/D102843.asp

> Click the download link on that page or click here

> Unzip the folder

> Run the setup file in the "Utility" folder (this will prompt you to uninstall your current utility, click yes, once uninstalled run the setup file again and it will install the new utility)

> Once you have installed the utility the windows installation wizard will pop up and ask you to install it, make sure you click the option that allows you to choose which driver to install (don't let windows choose for you)

> Find the driver (the driver you need is located in the "driver" folder - click on the folder that applies to you (XP users choose XP folder, Win98 users choose Win98 folder, etc)

> Install the driver

> Windows may say "not digitally signed" etc, click "Continue Anyway"

> When asked (can't remember when) make sure you let the Netgear utility control the connection - Don't let windows control it.

Step Three

> Click on Start

> Click on Run

> Type "regedit"

> Click the + on "HKEY_LOCAL_MACHINE"

> Click the + on "SOFTWARE"

> Click the + on "Microsoft"

> Click the + on "Windows"

> Click on the "CurrentVersion" folder

> If you see an "rtwlan" key, run & delete it

> Close regedit

> NOTE: IF YOU CANNOT FIND THE RTWLAN KEY, DO NOT WORRY - SOMETIMES IT IS NOT THERE, JUST CONTINUE TO STEP FOUR

Step Four

> Press Ctrl Alt Delete to enter task manager

> End task on "RTWLAN"

> End task on "Wtlwake"

> If there are any other processes called rtwlan or wtlwake, end them

Step Five

> Click on Start

> Click on Control Panel

> Click on Administrative Tools

> Click on Services

> Scroll down the files till you find "Wireless Zero Configuration"



> Right click on "Wireless Zero Configuration" and click "Stop"

> Right click on "Wireless Zero Configuration" again and click "Properties"

> In the window that has popped up, click the drop down menu and choose "Disabled"




> Click Apply

> Click OK

Step Six

> Click Start

> Run mouse over All Programs

> Run mouse over "Startup"

> Right click on the Netgear utility file



> Click delete

> To check you have done this correctly you can go to Start>Run>"msconfig">click startup tab>check if anything like "WG111v2..." is in there, if it is NOT in there, you have done the above CORRECTLY, if it is there, please make sure you followed the above steps properly.

> NOTE: IF YOU CANNOT FIND THE NETGEAR UTILITY FILE IN THIS FOLDER, DO NOT WORRY - SOMETIMES IT IS NOT THERE - JUST CONTINUE TO STEP SEVEN

Step Seven

> Look back at STEP ONE

> Follow step one again (the ping test)

> If your results are the same as when you first took the test before this tutorial (high maximum number) then you have incorrectly followed this tutorial.

> If your results are different and have a low maximum number, like the following example, then your wireless lag problem is FIXED, congratulations.

"Ping statistics for 192.168.0.1:
Packets: Sent = 194, Received = 194, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 14ms, Average = 1ms"
April 6, 2007 4:40:24 AM

Thank you so much JoeyTee. I'm a gamer too and after asking around I was getting annoyed with the idiots who kept telling me that Wireless Connections to routers suck and bla bla bla (noobs... ). Finding this and having it work was euphoric... 5 STARS!

Btw if you ever see this, what games do you play?
April 6, 2007 4:41:27 AM

Quote:
Unfortunately, that type of lag is inherent with wireless, it just wasn't designed with gaming in mind. You need to hard-wire your PC one way or another. Without knowing your home setup more specificly I couldn't tell you where to move your router to because you probably would have to move your cable/dsl modem or whatever also if you can't run any cables. If you are on dsl, no phone jack is likely going to kill that idea.

Something that may help, however, is to make sure that if you must use the wireless - make sure your PC is the only one turned on and connected to the router (make sure your wireless network is secure so your neighbors aren't hopping on!) - sometimes they will handle a single machine better than multiple machines.

Also, make sure your signal quality is maxed, not just your signal strength. Quality > Strength.


And you're gay...
April 6, 2007 12:06:33 PM

Hey, I'm glad I could help !

I just hope other people with the same problem find this topic and it solves their problem too, I remember how frustrated I was last year when I had the lag problems.

At the moment the two main games I play are Counter Strike Source and Pro Evolution Soccer 6. How about you ?

Oh and Shocon your reply made me laugh. :lol: 
April 6, 2007 5:41:07 PM

Quote:
It's OK, I have fixed it and written a tutorial for anyone with the same problem.

__

Before you start, please make sure you are using the WG111v2 54Mbps Wireless USB Adapter.

If you are unsure which it is, it looks like this:



If you are still unsure if you have v1 or v2 of the USB adapter, make sure you download the drivers for BOTH versions so that if you accidentally install the wrong one, you have the correct drivers on your PC downloaded and ready to use.

I recommend that you create a system restore point before attempting this tutorial, please also make sure that you have your WG111v2 USB installation CD in case something goes wrong.

If something does go wrong during this tutorial and you do not want to continue, use your installation disk to reinstall your WG11v2 back to how it was.

___________________________________________________________________

Before we start, you should check that you do have the exact problem this tutorial aims to fix, you can do this by:

Step One

- Click on "Start"
- Click on "Run"
- Type "cmd" and click OK
- In the black screen, type "ping -t 192.168.0.1"
- Let this test run for a minimum of THREE minutes
- After THREE minutes, press Control + C to stop the test
- Check that your results are similar to the following:

"Ping statistics for 192.168.0.1:
Packets: Sent = 194, Received = 194, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 2109ms, Average = 28ms
"

- (if next to Maximum it has a large number - like 2109 - then you DO have the problem and should follow the tutorial
- If next to Maximum it has a lower number (for instance - 15) then your connection is fine, and you should NOT follow the tutorial

If your test showed a large number by maximum, continue to step two

If your test showed a very small number by maximum, do not continue with this tutorial.


Step Two

> Go to http://kbserver.netgear.com/release_notes/D102843.asp

> Click the download link on that page or click here

> Unzip the folder

> Run the setup file in the "Utility" folder (this will prompt you to uninstall your current utility, click yes, once uninstalled run the setup file again and it will install the new utility)

> Once you have installed the utility the windows installation wizard will pop up and ask you to install it, make sure you click the option that allows you to choose which driver to install (don't let windows choose for you)

> Find the driver (the driver you need is located in the "driver" folder - click on the folder that applies to you (XP users choose XP folder, Win98 users choose Win98 folder, etc)

> Install the driver

> Windows may say "not digitally signed" etc, click "Continue Anyway"

> When asked (can't remember when) make sure you let the Netgear utility control the connection - Don't let windows control it.

Step Three

> Click on Start

> Click on Run

> Type "regedit"

> Click the + on "HKEY_LOCAL_MACHINE"

> Click the + on "SOFTWARE"

> Click the + on "Microsoft"

> Click the + on "Windows"

> Click on the "CurrentVersion" folder

> If you see an "rtwlan" key, run & delete it

> Close regedit

> NOTE: IF YOU CANNOT FIND THE RTWLAN KEY, DO NOT WORRY - SOMETIMES IT IS NOT THERE, JUST CONTINUE TO STEP FOUR

Step Four

> Press Ctrl Alt Delete to enter task manager

> End task on "RTWLAN"

> End task on "Wtlwake"

> If there are any other processes called rtwlan or wtlwake, end them

Step Five

> Click on Start

> Click on Control Panel

> Click on Administrative Tools

> Click on Services

> Scroll down the files till you find "Wireless Zero Configuration"



> Right click on "Wireless Zero Configuration" and click "Stop"

> Right click on "Wireless Zero Configuration" again and click "Properties"

> In the window that has popped up, click the drop down menu and choose "Disabled"




> Click Apply

> Click OK

Step Six

> Click Start

> Run mouse over All Programs

> Run mouse over "Startup"

> Right click on the Netgear utility file



> Click delete

> To check you have done this correctly you can go to Start>Run>"msconfig">click startup tab>check if anything like "WG111v2..." is in there, if it is NOT in there, you have done the above CORRECTLY, if it is there, please make sure you followed the above steps properly.

> NOTE: IF YOU CANNOT FIND THE NETGEAR UTILITY FILE IN THIS FOLDER, DO NOT WORRY - SOMETIMES IT IS NOT THERE - JUST CONTINUE TO STEP SEVEN

Step Seven

> Look back at STEP ONE

> Follow step one again (the ping test)

> If your results are the same as when you first took the test before this tutorial (high maximum number) then you have incorrectly followed this tutorial.

> If your results are different and have a low maximum number, like the following example, then your wireless lag problem is FIXED, congratulations.

"Ping statistics for 192.168.0.1:
Packets: Sent = 194, Received = 194, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 14ms, Average = 1ms"


Or, for the succinct answer: If you are having problems with wireless, and you are using Windows Zero Config utility, try the vendor-supplied utility instead.

If you are having problems with wireless and you are using the vendor-supplied utility, try Windows Zero Config instead.

No need for all the high fives and insulting comments. This is well-known advice.
April 7, 2007 4:37:24 PM

Maybe so. But if it's well known advice, explain why when I seeked help on the issue, every computer help forum I could find had no fix for the problem. Also, computer stores where I seeked help had no solution either, they all just blamed anti virus software.

Mind you, I was seeking help for this a year ago, so maybe things have changed since then and many more people know the fix, but back then it certainly wasn't easy finding anyone who could help.
April 10, 2007 3:10:47 AM

Quote:
It's OK, I have fixed it and written a tutorial for anyone with the same problem.

__

...
...
..., Average = 1ms"


Or, for the succinct answer: If you are having problems with wireless, and you are using Windows Zero Config utility, try the vendor-supplied utility instead.

If you are having problems with wireless and you are using the vendor-supplied utility, try Windows Zero Config instead.

No need for all the high fives and insulting comments. This is well-known advice.

The only thing we don't need are sunshine stealing misled fools that defend those who deserve whats coming to them. If you actually read the solution, you'd see its more than just disabling Zero Config. And it has nothing to do with USING the utility in the first place. If anything it has the complete opposite to do.

And NO what you just said Iceblue was not the fix. Your well known advice is useless here. You are the weakest link. Delete.

Oh and Joey! I play CS:S too!

-III- Cpt | B Shockwave

steam name is zoele add me to steam friends! see you around. thx again! High Five lol.
April 10, 2007 3:48:18 PM

It is not my problem that you require step by step with pictures to know how to disable WZC. Grow up.
June 22, 2008 2:03:16 AM

Hi guys, sorry to respond to such an old thread - But I was having the same issue with pretty much every game I tried. I then followed the tutorial and my wireless network is now working 100%, gone are the periodic 2 second lag.

A BIG thank you for writing that tutorial, it totally worked for me :)  :sol: 
Anonymous
March 10, 2009 1:02:55 AM

Im having this problem, and i dont think this tutorial supports vista. could someone plz help me because this is really getting on my nervesthis is really getting on my nerves!
April 3, 2009 11:58:26 PM

Yes can there be a tutorial like this for vista, because im having same problem.
!